1. The latest Spigot and BungeeCord builds have been updated to include support for Minecraft versions 1.7.2, 1.7.5, 1.7.6, 1.7.7 and the newly released 1.7.8. In order to enable this support all you need to do is to update to at least Spigot build #1387 and BungeeCord build #883.
    Additionally Spigot builds #1388 and above are full builds, not just protocol updates. Please note that these builds are still in development and quite unstable, as such staying on #1387 may be beneficial. When using these builds backups are very important as 1.7.8 makes PERMANENT changes to the way player data is stored.

Change Animal Spawn Rates in a World

Discussion in 'Bugs & Feature Requests' started by Gus Callaway, Nov 26, 2012.

  1. I want to make animals very rare in my world, while keeping monsters at normal spawn rates. I looked through bukkit.yml and changed it like so...
    spawn-limits:
    monsters: 70
    animals: 1

    Yet when I start the server there are plenty of animals roaming around, way more than 1. Is there any way I can make animals rare without getting another plugin?
  2. can no one help me with this?
  3. octagami

    octagami Benefactor

    I believe there are some number of animals that are spawned as the result of chunk generation. To get rid of those in already generated chunks, you'd need to manually remove them with a command like Essentials or WorldEdit's /butcher.

    To get rid of animals in new chunks, you'd probably need a custom plugin that removed them when chunks were generated.
  4. My world is already 100% generated. No new chunks are being formed. What do you mean by a "new chunk"?
  5. octagami

    octagami Benefactor

    Even so, when the chunks were first generated they were populated with animals and stored on disk with those animals persisted with the chunk. Those animals will exist regardless of the animal spawn rate unless removed manually.
  6. I have bucthered all the animals on the world many times. I want to modify the rate at which they reappear. The problem is that they spawn too quickly, not that there are too many of them already there.
  7. octagami

    octagami Benefactor

    In that case you can try setting animals: 0 instead of 1. Like you I thought Bukkit wouldn't accept a zero value for spawn limits, but I just tested it today and a zero value does prevent mobs from spawning completely.
  8. I dont want them to stop spawning completely. In my thread I said that I want to drastically reduce their spawn rate. I want animals to be extremely rare.
  9. octagami

    octagami Benefactor

    True you did say that. Sorry. I got so caught up with testing preventing spawns completely that I lost sight of your original request.

    How large is your world? The /butcher command can only remove the animals in loaded chunks. If you are the only player on the server, loaded chunks would be a small percentage of the full world. In order to kill off all of the animals created during chunk generation, you'd need to travel around loading the chunks in different areas in the world and repeatedly use /butcher. That is probably going to be too much work. You really want a custom plugin for that purpose.

    Assuming you are able to kill off every animal in every chunk of your pre-generated world, then you would start to worry about the spawn limit setting. Setting the spawn limit to 1 means there is about 1 animal wandering around in the chunks loaded per player.

    You can also slow down the spawn rate by increasing the "animal-spawns:" value under "ticks-per:" in bukkit.yml. The default is 400 meaning if the player finds and kills that 1 animal, another will spawn somewhere within 20 seconds. Increase that setting to a much larger number, such as 72000. New animals spawns would then only be attempted once per hour.
    Last edited: Dec 15, 2012
  10. Thanks! Thats just what I was looking for.