FlyingLlama's Recent Activity

  1. FlyingLlama replied to the thread No X11 DISPLAY variable was set... HeadlessException.

    You are trying to get the 'desktop' and create some sort of GUI on a server that probably has none, what exactly did you expect?

    Sep 21, 2018 at 10:15 PM
  2. FlyingLlama rated l3st4tPlugins's post Funny in the thread Where to buy a prebuilt PC?.

    You can't, but if you buy a prebuilt, you're not likely to open it.

    Sep 21, 2018 at 9:24 PM
  3. FlyingLlama replied to the thread Package versions should be removed..

    Possibly you missed the actual discussion, since OP had a meltdown and erased it. I am not trying to be elitist, but someone who knows...

    Sep 19, 2018 at 10:53 PM
  4. FlyingLlama rated Aikar's post Agree in the thread Package versions should be removed..

    Responsible plugin developers do not circumvent the system, see: WorldEdit. If you load WorldEdit on an unsupported version, it doesn't...

    Sep 19, 2018 at 12:54 AM
  5. FlyingLlama rated Sataniel's post Funny in the thread Package versions should be removed..

    You definitely shouldn't circumvent the system, but why do you need package versions to decide whether to use NMS based code or not?

    Sep 19, 2018 at 12:54 AM
  6. FlyingLlama replied to the thread Package versions should be removed..

    Basically the only thing of importance. Bads gonna bad, messing shit up for everyone else to lower the bar for them wont help anyone....

    Sep 19, 2018 at 12:54 AM
  7. FlyingLlama replied to the thread Package versions should be removed..

    It makes it a lot harder to stupid. It sounds like you have never used NMS, so you should probably step out of this discussion. If one...

    Sep 18, 2018 at 9:24 PM
  8. FlyingLlama rated FakeSaint's post Creative in the thread Package versions should be removed..

    Yea this is the bit I just don't agree with. All it does is require developers to change NMS package names across versions... or...

    Sep 18, 2018 at 9:22 PM
  9. FlyingLlama rated Aikar's post Agree in the thread Package versions should be removed..

    Which do you think is more likely. Thousands of end users doing something stupid Plugin developer doing something stupid I covered...

    Sep 18, 2018 at 9:22 PM
  10. FlyingLlama rated Aikar's post Agree in the thread Package versions should be removed..

    While I hate that relocations breaks debugging the server (as I am a developer of the server software itself), It does have more...

    Sep 17, 2018
  11. FlyingLlama replied to the thread Package versions should be removed..

    Reflection is not bad, it is a very important and powerful tool. What is bad is accessing classes/fields with the expectation of a...

    Sep 17, 2018
  12. FlyingLlama replied to the thread Package versions should be removed..

    Bads gonna bad. Removing it wont help anyone, and it will just encourage the bads to write their bad code without reflection. A lot of...

    Sep 17, 2018