✅ TheAPI ✅ 1.7.10 - Latest 7.0

Create plugins easier than before!

  1. nastho
    nastho
    4/5,
    Version: 6.2
    [18:04:42 ERROR]: Error occurred while enabling TheAPI v5.9.7 (Is it up to date?)
    java.lang.NoSuchMethodError: me.clip.placeholderapi.PlaceholderAPIPlugin.getLocalExpansionManager()Lme/clip/placeholderapi/expansion/manager/LocalExpansionManager;
    at me.devtec.theapi.placeholderapi.PlaceholderPreRegister.register(PlaceholderPreRegister.java:45) ~[?:?]
    at me.devtec.theapi.utils.theapiutils.LoaderClass.onEnable(LoaderClass.java:429) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[server.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [server.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [server.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [server.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [server.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414) [server.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378) [server.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) [server.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) [server.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [server.jar:git-Spigot-db6de12-18fbb24]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_282]
    1. TheDevTec
      Author's Response
      Please update TheAPI to the latest version, you are using the old version.
  2. ZenoX123
    ZenoX123
    4/5,
    Version: 5.9.1
    Pretty good, but Is there a wiki? I would like to know in-depth how to use many of the sub API's in this plugin, but otherwise great plugin. I don't know how to use it though and a wiki would help a lot
    1. TheDevTec
      Author's Response
      On our discord under the section "TheAPI" in the room "examples" you will find examples of use, if something is not clear to you, just write directly to us on our discord!
      https://discord.gg/8YtfC234dA
  3. China_Eternal_
    China_Eternal_
    5/5,
    Version: 3.1.5
    It's so easy to use this plugin to develop my own plugins.
    Can I share this plugin to a biggest Chinese BBS about Minecraft.
    (https://www.mcbbs.net/forum.php)
    The download link is at SpigotMC.
    I'll translate this page and list how to use this plugin.
    Thanks:)
    1. TheDevTec
      Author's Response
      Yes, you can
  4. Drexten
    Drexten
    5/5,
    Version: 1.9.7
    Its excellent, i love this, is the best solution

    I recommend it
    1. TheDevTec
      Author's Response
      Thank you, I'm working on it every day ! :)
  5. vqid
    vqid
    5/5,
    Version: 1.6
    This is probably one of the most useful things in Spigot. It's super helpful whilst making GUIs, Invsees, Vanish, etc.

    I have a suggestion though: Maybe make a tutorial on how to use the APIs? It would help so much.
  6. Meldiron
    Meldiron
    5/5,
    Version: 1.1
    Useless for me so far but great idea.. If we (developers) sum all APIs into one big chunk which we ensure is well-coded, it will help a LOT new developers. Fully support this project ♥