【DragonProxy】 —— join ANY PC server using MCPE/MCWin10 0.3.4.3

Join any Minecraft Java Edition server using un-modded Pocket Edition OR Win10 Edition!

  1. ProMoRRom
    ProMoRRom
    5/5,
    Version: 0.3.4.3
    Perfect, I am trying to create a GTA server that can run Bedrock Edition players and Java edition players, I can create the resource pack for both platforms.

    But, I don't know if this support crackshot.
    1. DefinitlyEvil
      Author's Response
      it should, and check out my LegendGuns plugin, better than CSP
  2. ProDash
    ProDash
    4/5,
    Version: 0.3.4.3
    sup[er plugins! Please add suport to bungeecord/waterfall ............................
    1. DefinitlyEvil
      Author's Response
      This is NOT a plugin and it should be able to connect to BungeeCord servers. Please DO NOT ACT AS YOU WERE BLIND, READ THE DESCRIPTIONS.
  3. x9nico
    x9nico
    5/5,
    Version: 0.3.4.2
    Amazing project ! Nice ! :)
    ..............................................................
    1. DefinitlyEvil
  4. Matsv
    Matsv
    5/5,
    Version: 0.3.4.2
    Amazing to see this project active again. Really impressive how well it works. Great job! (:
    1. DefinitlyEvil
  5. Mudminder
    Mudminder
    5/5,
    Version: 0.3.4.2
    I love this thing! as it lets others who want to join my Java server, can.
    This works really well and has a freaken load of potential! I would really love too see the future of this concept and see where it’s headed, but it’s not like I have a time machine to do that lol. I guess I will have to wait for the future to become the present.

    Great job man keep up the good work! This can go far!
    1. DefinitlyEvil
      Author's Response
      yep and RageElixir's brand new Minecraft server will utilize our software!
  6. AleksBG1
    AleksBG1
    5/5,
    Version: 0.3.4.2
    Wooooooooooooooooooooooooooow thats amazing!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    1. DefinitlyEvil
      Author's Response
      lel thanks! pls stay tuned! ;)
  7. LogoCat
    LogoCat
    5/5,
    Version: 0.3.4.1
    Dose minecraft PE actually use UDP ? This would make the server exposed in a potential DDOS attack since the firewall could only choose refusing all UDP or forwarding them to the real server via 19132, which is very dangerous.
    1. DefinitlyEvil
      Author's Response
      even DP is being attacked, it will not harm the remote Minecraft server. and DDoS protection can save your DP server too.
  8. ScuroK
    ScuroK
    5/5,
    Version: 0.3.3.1
    This is so cool! I hope you guys will be successful! This would boost the future of spigot servers alot in the future! Wondering why Mojang isnt doing anything themself. Maybe they dont want it. But its so nice to see people like you do this for the community!
    1. DefinitlyEvil
      Author's Response
      thanks and we will release 0.3.4 soon with a bunch of updates!
  9. Whitehouse_256
    Whitehouse_256
    5/5,
    Version: 0.3.3.1
    I have known this project since its very first versions and I think this is very interesting project and I hope all parts will 100% work soon. But I cannot join to dragonproxy with minecraft win 10 edition v1.2.8 - you say dragonproxy is for 1.2.7 - why not to update to 1.2.8 as it is the newest version (I can't downgrade my win 10 edition MC)?
    1. DefinitlyEvil
      Author's Response
      maybe it's compatible with 1.2.8, just try! ;)
  10. Coen
    Coen
    5/5,
    Version: 0.3.0
    Great plugin! Would it be possible to make it have 1.8 support? 1.9 can be really glitchy
    1. DefinitlyEvil
      Author's Response
      if you can reach the server console, you can install ViaVersion on Spigot/BungeeCord 1.8.x.
  11. TekkitCommando
    TekkitCommando
    5/5,
    Version: 0.3.0
    Author and others have worked very hard. It is constantly being updated and I can't wait to see the end result.
    1. DefinitlyEvil
      Author's Response
      thanks bro
  12. smithy5057
    smithy5057
    2/5,
    Version: 0.3.0
    please help i dont understand where i want wrong setting it up

    [19:56:38] [SEVERE] Error while executing command: java.lang.ArrayIndexOutOfBoundsException: 0
    java.lang.ArrayIndexOutOfBoundsException: 0
    at org.dragonet.proxy.commands.defaults.TestCommand.execute(TestCommand.java:28)
    at org.dragonet.proxy.commands.CommandRegister.callCommand(CommandRegister.java:71)
    at org.dragonet.proxy.commands.ConsoleCommandReader$1.run(ConsoleCommandReader.java:43)
    at java.lang.Thread.run(Unknown Source)
    1. DefinitlyEvil
      Author's Response
      test command is NOT for you to use, it's a command for debugging. and as I said do no post reports here. READ STUFFS!
  13. Killer123451
    Killer123451
    5/5,
    Version: 0.2.2.1
    Amazing Job !! Really good ! I like the idea of it hope you will update it everyday new update = new feature + New version supports
    1. DefinitlyEvil
      Author's Response
      we are trying our best to do that ;) just stay tuned
  14. AsVaidas
    AsVaidas
    5/5,
    Version: 0.2.1-preR1
    Finaly someone did it! Maybe a paypal link for donation? Hope to see it working more effectivly and with the newest version!
    1. DefinitlyEvil
      Author's Response
      we don't accept for donations now but you can donate us a demo server, contact me via Discord: DefinitlyEvil#4031
  15. ItsSniper
    ItsSniper
    5/5,
    Version: 0.2.1-preR1
    I am very impressed by this. I am glad someone came up with this concept. It also seems to get updated regularly. Keep up the good work :)
    1. DefinitlyEvil
      Author's Response
      thx man i gotta keep workin hard
  16. aaa8881
    aaa8881
    5/5,
    Version: 0.2.1-preR1
    Amazing amazing resource. I've just tested, and confirmed it is actually working! Although I'll wait until this gets more stabilized and have wider compatibility, I'd love to donate some to help dev to keep this resource free and keep up the development. Thanks for great and unique resource!
    1. DefinitlyEvil
      Author's Response
      yay thanks! we are now trying to make inventory working so pls keep updated ;)
  17. RobotPlays
    RobotPlays
    5/5,
    Version: 0.2.1-preR1
    very nice resource please add 1.8.8 support, this resource are amazing!!!
    And it's free!!!
    1. DefinitlyEvil
      Author's Response
      the solution for that is, you add another BungeeCord between DragonProxy and remote server, and use ViaVersion and ViaBackward so it can translate 1.12.2 packets to previous versions.
  18. ScuroK
    ScuroK
    5/5,
    Version: 0.2.1-preR1
    Crazy awesome! Hope it will fully work in the future. Great resource. thx alot for the work you do!
    1. DefinitlyEvil
      Author's Response
      thanks for the review, we are now moved into inventory support development.
  19. ProMoRRom
    ProMoRRom
    5/5,
    Version: 0.0.2-preR1
    Great!!!!!!!!!
    It would be better if you support 1.9 version and 1.8 version, so with ViaVersion players from 1.8-1.12.2 or 1.9-1.12.2 could join, with MCPE players.
    1. DefinitlyEvil
      Author's Response
      hmmm you can use older versions for 1.8, but that only support MCPE 0.14.x
  20. ScuroK
    ScuroK
    5/5,
    Version: 0.0.2-preR1
    WOW! please keep up the good work! this is so important to have in the future!
    thanks
    1. DefinitlyEvil
      Author's Response
      thanks mate! I will fight as hard as I can. :P