[1.15] TreeGravity 4.3.1

Chop entire trees down with just one swing!

  1. [3.9.1] New lumberjack + gravity methods, new toggle command, new chopMethod, optimization+bug fix

    Dudenn
    [3.9.1] New lumberjack + gravity methods, new player by player tg toggle command, new "stand" chopMethod, general optimization, and bug fix from 3.9.0
    • Added an altered lumberjack natural method (tgType = 2.1) to have leaves break along with the logs. Since the tree detection isn't optimized, a tree touching many other leaves in a forest will recognize them all as 1 tree. You could end up breaking hundreds of trees, I tried implementing something to limit the while loop but it isn't working. Sometimes a diamond axe got broken by chopping one tree, so I made durability go down only by the amount of logs broken. I'll have to solve this later; I'd advise against using tgType 2.1 at the moment.
    • Added altered gravity methods to have all logs on the tree fall down like sand/gravel when one block is chopped. Unlike tgType 4.0, these methods should be able to differentiate a tree from a manmade structure.
      • tgType = 4.1 - When a tree is chopped, all logs on the tree spawn a falling block. This is an experimental method, be careful with it.
      • tgType = 4.2 - When a tree is chopped, all logs on the tree spawn a falling block. However, once the logs fall Metadata is added to them, so that when you go to chop the fallen logs they will act as if the normal gravity method (tgType 4.0) is on, just spawning falling blocks directly above the log you chopped. This is an experimental method, be careful with it.
    • Added a player by player option to toggle TreeGravity on and off. command is /tg toggle. If you toggle tg off, and the server is reset or you leave and rejoin the server, tg will get toggled back on so you'll have to toggle it off again.
    • Added an option to "chopMethod" where trees only fell when hit with an axe while standing, they do not fell when sneaking. (chopMethod = stand)
    • fixed bug from 3.9.0 posted a few minutes ago, caused by API-version = 1.13.2 in plugin.yml (error = unsupported API). Should be good to go now.
    **Sorry there's not more, I'll try to get more out before the end of the year. Let me know if you encounter any issues on the discussion page or on Github. Thanks!
    WeaselBeans and galacticwarrior like this.
Return to update list...