[2LS] ExploitFixer - Professional Server AntiExploit 1.2.0

Secure your server from exploits with this professional AntiExploit system for FREE.

  1. LinsaFTW
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    Source Code:
    https://github.com/2LSpigot/ExploitFixer

    INFORMATION


    This is a free BungeeCord/Spigot plugin that secures your server preventing exploits by checking packets before they are readed by the server.

    To fix BungeeCord netty exploits (OutOfBounds, DecoderException, HTTP packets, etc...) use FlameCord. (BungeeCord with 1.7+ compatibility)


    FEATURES

    · Increases your server performance.
    · Spigot and BungeeCord compatibility.
    · Notification and stats system.

    ExploitFixer protects you from the following exploits:


    · CustomPayload packets with big book data used to overload the server and lag it.
    · UUIDSpoof that is used on non-firewalled servers with bungeecord: true by connecting to a Spigot instance and forwarding a invalid UUID/Address.
    · NullAddress its a exploit used to bypass ipwhitelist by forwarding a invalid address and making it return a server error
    · Commands that some plugins have and can crash your server are blocked by ExploitFixer.
    · Items are remade by ExploitFixer to prevent invalid Hacked Creative Items. (Players with creative mode can create any kind of item by sending a packet)
    · Packets that accomplish certain conditions (ex: sending big book data) will be blocked from the server to prevent lagging your network. (ExploitFixer protects you from every packet possible sent by players)
    · Signs created by hacked clients that have extra lines to crash your server.

    Some exploits can't be blocked by only installing BungeeCord version!

    COMMANDS

    · /exploitfixer help shows the available commands of the plugin.
    · /exploitfixer reload reloads the plugin configuration.
    · /exploitfixer notifications toggles notifications for yourself.
    · /exploitfixer stats shows you some information about the plugin.


    PERMISSIONS

    · exploitfixer.admin - Permission to use administration commands.
    · exploitfixer.notifications - Permission to toggle notifications.


    INSTALLATION

    If you're running a BungeeCord Network, install the plugin in BungeeCord and all your Spigot servers.

    Remember to use FlameCord to prevent Netty Exploits.

    This plugin requires ProtocolLib installed in your Spigot servers.


    TEST SERVER

    ArkFlame Network is our official test server.
    (Please try not to bother players when testing, thanks!)


    [​IMG]

    LAST WORDS


    Please feel free to donate to help improve our development team to keep a safe server hosting experience on the community.

    Leave a positive review to help improving the development of the resource, thanks!

Recent Updates

  1. ExploitFixer - Update 1.2.0
  2. ExploitFixer - Update 1.1.9
  3. ExploitFixer - Update 1.1.8

Recent Reviews

  1. ManuGamesX
    ManuGamesX
    5/5,
    Version: 1.2.0
    Since the last 20 uptates the plugin continues with the same bug that it ocurred me, requiremets for other plugins doesn't work, even in one ocassion protocolib stop working, I remove exploit fixer and it worked again, and with auth and authmetitle happened the same, pls fix it.
  2. nikv2
    nikv2
    5/5,
    Version: 1.1.7
    Excellent plugin, One of a kind on the market and i'm glad resources like this one are getting constant updates !

    The config reset however is such a pain:( <3 Here's a suggestion.

    On each updated, If there's any changes to the config file you could add a Pastebin link on the specific update showing the new config file or the specific changes to it, So users can replace - add things manually without resetting and losing all their changes.

    Cheers!
    NikV2
    1. LinsaFTW
      Author's Response
      You can see the config changes on GitHub :)
  3. Brottweiler
    Brottweiler
    3/5,
    Version: 1.1.6
    This plugin does the job, it blocks book exploit which crashed my 1.8 server, and it's probably the biggest plugin for fixing various exploits on 1.8.
    I've had a bunch of crashes due to bugs from this plugin which lowers my rating, but they are also fixed fast which is a plus.
    1. LinsaFTW
      Author's Response
      Thanks for updating your review.
  4. TheRealDGrew
    TheRealDGrew
    5/5,
    Version: 1.1.4
    A really good solution against exploits, protects from all popular exploits flawlessly. A must-have!
    1. LinsaFTW
      Author's Response
      Thanks for the positive review! Im glad its working :)
  5. VermiumSifell
    VermiumSifell
    5/5,
    Version: 1.1.3
    Looks like it takes off overlay of skins and to fix that you need to go to options then skin options in your minecraft menu but otherwise it looks like a good plugin!
    1. LinsaFTW
      Author's Response
      Really strange... I will look on that. Probably has to do with the new version checking custompayload packets.
  6. Alpha3131
    Alpha3131
    5/5,
    Version: 1.1.3
    nice plugin. I hope you will develop the plugin further. Good luck.
    .
    1. LinsaFTW
      Author's Response
      Thanks for the positive review :)
  7. brs73
    brs73
    5/5,
    Version: 1.1.3
    ASOMBROSO :D:D:D:DD::D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D:D

    80 Caracteres
    1. LinsaFTW
      Author's Response
      Gracias por la review positiva :)
  8. 23qrn
    23qrn
    5/5,
    Version: 1.1.0
    Very very good! Thank you for this beautiful Plugin! Best on SpigotMC! But please add an check for Book Crashers!
    1. LinsaFTW
      Author's Response
      Theres already a check for book crashers. Checks are max_bytes on packets, invalid packets and CustomPayload.
  9. lokka30
    lokka30
    5/5,
    Version: 1.0.9
    I'm not sure if I had reviewed the resource already but it works brilliantly and the author frequently patches everything
    Highly recommended
    The frequent config.yml changes are slightly annoying but since there are only a few settings which I change from stock it's no issue
    1. LinsaFTW
      Author's Response
      Thanks for the positive review :) sorry for the changes...
  10. BouncePvP
    BouncePvP
    5/5,
    Version: 1.0.7
    This plugin is amazing. Helped me fix the frequent crash exploits that were going on on my server.
    1. LinsaFTW
      Author's Response
      Thank you for your positive review! :)