[ABANDONED] DimensionChanger / SkyChanger 1.5.4

If you ever wanted to change your world's sky color, here's how you can do it!

  1. Fabricio20
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    Contributors:
    codename_B, Fabricio20
    Have you ever wanted to change the sky color of your world, but don't know how and didn't found anything around the internet?
    So here's the plugin you where searching for!

    Screenshot:
    [​IMG]

    Features:
    • Easy to use! Just one command!
    • Stores info on the config file!
    • Has a shitty written webpage on spigotmc! ( see TODO )
    • Permissions support!
    How to use:
    - /dc <setworld/setplayer> <world/player> <dimension>
    Example:
    - /dc setworld Lobby -1

    Permissions:
    - Set-able in config.

    Actual Supported Dimensions By Minecraft:
    -1 = NETHER
    0 = OVERWORLD/NORMAL
    1 = THE END
    stuuuuuuarrt and MyzelYam like this.

Recent Updates

  1. 1.9 Support
  2. Java 1.7 Compatibility
  3. Re-Made

Recent Reviews

  1. elmixil17
    elmixil17
    1/5,
    Version: 1.5.4
    The plugin just ruined my hub server, don't use, you can use the Original SkyChanger plugin.
    1. Fabricio20
      Author's Response
      Hey there, thanks for the review. This plugin is abandoned and was released even before "The Original SkyChanger", it was first added to SpigotMC on 2014 and the last update was on 2016.
  2. Chimera
    Chimera
    1/5,
    Version: 1.5.4
    Installed onto my 1.11 server, shows up as working-but the command doesn't change anything. Tried turning off custom sky just in case, still nothing.
    Command says that it worked, but console says "[DimensionChanger] Unsupported Server Version Detected!"

    Please update and I'll change my review!
  3. Fargus
    Fargus
    1/5,
    Version: 1.5.4
    not work on 1.12.x ......................................................................
  4. cocoraid
    cocoraid
    3/5,
    Version: 1.5.4
    Not work with 1.9 version, it changes the full word like the nether. You should change your nms method :)
  5. KrashDozer
    KrashDozer
    5/5,
    Version: 1.5.2
    Works like it says
  6. fire__rain
    fire__rain
    5/5,
    Version: 1.5.2
    cant choose a arena to change the skycolor?
    please add
    1. Fabricio20
      Author's Response
      That would crash clients ;/
      This works just like as the player had died and respawned, so If I keep sending them these packets they WILL crash eventually ;/
  7. EpicnessServers
    EpicnessServers
    4/5,
    Version: 1.5.1
    Using both the normal 1.8 jar and the 1.8 protocol patch I get http://pastebin.com/TFRFDr10 at startup. Am I doing something wrong here? Using latest version of Spigot
    1. Fabricio20
      Author's Response
      Hahah, no, I forgot to update this plugin! I'll be fixing it ASAP.
  8. stuuuuuuarrt
    stuuuuuuarrt
    5/5,
    Version: 1.5.1
    Great plugin! Exactly what I needed :)
  9. Syam44
    Syam44
    5/5,
    Version: 1.5.1
    Excellent ! :) But use getConfig().addDefault(x, x) ! :)
    1. Fabricio20
      Author's Response
      I'm going to test this! Thanks for the review :)
  10. chas13
    chas13
    5/5,
    Version: 1.5
    nice