ActionBarAPI [1.8 - 1.12.1] 1.5.3

A easy to use API for developers to take advantage of the new Action Bar feature in Minecraft 1.8

  1. ConnorLinfoot
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    Contributors:
    ConnorLinfoot
    A easy to use API for developers to take advantage of the new Action Bar feature in Minecraft 1.8/1.9.

    Spigot 1.8/1.9/1.10
    If you are running the full Spigot/CraftBukkit 1.8.x you can use the latest version. If you are on the 1.8 protocol hack please download version 1.1 from here: http://www.spigotmc.org/resources/actionbarapi.1315/download?version=4276


    If you're a server owner:
    The ActionBarAPI may be required in a plugin which has directed you to this page, download the plugin and put it in your 'plugins' directory and boom, you're good to go!


    If you're a developer:
    The ActionBarAPI is simple and easy to use, first download and import the plugin into your project.

    You will want to import it as a dependency into your plugin.yml just so no errors occur.

    To call the API it's as simple as:
    Code (Text):
    ActionBarAPI.sendActionBar(player,"Action Bar Message");
    There are other methods such as a method to send the Action Bar for a specific amount of time (ticks, 20 = 1 second):
    Code (Text):
    ActionBarAPI.sendActionBar(player,"Action Bar Message", duration);
    There is also now an event that you can use to hook in to other plugins using ActionBarAPI & BountifulAPI. This event is called "ActionBarMessageEvent"


    GitHub Repo (Source): https://github.com/connorlinfoot/ActionBarAPI

    Note: Old versions of the plugin are no longer supported in any way.

    Please submit bugs, questions, issues and suggestions on GitHub https://github.com/ConnorLinfoot/ActionBarAPI/issues Do not PM me, I will not respond. Please check GitHub issues for solutions first and read the full information on this page..
    Infxnty, JosephGP, JustBru00 and 7 others like this.

Recent Updates

  1. Support for 1.12
  2. Improved the Updater
  3. ActionBarAPI v1.5.1

Recent Reviews

  1. ModMaster150
    ModMaster150
    5/5,
    Version: 1.5.3
    1.12 thanks :) .
  2. saahil
    saahil
    5/5,
    Version: 1.5.2
    how do u use this, i cant control what the anouncments say :):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):)
  3. Wowserman
    Wowserman
    5/5,
    Version: 1.5.2
    This really helped me out! Great API really, its really useful and its great that you submitted the source-code to help me understand it better!
  4. BaconSubPancakes
    BaconSubPancakes
    5/5,
    Version: 1.5.2
    Going to use this for making my plugin as a dependency, thank you for making this. This will help me out. :D
  5. superjay204
    superjay204
    5/5,
    Version: 1.5.2
    Cool :) !

    I't works perfectly! 9999999999999999999999999999999/10

    Im using this now :)

    - superjay204
  6. RobinMC
    RobinMC
    5/5,
    Version: 1.4.2
    Great, got it to work with my plugin in no time. You have saved me hours of doing research into making my own api. Thanks a bunch!
  7. brooky1010
    brooky1010
    5/5,
    Version: 1.3
    Very good! I'm using both (TitleAPI & ActionBarAPI) in my plugin.
    It's easy to work with and perfect for my uses. :)
  8. dbzjp
    dbzjp
    4/5,
    Version: 1.2
    When I use this, it show to me an error in the console, I have the last version and the Spigot 1.8.3 version ...
  9. boomboompower
    boomboompower
    5/5,
    Version: 1.2
  10. 4chan
    4chan
    5/5,
    Version: 1.2
    Does exactly what the title says, got it working in under a minute, no problems at all. It seems to be working flawlessly.