AntiLaby 1.8 - 1.12.2: Disable LabyMod functions! 1.11

AntiLaby 1.8 - 1.12.2: Disable LabyMod functions!

  1. Nathan_N
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    Source Code:
    https://github.com/AntiLaby/AntiLaby
    Languages Supported:
    English, German, French, own language files
    This resource will no longer be updated. Source code: https://github.com/AntiLaby/AntiLaby

    AntiLaby is a simple plugin, to disable LabyMod functions. You can enable or disable many different functions from the mod in the config file.

    antilaby_1_10_panorama.png
    AntiLaby features.png

    Set an option to true, to block this feature, set it to false, to allow it.

    You can reload the full plugin and all LabyMod blocks without rejoin with '/antilaby reload' and the permission 'antilaby.reload' or OP

    BungeeeCord Information: If you use this plugin in a BungeeCord network, put this plugin on every lobby server. If you switch the server in the network, the disabled functions will be accepted on the other servers.

    Config:
    antilaby_1_10_config.png

    LabyInfo:

    With the command /labyinfo <player> and the permission antilaby.labyinfo you can check if a player uses LabyMod.*

    JoinCommands:
    You can set join commands in the configuration file. These commands will be executed if a player with LabyMod and without the permission antilaby.bypasscommands joins your server.

    Auto-update:
    The plugin will update itself to the newest version. Newer versions can contain important bug fixes and new features. The plugin will not update to beta versions. If you want to disable this feature you can do it in the config file: 'AntiLaby.Update.AutoUpdate'. Set it to 'false' to disable.

    Permission:
    - antilaby.bypass (bypass the protection if enabled, default: OP), (suggested by @chsedv)
    - antilaby.reload (allows you to reload the config and update blocked features for every player without rejoin), (suggested by @MrJonton01)
    - antilaby.bypasscommands (allows you to bypass the join commands if you join with LabyMod)
    - antilaby.labyinfo (allows you to check if a player uses LabyMod with the command /labyinfo <player>)
    More information about the permissions

    The plugin will also create a file "info.txt" with some information about the plugin, the compatibility, and the update status.

    Installation:
    - Bukkit / Spigot: Put this plugin in your plugins folder and reload your server. To disable functions in your client you have to rejoin the server.
    - BungeeCord: Put this plugin in the plugins folder of every lobby server and reload every lobby server. To disable functions in your client you have to rejoin the server.

    Video by @SirBukkit (German) [OLD VERSION]:


    Multilingual messages:
    There is a folder named language with different language files. You can add your own as well. The player will receive the message dependent on his client language. If there is no file equals his client language he will receive the message from the 'en_us' file.

    If you like the plugin, feel free to leave a nice rating <3

    FAQ:
    Q: No functions will be disabled, what can I do?
    A: Do you have OP or the permission antilaby.bypass? Is at least one function in the config set to true?

    Q: Can I block functions from earlier LabyMod versions, too?
    A: Yes! You can block features too, wich are removed from the newest LabyMod version.

    Q: The join commands do not work.
    A: The join commands will only be executed at the join of players without OP or the permission antilaby.bypasscommands.

    Q: Error: UnsupportedClassVersionError
    A: Please try to update or reinstall Java on your server.

    Q: Is there a version for Minecraft 1.7 or earlier?
    A: No, only versions from 1.8 and above are supported. There is no LabyMod for earlier versions, so it would be useless to use AntiLaby on a server with Minecraft 1.7 or earlier.

    Downloads:
    03.09.2016: 1,000
    11.06.2017: 10,000
    07.01.2018: 15,000
    Q3 2018: 20,000
    Thank you <3

    Images

    1. pic1.png
    2. newconfig - info.png

Recent Reviews

  1. 10Meisterbaelle
    10Meisterbaelle
    3/5,
    Version: 1.11
    Ziemlich gutes Plugin, kann aber nicht mehr (sogar weniger) als die Labymod API. Es ware gut, wenn du eine Funktion hinzufügst, mit der man LabyMod Addons (wie Laby's Minimap) deaktivieren kann.
  2. Fllame66YT1
    Fllame66YT1
    5/5,
    Version: 1.11
    das plugin ist toll aber wäre gut wenn man die ADDONS ausschalten kann mind. das chatclear addon
  3. Red.stone
    Red.stone
    5/5,
    Version: 1.11
    Hey, eine Frage: Welches Feature muss ich für die Minimap aus bzw. an machen? Sonst ist das ein echt gutes Plugin ;D
    1. Nathan_N
      Author's Response
      Hey, danke für deine Bewertung. MINIMAP_RADAR muss dafür auf true stehen
  4. leTiger
    leTiger
    1/5,
    Version: 1.11
    Egal was ich in der Config eintrage es juckt das Plugin nicht
    und wenn ich /labyinfo [NAME] mache steht da "Der Spieler ... spielt nicht mit LabyMod." obwohl er mit LabyMod spielt....
  5. aendu1234
    aendu1234
    3/5,
    Version: 1.11
    Ich finde es ein gutes Plugin, doch wo finde ich im Ordner die config.yml?

    Ansonsten sehr gutes Plugin, weiter so!
  6. Skippero
    Skippero
    4/5,
    Version: 1.11
    Ich gebe dir leider nur 4 Sterne weil in der 1.8.9 komischerweise DamageIndicator nicht geblockt wird, ich weiß nicht ob es am Server oder so liegt aber wenn es funktioniert bekommst du 5 Sterne :)
  7. LaserSlimeHD
    LaserSlimeHD
    1/5,
    Version: 1.11
    In der Konsole steht, dass die Funktionen deaktiviert wurden, aber wurden sie nicht.

    Ich hab schon versucht den Spieler zu kicken, aber auch das funktionierte nicht...
    Und behebt mal bitte diese Fehlermeldung beim ersten Start!
    1. Nathan_N
      Author's Response
      Danke für deine Bewertung. Bitte sende mir eine private Nachricht mit erweiterten Informationen zu deinem Server, damit wir den Fehler beheben können. Vielen Dank.
  8. PiggiesGoSqueal
    PiggiesGoSqueal
    5/5,
    Version: 1.11
    Some console errors on Spigot 1.12.2 when starting plugin for the first time. But not really a big issue as long as it doesn't do that each time. Thanks for this awesome & useful plugin!

    ==================
    Seems to work on 1.12.2
    but I haven't actually
    tested with mod
    ==================
    1. Nathan_N
      Author's Response
      Thank you for your nice review!
      The console errors on the first start are already known and will be fixed in the next update.
  9. TheGamer7500
    TheGamer7500
    4/5,
    Version: 1.11
    Ein echt nützliches Plugin um die Hacks (Ja ich spreche hier von hacks) ein für alle mal auszuschalten. Die Funktion mit dem Kick finde ich echt super! Warum gebe ich dann nicht 5 Sterne? Wegen 4 Dingen.

    1. Es wäre cool wenn es möglich wäre die Spieler temporär zu bannen (Mein Serverteam ist fest davon überzeugt, dass Labymod ien hack ist)

    2. Die Spieler beim Join, Befehle ausführen zu lassen, oder eine Chat-nachricht zu hinterlassen.

    3. Einige Spieler sagten mal, dass sie durch Zufall mal mit Labymod joinen konnten, was ich aber für ein sehr mysteriöses Gerücht halte.

    4. Wenn ein Spieler mit Labymod joint und dann automatisch gekickt wird, könnten die Operatoren ja eine Chat-nachricht von wegen, "<Spieler> hat versucht mit labymod zu spielen" oder sowaserhalten ...

    Aber ansonsten ein echt hilfreiches Addon für jeden Server! Good job man! :)
    1. Nathan_N
      Author's Response
      Vielen Dank für die konstruktive Bewertung!
      Zu den angesprochenen Punkten:

      1. Das ist mit den JoinCommands möglich. Beispiel: "ban %PLAYER% Hacks/LabyMod" oder den Befehl von eurem Ban-Plug-in
      2. Meinst du die JoinCommands?
      3. Das können wir nicht reproduzieren oder bestätigen.
      4. Das geht auch mit den JoinCommands, z. B. mit /msg oder /tellraw. Möglicherweise bauen wir auch noch eine einfachere Funktion ein. Vielen Dank für den Vorschlag!

      Wir hoffen, dass wir dir helfen konnten :)
  10. Luligabi
    Luligabi
    4/5,
    Version: 1.11
    Very useful,but being able to make a custom kick message and multilanguage support would be apreciated.Waiting for this in a upcoming update ;)
    1. Nathan_N
      Author's Response
      Thank you for your review.
      Your mentioned features are already implemented! You can find those settings in the folder 'AntiLaby/language'.