AntiPluginSpy 2.0

Prevent your server plugin being spy

  1. Peace2016
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    My Plugins
    CombatTag, Reputation, CommandSpy, GroupWorldChat, AntiPluginSpy, SafetyGuard

    Description
    Prevent your server plugin being spy. This plugin working with Java 8.

    SoftDepend Plugin
    Essentials

    Feautures
    • Colon command block (example: bukkit[:]pl)
    • Essentials integration, If not essentials help than will block /help command.
    • Three bypass AntiPluginSpy type - [none, perm, whitelist]
    • Prevent below commands to be used or using <tab> to spy:
      • /pl
      • /plugins
      • /bukkit[:]plugins
      • /bukkit[:]pl
      • /?
      • /bukkit:help
      • /bukkit:?
      • /version
      • /bukkit:version
      • /canihasbukkit
      • and other customizable at config.yml
    • Prevent MC 1.13 version command complete feautures
    • Prevent /<tab>
    • Log player that trying to spy
    • Bypass permission editable
    • Fakeplugin Feautures
    • 95% message editable
    How to use
    1. Download this plugin.
    2. Download SoftDepend plugin
    3. Put this plugin and Softdepend plugin into your plugin folder.
    4. Reload or restart your server.
    5. Configuration your file.
    Commands & Permission
    • /antipluginspy
      • Description: Display plugin help
      • Aliases: [aps]
      • Permission: antipluginspy help / OP
    • /antipluginspy reload
      • Description: Reload AntiPluginSpy plugin
      • Aliases: [aps reload]
      • Permission: antipluginspy.admin / OP
    • /antipluginspy info
      • Description: Get plugin info
      • Aliases: [aps info]
      • Permission: antipluginspy.admin / OP
    • antipluginspy.bypass
      • Description: Bypass antipluginspy
      • Editable: true
    Configuration
    ######################################
    # Options #
    ######################################
    #ColonCMDBlock: Cancel Colon inside command example essentials:warp.
    ColonCMDBlock: true
    #UpdateChecker: Check for update
    UpdateChecker: true
    ######################################
    # AntiPluginSpy Options #
    ######################################
    #FakePlugin: It not blocking player to spy plugin but giving fake plugin list to player. It working with /pl,/plugins commands.
    FakePlugin: false
    #CommandBlackList: Command to block for use.
    AntiPluginSpy:
    CommandBlacklist:
    - '/abcaacc'
    #CommandComplete: Disabled command listed in 1.13 version.
    CommandComplete: true
    ######################################
    # Bypass Options #
    ######################################
    #Type: perm - Bypass with Bypass Permission in config.yml
    # none - Cannot bypass including staff/op
    # whitelist = Player contain Whitelist can bypass
    #Permission: Permission needed to bypass
    #Whitelist: Player in whitelist will bypass
    Bypass:
    Type: 'perm'
    Permission: 'antipluginspy.bypass'
    Whitelist:
    - 'Notch'
    ######################################
    # Tab Options #
    ######################################
    #AntiSlashSpy - /<tab> will be disabled if true
    #Notify - Will send out error when player try to tab
    #Blacklist - Command in TabBlackList not able to tab
    Tab:
    AntiSlashSpy: true
    Notify: true
    Blacklist: true
    TabBlackList:
    - '/pluginmenu'
    ######################################
    # Log Options #
    ######################################
    #Command - Log player that trying to spy plugin by command.
    #Tab - Log player that trying to spy plugin by tab.
    Log:
    Command: true
    Tab: true
    ######################################
    # Hook Options #
    ######################################
    #Essentials - If not having essentials than block /help
    Hook:
    Essentials: true
    Prefix: '&c&lWATCHDOG &e--> '
    Messages:
    CommandBlock: '&cSorry, not permitted to use this command.'
    TabBlock: '&cSorry, not permitted to use tab on this command.'
    FakePlugin: '&fPlugins (1): &a%servername%'
    NoPermission: '&cSorry, not permitted to use this command.'
    PluginReload: '&aPlugin Reloaded'
    ColonCMDBlock: '&cCommand that contains colon disabled.'

    Plan To Do
    • Staff Notify
    • Suggest your idea
    B_Z_27_MC likes this.

Recent Updates

  1. Plugin Recoded and new feautures added