[API] I18N - Translate your plugins easier than ever before! - v1.8 - v1.11 1.4.0

Internationalization API for use with CraftBukkit / Spigot

  1. Update to Version 1.3.0: Added support for Minecraft v1.8.3+ and Legacy Builds

    BlackyPaw
    Taking up a request to add support for Minecraft versions 1.8.(x) here comes support for said versions under the following restrictions:
    1. For Minecraft versions v1.8.3 and above use I18N's regular builds which you can download from the project's GitHub releases page by following the download link of this resource.
    2. For Minecraft versions below v1.8.3 you must clone the project's source code repository yourself and compile it using maven as follows:
      Code (Text):
      mvn -Dlegacy-build=true clean install
      This is due to the fact that these old versions were relocating the Gson dependency, I18N makes use of. JAR files compiled with the legacy-build flag set to true will append '-legacy' to their plugin version numbers. As a side note: the 4.1.0 release of ProtocolLib does not work when using I18N and Spigot version 1.8. Use version 3.6.4 of ProtocolLib instead (the reason being that one of the relocated classes could not be loaded since its constructor's signature has changed in between versions).
    Enjoy! :)
Return to update list...