ArmorLite (Cosmic Armor) || Yijiki, Phantom + More Custom Sets 1.3.9.1

Create your own, custom armor sets like CosmicPVP!

  1. nbdSteve
    Native Minecraft Version:
    Legacy (< 1.13)
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    Source Code:
    https://github.com/nbdSteve/Carmor
    Contributors:
    nbdSteve
    ArmorLite (Camor) v1.3.9.1
    ¤▬▬▬¤
    Test the plugin: prac.nuer.dev
    ¤▬▬▬¤
    Description:
    ArmorLite is a free custom armor plugin inspired by the armor sets from ComsicPVP. You can create your own custom sets that have configurable: additional damage, damage reduction, item name, lore and enchantments. Each armor set also has a custom equip message, this is sent to the player when they equip a full set of custom armor. Furthermore, each set can have custom attacks, there are currently two types of attacks (yijiki etc.), more are being added.

    ¤▬▬▬¤
    Unique Features:
    - Everything can be customized in the plugin
    - There is a list of passive & damage modifiers that can be added to each armor set.
    - Each armor set can have its own potion effects, these will be applied to the player when they are wearing a full set and removed when they take 1 piece of armor off
    - Easy to add more armor sets, simply add them to the armor.yml and give them to your players
    - Create armor sets that are unique to your server, or mimic those of bigger servers like CosmicPVP.
    - The plugin is super lightweight
    - The armor sets can be given through a command in game, this works with crates and buycraft as well

    ¤▬▬▬¤
    Special Attacks:
    - There are currently 2 different special attacks, these can be added to the same armor sets as the attacks stack.

    Lightning Attack:
    - This will strike nearby enemies with lightning, the lightning strike will not damage the player wearing the armor
    - syntax in armor.yml:
    <attackType>:<if the radius is random>:<radius>:<number of strikes>:<delay between strikes (in ticks)>:<damage dealt per strike>:<proc chance>
    - example:
    Code (Text):
    lightning:false:15:4:10:1.36:0.14


    Potion Attack:
    - This will give nearby enemies the desired potion effect, you can make this any type of effect
    - syntax in armor.yml: <attackType>:<potion effect given>:<level>:<duration in seconds>:<random radius enabled>:<radius>:<proc chance>
    - example:
    Code (Text):
    potion:poison:3:3:true:5:0.3
    Warp Attack:
    - This will teleport the player being attacked behind their attacker. They will be facing their attacker (This feature is new so please report bugs).
    - syntax in armor.yml: <attackType>:<number of blocks to warp>:<proc chance>
    - example:
    Code (Text):
    warp:4:0.2
    TODO:
    - add factions support for special attacks

    ¤▬▬▬¤
    Passive & Damage Modifiers:
    Modifier List:
    - health:24 , this will set the players maximum health to 24
    hearts

    - +dmg:1.20 , this will increase the players offensive damage by 20%

    - -dmg:0.8, this will decrease the players defensive damage by 20%

    - kb:-0.5 , this will decrease the amount of knockback that the player wearing the armor set will take, increase the number to take less kb.

    ¤▬▬▬¤
    GUI:
    - There is a main gui which contains icon for each of the armor sets, when the player clicks an icon they are taken to a gui specific to that armor set where they can buy each piece.
    - The gui supports up to 54 different armor sets.
    - Add a "back to gui button" to each of the armor set gui
    - Add an "information item" to the main gui to explain the armor sets! This item is completely customizable and can be disabled.

    ¤▬▬▬¤
    Permissions:
    Commands:
    /ca - carmor.gui
    /ca help - carmor.help
    /ca reload - carmor.reload
    /ca list - carmor.list
    /ca give - carmor.give
    (example: /ca give <player> <set number> <item(diamond_helmet or leather_helmet)> <amount>)

    GUI:
    in order for the player to buy the armor set they must have the permission: carmor.gui.<armor set number> (example: carmor.gui.1 permission to buy armor-set-1)

    ¤▬▬▬¤
    Source Code
    ¤▬▬▬¤
    Partners:
    (pm me for details on becoming a partner)

    squeeze-banner-1.png
    ¤▬▬▬¤
    Dependencies:
    - Vault (required to use the Gui feature, the plugin will run if you do not have this on your server).

    Installation:
    Simply drag and drop the plugin into your plugins folder and restart your server!

    ¤▬▬▬¤
    Report Bugs / General Support:
    You can seek support in my SUPPORT DISCORD, or you can message me on Spigot.
    **PLEASE SEEK SUPPORT BEFORE LEAVING A BAD REVIEW**
    LordiusYT likes this.

Recent Reviews

  1. darkinnit
    darkinnit
    4/5,
    Version: 1.3.9.1
    I'm having a problem when typing /ca.. it says an internal error
    can you tell me why? I'll rerate it to 5 if you know why



    > [23:50:48] [Server thread/INFO]: BaconBiscuit issued server command: /ca
    > [23:50:48] [Server thread/ERROR]: null
    org.bukkit.command.CommandException: Unhandled exception executing command 'ca' in plugin Carmor v1.3.9.1
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:47) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:149) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchCommand(CraftServer.java:710) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.PlayerConnection.handleCommand(PlayerConnection.java:1641) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.PlayerConnection.a(PlayerConnection.java:1481) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.PacketPlayInChat.a(PacketPlayInChat.java:47) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.PlayerConnectionUtils.lambda$0(PlayerConnectionUtils.java:19) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.TickTask.run(SourceFile:18) [minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandler.executeTask(SourceFile:144) [minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) [minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandler.executeNext(SourceFile:118) [minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.MinecraftServer.aX(MinecraftServer.java:909) [minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.MinecraftServer.executeNext(MinecraftServer.java:902) [minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandler.awaitTasks(SourceFile:127) [minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.MinecraftServer.sleepForTick(MinecraftServer.java:886) [minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:819) [minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]
    Caused by: java.lang.IllegalArgumentException: No enum constant org.bukkit.Material.INK_SACK
    at java.lang.Enum.valueOf(Enum.java:238) ~[?:1.8.0_222]
    at org.bukkit.Material.valueOf(Material.java:1) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    at dev.nuer.ca.gui.MainGui.mainGui(MainGui.java:46) ~[?:?]
    at dev.nuer.ca.command.CaCommand.onCommand(CaCommand.java:48) ~[?:?]
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:45) ~[minecraft_server.jar:git-Spigot-94af569-a3fdef8]
    ... 17 more
    1. nbdSteve
      Author's Response
      Hey, please contact me for support before leaving a review. There is an extremely simple fix to this problem. You simply need to rename INK_SACK to something else that is a 1.14 item. If you can't figure it out please join the support discord.
  2. puglover1508
    puglover1508
    5/5,
    Version: 1.3.9.1
    Incredible plugin for servers with a small budget. more reliable than all other cosmic armor set plugins on spigot. The plugin's configs are organized perfectly and are extremely easy to use!
    1. nbdSteve
      Author's Response
      Thanks for the positive review, I'm glad you like the plugin :)
  3. lolilol94
    lolilol94
    4/5,
    Version: 1.3.9.1
    very good plugin but what is the list of potions please because I do not understand how to add strength or other potion effect
    1. nbdSteve
      Author's Response
      Reviews is not the place to get support, please join my support discord if you are having problems with the plugin.
  4. Nahid
    Nahid
    5/5,
    Version: 1.3.9.1
    Such an amazing plugin! I like all the features it has and the developer is constantly online! It's a very well made plugin
    1. nbdSteve
      Author's Response
      Thanks so much for the positive review :D I'm glad you're enjoying the plugin.
  5. Okamis
    Okamis
    5/5,
    Version: 1.3.9.1
    The plugin is very customizable and works great. The developer is very helpful, provides great support, active on discord and listens to suggestions. Would recommend this and any other plugin made by this developer!
    1. nbdSteve
      Author's Response
      Thanks so much for the nice review :)
  6. Ergenta
    Ergenta
    5/5,
    Version: 1.3.11
    Very patient developer backing a very made, very customizable, yet some how lightweight plugin. Answers questions and even gives one-one tutorials if he's available. Adds suggested features that are appropriate and keeps the wiki up to date, unlike other similar 'premium' plugins. Don't be fooled by shiny imitators as the real 'premium' version is right here.
    1. nbdSteve
      Author's Response
      Thanks a lot :) I really appreciate the review, support and suggestions!
  7. Bambanah
    Bambanah
    5/5,
    Version: 1.3.9
    A really well made plugin, and a very helpful dev. Will definitely be using this.
    1. nbdSteve
      Author's Response
      Thank you for the kind review, fellow dominoid... :)
  8. ExeoAge
    ExeoAge
    5/5,
    Version: 1.3.3
    love the plugin but you should make a "disable buy command" so people don't have to buy it.
    1. nbdSteve
      Author's Response
      Thanks for the review, I'm glad you're enjoying the plugin :) Thanks for the suggestion! I will add it in a future update, if I do the wrong thing please let me know if the discussion tab.
  9. AaronLion_fury
    AaronLion_fury
    5/5,
    Version: 1.3.2
    I edited the armor names to fit my theme and now the GUI doesn't work. The command to give me the armor doesn't work either.
    1. nbdSteve
      Author's Response
      Thanks for the review :) Please get in contact with me through my support discord, its likely you just missed something in your configuration. My discord: https://discord.gg/j6Yj5B8
  10. Gornuz
    Gornuz
    5/5,
    Version: 1.2.2
    A great plugin! Constantly upgraded and the pluginner hear your requests and suggestions!
    1. nbdSteve
      Author's Response
      Thanks for the review! Also, thanks for all the suggestions! :)