AsyncWorldEdit 3.9.1

Async WorldEdit - Edit millions of blocks without lag!

  1. Java 16 compatibility fixes

    SB_prime
    IMPORTANT:
    This build works with Minecraft 1.17 (and earlier), it was tested against the latest version of WorldEdits Dev build, and it should work with NBT data.

    Changes:
    • Further fixes for Java 16 compatibility
    • Undo block ghosting

    Please read:

    This release is designed to work on Minecraft (Spigot) 1.13+ it won't work on any older version of Minecraft. For Minecraft 1.12 and older please use...
    Kixhiz and Zoro6191 like this.
  2. A leap forward...

    SB_prime
    IMPORTANT: This build works with Minecraft 1.17 (and earlier), although at the time of release there is no Minecraft 1.17 compatible version of WorldEdit, therefore all NBT related operations will not work. You might have luck with new DEV versions (when they are released) but at this moment its a lottery, they might work they might not.
    For a regular release you should expect a new version of AWE not sooner then next weekend (if no critical bugs are reported and new builds of WE are...
  3. Compatibility fixes

    SB_prime
    Changes:
    • Java 16 compatibility
    • Latest spigot build compatibility
    • Shutdown bug

    Please read:

    This release is designed to work on Minecraft (Spigot) 1.13+ it won't work on any older version of Minecraft. For Minecraft 1.12 and older please use old version 3.5.4 and WE 6.1.7.3.

    This version was build and tested against WorldEdit 7.2.5, and latest 7.3.0 DEV. It might work...
    ZetaStormy likes this.
  4. Physics freeze rewrite

    SB_prime
    Changes:
    • Fix CoreProtect integration
    • More relatable physics freeze
    Please read:
    This release is designed to work on Minecraft (Spigot) 1.13+ it won't work on any older version of Minecraft. For Minecraft 1.12 and older please use old version 3.5.4 and WE 6.1.7.3.

    This version was build and tested against WorldEdit 7.2.5, it won't work with any older version of WorldEdit....
    Potato_IQ and Halflove like this.
  5. Allign to premium

    SB_prime
    Changes:
    • Fixed undo/redo after player re-login to the server
    • Less talkative injector
    • Change permissions before starting processing commands (if player has not AWE permissions no message will be executed)
    Please read:
    This release is designed to work on Minecraft (Spigot) 1.13+ it won't work on any older version of Minecraft. For Minecraft 1.12 and older please use old version...
  6. WorldEdit 7.2.0-beta-04 compatibility

    SB_prime
    Changes:
    • Fixed WorldEdit 7.2.0-beta-04 compatibility
    Please read:
    This release is designed to work on Minecraft (Spigot) 1.13+ it won't work on any older version of Minecraft. For Minecraft 1.12 and older please use old version 3.5.4 and WE 6.1.7.3.

    This version was build and tested against WorldEdit 7.2.0-beta-04, it won't work with any older version of WorldEdit. It might...
  7. WorldEdit 7.2.0-beta-03 compatibility

    SB_prime
    IMPORTANT:
    In this version I (finally) added support for java 12+. The plugin was tested with java 8 all up to 14. It worked without any issues but please note that I'm testing on a bare-bone server (WE + AWE only) and it might not be compatible with all plugins when you use java 12+. I consider the support for java 12+ experimental/beta, therefore I still do not recommend it if its absolutely not needed. That said if you experience problems while running the plugin on java 12 send me...
  8. WorldEdit 7.2.0-beta-02 compatibility

    SB_prime
    IMPORTANT:
    In this version I (finally) added support for java 12+. The plugin was tested with java 8 all up to 14. It worked without any issues but please note that I'm testing on a bare-bone server (WE + AWE only) and it might not be compatible with all plugins when you use java 12+. I consider the support for java 12+ experimental/beta, therefore I still do not recommend it if its absolutely not needed. That said if you experience problems while running the plugin on java 12 send me...
    jflory7, PirateCraft, Swede and 3 others like this.
  9. Fixes and WE 7.2.0-beta

    SB_prime
    IMPORTANT:
    In this version I (finally) added support for java 12+. The plugin was tested with java 8 all up to 14. It worked without any issues but please note that I'm testing on a bare-bone server (WE + AWE only) and it might not be compatible with all plugins when you use java 12+. I consider the support for java 12+ experimental/beta, therefore I still do not recommend it if its absolutely not needed. That said if you experience problems while running the plugin on java 12 send me...
  10. Java 12+

    SB_prime
    IMPORTANT:
    In this version I (finally) added support for java 12+. The plugin was tested with java 8 all up to 14. It worked without any issues but please note that I'm testing on a bare-bone server (WE + AWE only) and it might not be compatible with all plugins when you use java 12+. I consider the support for java 12+ experimental/beta, therefore I still do not recommend it if its absolutely not needed. That said if you experience problems while running the plugin on java 12 send me...
    jflory7, lokka30, HyperVx2 and 9 others like this.