BKCommonLib v1.16.5-v2

Common utility library adding unique new features and API's

  1. lokka30
    lokka30
    5/5,
    Version: v1.16.5-v2
    People usually run to the reviews section to document all the issues they've had with plugins. Although this library does absolutely nothing by itself as a plugin installed on your server, it is depended upon by some brilliant resources by these guys, so it is definitely doing things right. Never had issues with it at all. Thanks, team BH!
  2. Gynzel
    Gynzel
    4/5,
    Version: 1.16.4-v2
    For the new security update 1.16.5 please recompile your plugin, please.

    THX ET
  3. jaapie_aapie2
    jaapie_aapie2
    1/5,
    Version: 1.16.4-v2
    pretty shit

    because it's laggy af it doesn't work half of the time the tracks switch sometimes and it just sucks in general
  4. I_EAT_YOU
    I_EAT_YOU
    5/5,
    Version: 1.16.4-v2
    Works :)
  5. benjamonSRL
    benjamonSRL
    5/5,
    Version: 1.16.4-v2
    ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
    ---------------------------------------------
    [ Very nice ]
    ---------------------------------------------
    ▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
  6. sunnystgt
    sunnystgt
    5/5,
    Version: 1.16.3-v1
    upgrade 1.16 4 nice plugin big thx nice nice nice nice nice nice nice nice nice
  7. Keybax
    Keybax
    4/5,
    Version: 1.16.2-v1
    Nice Plugin!!!!
    Can you please add the 1.16.3!

    Nice Nice Nice
    Nice Nice Nice
    Nice Nice Nice
    Nice Nice Nice
  8. R3tuxn
    R3tuxn
    3/5,
    Version: 1.16.2-v1
  9. Alexi123_
    Alexi123_
    3/5,
    Version: 1.16.2-v1
    Impossible to run the ressource, when i add it to the server, the CPU jump to 100%, when i remove it it's normal. I don't know what's happening here but can't really use it :/
  10. ItzCodex
    ItzCodex
    5/5,
    Version: 1.16.1-v1
    Great plugin! When will there be support for 1.16.2? Would love to hear from you!
  11. NewWheat
    NewWheat
    5/5,
    Version: 1.16.1-v1
    1. TeamBergerhealer
  12. draexo
    draexo
    5/5,
    Version: 1.16.1-v1
    This is a great resource. Very handy for a mature server. I have been using this for a while.
  13. AlikSondor
    AlikSondor
    4/5,
    Version: 1.15.2-v3
    I use several plugins that require this API. Everything worked fine everywhere until I tried AtomSpigot 1.8.
    All plugins and the API itself produce a error Could not initialize class com.bergerkiller.bukkit.common... and are turned off.
    Full report about error: https://pastebin.com/rKNpDxUs
  14. cal3432
    cal3432
    4/5,
    Version: 1.15.2-v2
    Good API :) It has lots of hooks and comes really useful in most mods, i have been using it for a while now.
  15. carboom89
    carboom89
    3/5,
    Version: 1.15.2-v1
    Cannot get this plugin to work, tried searching on google, but nothing is coming up, please if someone knows how to get this working, that would be great! Issue that I have found:
    [BKCommonLib] [Network] Failed to register a valid Packet Handler
    1. TeamBergerhealer
      Author's Response
      Try updating protocollib, that might be to blame. You can send the full error in private messages so I can help you out
  16. EchocallingEarth
    EchocallingEarth
    5/5,
    Version: 1.15.2-v1
    5 of 5 plugin library. Extremely active dev who takes personal pride in the work. The Discord is a great place for any answers to any questions regarding this and the plugins that it is made to work with.
  17. NomadMC
    NomadMC
    5/5,
    Version: 1.14.4-v1
    Excellent plugin library all around. Does its job, is well-maintained, and has fantastic support.
  18. realEntity303
    realEntity303
    3/5,
    Version: 1.14.4-v1
    1. TeamBergerhealer
      Author's Response
      This may already be fixed in dev, but I'll be sure to double-check 1.8.8 paperspigot functionality before the next 1.15/1.15.1 release. Thanks :)
  19. TMCThomas00
    TMCThomas00
    5/5,
    Version: 1.13.2-v3
    Amazing and complex. Thanks for keeping this plugin updated, works perfectly with traincarts.
  20. AntivirusDev
    AntivirusDev
    5/5,
    Version: 1.13.2-v3
    You can't truly appreciate this plugin unless you're a developer. No more digging through wiki.vg to find NMS protocol, no more buggy items/inventories/chunks, and no more messy packet code. This is by far the best game utility library I've ever used, and is a much more consolidated option to using NMS. Perfect for intensive server plugins and multiple-version backward compatibility.