BlockVersion [for ProtocolSupport] 1.2

This addon for ProtocolSupport can block defined versions to join the game.

  1. ghac
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    This plugin can block defined client versions to join the game.

    Default config:
    Code (Text):
    mode: whitelist
    kickmessage: '&4The version you used is not supported on this server.'
    versions:
    - MINECRAFT_1_8
     
    The mode can either be whitelist or blacklist (only allowing versions that are listed when using whitelist and only blocking versions that are listed when using blacklist.)

    You can configure the kickmessage with colorcodes(&a etc.)

    Source can be found here.

    You can find the names of the version here (its the "long name" with the _ ).

    You like my work? You can donate me some money here, if you want to:)

Recent Reviews

  1. myketronic
    myketronic
    4/5,
    Version: 1.2
    Tested and works with 1.14.4, very happy about that! I'm not a fan of the bit where, if you make a mistake in your config.yml, it replaces your config.yml with the original/default file. Make config.yml backups before you restart your server!
  2. PluginDownloader
    PluginDownloader
    5/5,
    Version: 1.2
    Good plugin! Can you make a permission in the config for players that can be able to use that client version? That would be great!
  3. oneaddictions
    oneaddictions
    5/5,
    Version: 1.2
    Question, Does this mean i can use 1.7 items if i block below 1.7 thanks please reply back!
  4. muzyeh
    muzyeh
    5/5,
    Version: 1.2
    up 1.13.x
    thx
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  5. NamerPRO
    NamerPRO
    5/5,
    Version: 1.2
    I agree with @DARTANZ. Excellent way to create servers 1.8-1.12 with 1.11.2 core.
  6. DARTANZ
    DARTANZ
    5/5,
    Version: 1.2
    Thanks ! That very good for 1.8 » 1.12 server !
    You help me a lot with that ! Thanks you ! ✓
  7. Gustaw242
    Gustaw242
    3/5,
    Version: 1.2
    Nie działa. Blokuje wersje 1.7.* i gracze nie mogą wejść z 1.8 - 1.12. Proszę zrób coś z tym.
  8. Qilx1014
    Qilx1014
    5/5,
    Version: 1.2
    Good plugins
    Please update to 1.12 versions
    We need it.
    --------------------------------------------
    1. ghac
      Author's Response
  9. Ondra3211
    Ondra3211
    5/5,
    Version: 1.2
    Nice addon!!! :D Please update to 1.12 versions
    -------------------------------------------------------------------
    1. ghac
      Author's Response
  10. Roadhog360
    Roadhog360
    5/5,
    Version: 1.2
    This is great. However, as the below comment says, there should be a message when logging on with a certain version. Also a delay on it so any opening messages a plugin has don't drown it.