BountifulAPI [1.8 - 1.12.1] 1.6.2

BountifulAPI includes API Methods for sending a 1.8 title, ActionBar or even getting the protocol.

  1. ConnorLinfoot
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    BountifulAPI includes API Methods for sending a 1.8+ title or ActionBar.
    Latest build should work with all 1.8 + Versions now (If not let me know!)

    Other Versions (In case latest build doesn't work):
    1.7/1.8 Protocol Hack: http://www.spigotmc.org/resources/bountifulapi.1394/download?version=4513

    Spigot 1.8: http://www.spigotmc.org/resources/bountifulapi.1394/download?version=17988

    Spigot 1.8.3: http://www.spigotmc.org/resources/bountifulapi.1394/download?version=6905


    Made from:

    TitleAPI: http://www.spigotmc.org/resources/titleapi.1325/
    ActionBarAPI: http://www.spigotmc.org/resources/actionbarapi.1315/
    WhatVersion: http://www.spigotmc.org/resources/whatversion.1385/ (Now only works in 1.0)


    Code (Text):
    BountifulAPI.sendTitle(player,fadeIn,stay,fadeOut,"Title","Subtitle");
    Code (Text):
    BountifulAPI.sendTabTitle(player,"Header","Footer");
    Code (Text):
    BountifulAPI.sendActionBar(player,"Action Bar Message", duration);
    Code (Text):
    BountifulAPI.clearTitle(player);

    Note: Old versions of the plugin are no longer supported in any way.

    Please submit bugs, questions, issues and suggestions on GitHub https://github.com/ConnorLinfoot/BountifulAPI/issues Do not PM me, I will not respond. Please check GitHub issues for solutions first and read the full information on this page..

Recent Updates

  1. Support for 1.12
  2. Improved the Updater
  3. BountifulAPI v1.6.0

Recent Reviews

  1. NEEMAN123
    NEEMAN123
    5/5,
    Version: 1.6.1
    Absolutely amazing. Had some problems at first from my side, contacted creator via skype, instant response. Thank you very much!
  2. PurrfectMistake_
    PurrfectMistake_
    5/5,
    Version: 1.6.1
    I use this API for my plugins. 10/10! I hope you will always push updates, because this is such a fantastic API!
  3. Emaltonator
    Emaltonator
    5/5,
    Version: 1.5.3
    This works great! I would like to use it too, do you have a repo for maven? Would be a lot easier to manage!
  4. HSIkMy
    HSIkMy
    5/5,
    Version: 1.5
    THANK YOU FOR 1.9!!!! WORKS PERFECTLY ON THIS SERVER.
    I was just worried about my actionbar/title api not working anymore in 1.9 when I tried to update my plugin. Then it says i have a new message saying that this API has updated. You saved my goddamn life!!
    1. ConnorLinfoot
      Author's Response
      Nice to know! :) Thanks for the review!
  5. CoredTV
    CoredTV
    2/5,
    Version: 1.4
    Doesnt work :/ Iam using Spigot 1.8.3 and The Bountiful 1.8.3 Version as API, but it doesnt work. Will edit my rating when fixed..
    1. ConnorLinfoot
      Author's Response
      "Note: Old versions of the plugin are no longer supported in any way."
  6. Manercraft
    Manercraft
    5/5,
    Version: 1.3
    Like this API, Works perfect !
    Good job !
    Add function to custom time for ActionBar ?
    5 stars
    Really good :D
  7. GoldenGamerZone
    GoldenGamerZone
    5/5,
    Version: 1.3
    With reflections to work on multiple server versions...
    Really good :D
  8. kukubaczek
    kukubaczek
    5/5,
    Version: 1.3
    Add souruce code and boss bars (1.8&&1.7) :)
    Very good API.
  9. HSIkMy
    HSIkMy
    5/5,
    Version: 1.2
    It's a really awesome API! Using it to send action bar messages!
  10. Airos10
    Airos10
    5/5,
    Version: 1.2
    Great plugin, but 1.8 not work for me, need v1_8_R2, can you compile with v1_8_R1?