Builders Wand | Building Help | API | Configurable | Supports multiple plugins |1.8 - 1.14.3 2.12.0

Builders Wand is a plugin that adds a custom item which helps you build in creative and survival mod

  1. Wythe
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    Source Code:
    https://github.com/Falseee/Builder-s-Wand
    Contributors:
    Wythe aka False
    Languages Supported:
    english, german, spanish
    [​IMG]
    Builders Wand is a plugin that adds a custom item which helps you build in creative and survival mode.
    This plugin is inspired by the item "Builders Wand" from extra utilities.

    [​IMG]


    [​IMG]
    [​IMG]
    Example usage of the Wand (Spigot cant display it here... idk why)

    [​IMG]


    [​IMG]
    config.yml:
    Code (Text):

    update:
      notification: true
      autoDownload: true
    particle:
      renderInterval: 2
      renderForAllPlayers: false
     
    wands:
    Code (Text):

    wands:
      '1':
        name: '&3Builders Wand'
        material: BLAZE_ROD
        maxSize: 8
        consumeItems: true
        durability:
          amount: 130
          enabled: true
          text: '&5Durability: &e{durability}'
        crafting:
          ingredient:
            d: DIAMOND
            b: BLAZE_ROD
          enabled: true
          shapeless: false
          recipe:
          - xxd
          - xbx
          - bxx
        particles:
          enabled: true
          type: REDSTONE
          count: 3
        storage:
          enabled: true
          size: 27
     
    You can find the particles list under Particles (Enum Constants), but beware its the newest documentation so if you dont have the newest spigot version maybe some particles not working.

    [​IMG]
    • /bw reload - reloads the config
    • /bw give <player> - give the builder wand (tier 1)
    • /bw give <player> <tier> - give the builder wand (tier X)
    [​IMG]
    • buildersWand.reload to execute the reload command
    • buildersWand.give to execute the give command
    • buildersWand.use to allow a user using the wand
    • buildersWand.craft to allow crafting the wand
    • buildersWand.bypass to allow building in blocked areas (e.g. aSkyBlock and/or worldGuard areas)
    • buildersWand.storage to allow the user using the builders wand storage/inventory
    • buildersWand.updateNotification to get a message on a new update of this plugin
    Optional permissions for each wand, is a permissions set (in the wands.yml) then the user needs the permission to use the wand.

    Example:
    Code (Text):
    wands:
      '1':
        [other config]
        permission: 'buildersWand.use.1'
    So the user needs the permission "buildersWand.use.1" to use the wand.


    [​IMG]
    • Improve the block selection algorithm
    • Add a gui to configurate the config ingame
    • Commands usable on the commandline
    [​IMG]
    To report a bug or suggest/request a feature please use github, write me on Discord or just write in the comments.


    You will support/donate me ?
    Its not a requirement, but a nice gesture.
    Feel free to pn me :)
    Diclo, DarkTwin, Roy7885 and 6 others like this.

Recent Reviews

  1. MrGamerz
    MrGamerz
    4/5,
    Version: 2.12.0
    great plugin could you update to 1.15.2 as we are moving version and i wanna take your plugin with me cheers
  2. peezykz123
    peezykz123
    5/5,
    Version: 2.12.0
    when player /hat diamond block. then he use bw to build but blocks he has hat doesn't lose
    sorry about my bad English (i'm Vietnamese)
  3. TwerkRekt
    TwerkRekt
    3/5,
    Version: 2.12.0
    good plugin but not configurable, impossible to edit tile gui, change prefix ect...
  4. Gamerben13
    Gamerben13
    4/5,
    Version: 2.12.0
    This plugin is very good, but I have noticed I can't add more than 1 line of lore onto the builder's wand. If you could let me know if I can and I'm just doing it wrong.

    But really amazing plugin!
  5. Socialclubz.com
    Socialclubz.com
    5/5,
    Version: 2.12.0
    Great Plugin, Honestly best one out there so far that works in 1.14.4 If you can look into adding support for FabledSkyblock that would be epic!
  6. ThatHunky
    ThatHunky
    5/5,
    Version: 2.11.0
    Really awesome plugin and helpful developers! Helped me resolve my problem really fast!
  7. Fang28
    Fang28
    5/5,
    Version: 2.11.0
    When I first downloaded the plugin didn't support coreprotect. I left a comment asking for it and it was added within days. I'm very impressed by this dev! Thanks for this :)
  8. The_WhiteMage
    The_WhiteMage
    5/5,
    Version: 2.11.0
    It's pretty easy to setup and use. Nobody has had a problem using it and players who build often were happy it cut out a lot of their busywork. Common request players have is if the wand could use items from their shulker boxes.
  9. xXIMMORTALXx
    xXIMMORTALXx
    4/5,
    Version: 2.7.0
    it seems like a pretty good plugin but this latest version is having errors where people cant move named items to other inventory slots
    1. Wythe
      Author's Response
      should be fixed in the latest version
  10. Alfredddd
    Alfredddd
    4/5,
    Version: 2.7.0
    Nice plugin! But please add support for PlotSquared, other players can build on other players plots
    1. Wythe
      Author's Response
      Added Support for PlotSquared