BungeeChatAPI 1.0.2

Include 'net.md_5.bungee' and Google's GSON libraries in older Minecraft versions.

  1. kangarko
    Contributors:
    MineAcademy.org
    This plugin has been featured on... [​IMG]


    BungeeChatAPI
    A bukkit library that allows plugin requiring bungee chat library to run on older Minecraft versions. It is only a library and does nothing on its own. It was originally made for plugins like ChatControl and Confiscate to allow it to be run on older Minecrafts, but you may use it in your plugin to extend its compatibility.

    Background:
    Starting 1.7.10, Spigot begun to include its bungee chat api library, that makes it possible to send JSON components easily (for example chat messages with hover elements or clickable links). Unfortunately, plugins utilising this library won't work on older Minecraft. This is why I decided to create this library.


    Installation:
    1. Shutdown your server network.
    2. Drag & drop the .jar file into the plugins folder in your Bukkit folder.
    3. Optional if it is not working: Open the incompatible plugin's .JAR file you want to make working (with WinRAR or similar). Then, open 'plugin.yml' within the .jar file and insert BungeeChatAPI to 'softdepend' (create the key if not present). Server must be shut down under the whole process.
    Features:
    Does nothing on its own, but allows third party plugins to run.

    Requirements:
    Java 8
    Craftbukkit or Spigot for Minecraft 1.2.5, 1.3.2, 1.4.7, 1.5.2, 1.6.4, 1.7.10 and usually all versions in between.

    Copyright:
    I do not own the rights to this code and only provide a compatibility bridge for third party plugins. The library code this plugin include is made by md_5 and it freely available at
    https://github.com/SpigotMC/BungeeCord

    Enjoyed this plugin?
    You may be also interested
    in ChatControl or Confiscate.
    Manic97 likes this.

Recent Updates

  1. 1.0.2
  2. 1.0.1