Classic Duels [1.9-1.16.5] 1.0.3

Addictive Gameplay | MySQL/YAML | BungeeCord/Multi Arena | Placeholders | Many Languages |

  1. Despical

Recent Reviews

  1. jheferson
    jheferson
    5/5,
    Version: 1.0.3
    Great plugin, by far the best Duel plugin I tried here at spigot, but it just lacks the possibility to create new kits for dueling, if possible add, I even pay for it !!
    1. Despical
  2. Luch_Stanz
    Luch_Stanz
    1/5,
    Version: 1.0.3
    took inventory off of some players and bugged them so they wouldn't have weapon delay in 1.16.5. ruined a friends server
  3. RubenCaleb
    RubenCaleb
    5/5,
    Version: 1.0.3
    VERY NICE PLUGIN VERY RECOMMENDED!

    please can you add support for spigot 1.8.x? because PVP in that version its much better thant 1.9x :(
    1. Despical
      Author's Response
      Thank you for your review.
  4. Frreiheit
    Frreiheit
    5/5,
    Version: 1.0.0
    The plugin is function very good, is easy to setup, it gives good support and the developer is very friendly. :D
    1. Despical
      Author's Response
      Thanks for the review, have fun!