CommandBlocker 4.0.1

Block Commands! World specific, command-specific permissions, per world blocks, and also from ops!

  1. MrEminent42
    [​IMG]
    This is a simple plugin that allows you to block all /minecraft: and /bukkit: commands.
    The event priority for this plugin is set to HIGHEST. For non-developers, this basically means this plugin will override most plugins when handling commands.

    This plugin requires CS-CoreLib to run, it will be automatically installed when you install this plugin.

    [​IMG]
    Code (Text):
    commands: ## Command list
    /minecraft: ## Command to be blocked, must start with a forward slash (/)
    permission: minecraft.permission ## Permission to bypass THAT COMMAND ONLY
    /reload:
    permission: reload.permission
    world-specific: ## World specific list
    world: ## World name
    /warp: ## Command to be blocked, must start with a forward slash (/), only blocked in that world
    permission: world.warp ## Permission to bypass THAT COMMAND ONLY, IN THAT WORLD ONLY
    world_nether
    /tp:
    permission: worldnether.warp
    block-ops: ## Commands to block from ALL ops. There is no bypass permission for this.
    - /op
    - /reload
    - /stop
    - /deop
    options:
    auto-update: true
     
    You can also customize the message in the messages.yml.

    [​IMG]
    • Any ideas you guys have!

    Metrics
    This plugin also uses a Metrics-System which collects anonymous data to use for statistics. See more information about this here. You can opt-out of this service can be done by going to plugins/Plugin Metrics/config.yml and set opt-out: true.

    --
    All of my plugins utilize the All Rights Reserved license. This means that you cannot modify or redistribute without my permission.

    If you give my plugin a bad review because you want something added, the review will be reported and I will not add the requested feature to the plugin.
    waleed likes this.

Recent Updates

  1. TOTAL REDO - v4.0 - v4.0.1
  2. Bug Fixes - v3.0.2
  3. Bug Fixes - v3.0.1

Recent Reviews

  1. Yatogamitetsu
    Yatogamitetsu
    2/5,
    Version: 4.0.1
    Umm...Hey! Why the config file doesn't completely generated....and the config shown on this page doesn't match with the config generated ....

    If this isn't a bug please tell me the format how to modify the config file :)
  2. dawidperez
    dawidperez
    5/5,
    Version: 4.0.1
    Good plugin! This plugin is very handy on my server ! Thank you so much for this simple plugin! :) hope I will see it grow
  3. waleed
    waleed
    5/5,
    Version: 4.0.1
    thx
    1. MrEminent42
      Author's Response
      No problem! Thanks for the review :)
  4. JavaSE
    JavaSE
    3/5,
    Version: 3.0.2
    Requires CS-corelib? Where did it say that? CS-corelib breaks a lot of the plugin on my server! If I would have known that I wouldn't have even downloaded it :/
    1. MrEminent42
      Author's Response
      Thanks for the review

      It says it requires CS-CoreLib on the discription! And what do you mean it breaks? I can help. Post the problem in the discussion section!
  5. HelloitsRien
    HelloitsRien
    3/5,
    Version: 3.0.2
    Nice plugin, does what it must do!
    1. MrEminent42
      Author's Response
      Thanks.
      I see the review is only 3 stars, so if you want anything added, please request it in the Discussion section. I'll add it if I can :)
  6. Elijah
    Elijah
    5/5,
    Version: 3.0.2
    :D Awessommmeee. :3
    1. MrEminent42
      Author's Response
      Thanks for the review! Glad I could give you quick support.