CommandWhitelist - Spigot/Waterfall/Velocity 1.7.7

Block commands, subcommands and tab completions!

  1. YouHaveTrouble
    Native Minecraft Version:
    1.16
    Tested Minecraft Versions:
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    • 1.17
    Source Code:
    https://github.com/YouHaveTrouble/CommandWhitelist
    CommandWhitelist offers both command blocker and tab completion blocker for bukkit/spigot/paper 1.8 - 1.16 and Waterfall or its forks.

    This plugin was created because of my frustration of having to use multiple plugins for controlling the commands usage AND tab completions, and when I added some plugin I had to add its commands in multiple configs. No more. This one functions as command blocker and tab complete blocker. At once. One config.


    Why CommandWhitelist?
    • Avoid confused players trying to use commands that they do not have permissions for.
    • Display only whitelisted commands in modern 1.13+ command suggestions
    • Display your own "no such command" message
    • Decide what commands player can see and execute based on permission
    • Hide tab completions on legacy servers (requires ProtocoLib)
    • Hide and block specific subcommands on spigot!

    default group is assigned to players automatically as default, so all the commands on that list will be usable and will autocomplete for all.

    You can add unlimited amount of whitelists by adding sections in config under "commands" line, just like an example already present in default config.

    You can find detailed instructions how to use this here.

    If you find any bugs please, do not rate 1 star and leave, but create an issue here, I will be more than happy to fix it!
    shayegan, adrianed04 and MilkAndSugar like this.

Recent Updates

  1. Bug fix
  2. The last legacy fix
  3. What.

Recent Reviews

  1. xYundy
    xYundy
    5/5,
    Version: 1.7.3
    Simple, non-laggy plugin that does the job. Must have for every server.

    PL: Prosty, nie obciążający plugin, który robi robotę. Musisz go mieć na swoim serwerze!
  2. eloso
    eloso
    5/5,
    Version: 1.7.3
    Un buen plugin, no sé inglés como para comentar en inglés; pero en español puedo decir que es un gran plugin fácil de usar y muy útil.
  3. CroaBeast
    CroaBeast
    5/5,
    Version: 1.7.3
    Dude, this plugin works so flawless, I love it.
    11/10 awesome plugin :DDDDDDDDDDDDDDDDDDDDDD
  4. Parimek
    Parimek
    2/5,
    Version: 1.7.3
    у меня плагин не хочет работать от слова совсем даёт ошибку в консоль и не включается использую ядро paper 1.12.2
    1. YouHaveTrouble
      Author's Response
      User never contacted me via any means to solve the issue.
  5. Bestem0r
    Bestem0r
    5/5,
    Version: 1.7.3
    Really good plugin. Does exactly what it's supposed to without any issues! Using paper 1.8
  6. ZhenkM
    ZhenkM
    5/5,
    Version: 1.7.2
    very good complement, super very good complement, I think everyone should use it, thanks for the support, have a good day!
  7. adrianed04
    adrianed04
    5/5,
    Version: 1.7.2
    Good plugin, I have been using it for several months and it works for me on the most popular platforms (Waterfall / Velocity in my case), it does double work without any performance cost and very easy to use. Buen plugin c:
  8. Saphirus
    Saphirus
    5/5,
    Version: 1.7.2
    10/10, simplifies a lot of things, has helped me massively when making things look clean
    maybe add per group denied messages?
  9. LuukPlay
    LuukPlay
    5/5,
    Version: 1.7.1
    Thanks for plugin, simple and objective.........................................
  10. yigityetkin
    yigityetkin
    5/5,
    Version: 1.6.0
    Nice plugin but /reply and /spawn commands cannot usable. Can u fix it?
    ........
    1. YouHaveTrouble
      Author's Response
      Please describe the issue in either discussion thread or open an issue on github, there isn't enough information to troubleshoot.