Confirm Menu | 1.8 - 1.16 | Configurable 1.1.7

Easily add a confirmation to your commands !

  1. MaximePremont
    Native Minecraft Version:
    Legacy (< 1.13)
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    Source Code:
    https://github.com/MaximePremont/ConfirmMenu
    Languages Supported:
    French, Spanish, German, Turkish, Chinese, Russian, Polish, Czech
    [​IMG]

    This spigot plugin working with all versions of minecraft from 1.8 to 1.16 will allow you to easily add to a confirmation menu for all of your commands, including those added with your other plugins !
    ConfirmMenu also has a system for easily changing languages between 9 different languages !
    [​IMG]
    [​IMG]
    [​IMG]
    • Confirmation Menu​
    • Written confirmation​
    • Configurable messages​
    • Permissions​
    [​IMG]
    Code (YAML):
    # List of commands that require confirmation
    Commands
    : "reload, stop"
    # List of commands that require a confirmation by writing "confirm"
    CommandsWrite
    : "kick, ban"

    # Enable open sound
    OpenSound
    : true
    # OP players have permission to skip confirmation by default ( confirmmenu.skip )
    SkipPermsForOP
    : false
    # Messages ( color codes are valid )
    Text
    :
        ConfirmMessage
    : "&eAre you sure ?"
        WriteConfirmMessage
    : "&eWrite CONFIRM to confirm, or something else to cancel."
        CancelMessage
    : "&cCanceled !"
        MenuTitle
    : "&8&lCONFIRM"
        MenuConfirm
    : "&a&lCONFIRM"
        MenuCancel
    : "&c&lCANCEL"
        NewVersion
    : "&eA new version of the plugin is available !"
        UpdateFail
    : "&cCould not check for updates !"
    # Changing the language will automatically change the configuration on the next reboot
    # Available languages : EN | FR | ES | DE | TK | ZH | RU | PL | CZ | OTHER
    Language
    : "EN"
    # Check for updates and send a message to the console
    UpdateCheck
    : true
    Code (YAML):
    # Liste des commandes qui ont besoins d'une confirmation
    Commands
    : "reload, stop"
    # Liste des commandes qui peuvent êtres confirmées en écrivant "CONFIRM"
    CommandsWrite
    : "kick, ban"

    # Activer le son d'ouverture du menu
    OpenSound
    : true
    # Les joueurs OP ont la permission de passer la confirmation ( confirmmenu.skip )
    SkipPermsForOP
    : false
    # Messages ( les codes couleurs fonctionnent )
    Text
    :
        ConfirmMessage
    : "&eÊtes-vous sûr ?"
        WriteConfirmMessage
    : "&eEcris CONFIRM pour confirmer, écris autre chose pour annuler."
        CancelMessage
    : "&cAnnulé !"
        MenuTitle
    : "&8&lCONFIRMATION"
        MenuConfirm
    : "&a&lCONFIRMER"
        MenuCancel
    : "&c&lANNULER"
        NewVersion
    : "&eUne nouvelle version du plugin est disponible !"
        UpdateFail
    : "&cImpossible de vérifier les mises à jour !"
    # Changer la langue modifiera automatiquement la configuration au prochain redémarrage
    # Langages disponibles : EN | FR | ES | DE | TK | ZH | RU | PL | CZ | OTHER
    Language
    : "FR"
    # Vérifier si il y à une mise à jour et l'indiquer dans la console
    UpdateCheck
    : true
    Code (YAML):
    # Lista de comandos que necesitan confirmación
    Commands
    : "reload, stop"
    # Lista de comandos que pueden confirmarse escribiendo "CONFIRM"
    CommandsWrite
    : "kick, ban"

    # Activa el sonido de apertura del menú
    OpenSound
    : true
    # Los jugadores OP tienen permiso para pasar la confirmación ( confirmmenu.skip )
    SkipPermsForOP
    : false
    # Mensajes ( los códigos de colores funcionan )
    Text
    :
        ConfirmMessage
    : "&eEstas seguro ?"
        WriteConfirmMessage
    : "&eEscriba CONFIRM para confirmar, o algo más para cancelar."
        CancelMessage
    : "&c¡Cancelado!"
        MenuTitle
    : "&8&lCONFIRMAR"
        MenuConfirm
    : "&a&lCONFIRMAR"
        MenuCancel
    : "&c&lCANCELAR"
        NewVersion
    : "&e¡Una nueva versión del plugin está disponible!"
        UpdateFail
    : "&c¡No se pueden buscar actualizaciones!"
    # Cambiar el idioma cambiará automáticamente la configuración en el próximo reinicio
    # Idiomas disponibles : EN | FR | ES | DE | TK | ZH | RU | PL | CZ | OTHER
    Language
    : "ES"
    # Comprube si hay un actualización e indíquela en la consola
    UpdateCheck
    : true
    Code (YAML):
    # Liste der Befehle, die eine Bestätigung brauchen durch ein Inventar (GUI)
    Commands
    : "reload, stop"
    # Liste der Befehle, die eine Bestätigung durch das Schreiben von "confirm" brauchen
    CommandsWrite
    : "kick, ban"

    # Aktiviere Inventar Öffnen Sound?
    OpenSound
    : true
    # OP-Spieler haben standardmäßig die Erlaubnis, die Bestätigung zu überspringen ( confirmmenu.skip )
    SkipPermsForOP
    : false
    # Nachrichten ( Farb-Codes können verwendet werden )
    Text
    :
        ConfirmMessage
    : "&eBist du sicher ?"
        WriteConfirmMessage
    : "&eSchreibe CONFIRM, um zu bestätigen, oder etwas anderes um abzubrechen."
        CancelMessage
    : "&cAbgrebrochen!"
        MenuTitle
    : "&8&lBESTÄTIGE"
        MenuConfirm
    : "&a&lBESTÄTIGE"
        MenuCancel
    : "&c&lABBRECHEN"
        NewVersion
    : "&eEine neue Version des Plugins ist verfügbar !"
        UpdateFail
    : "cKonnte nicht nach Updates suchen !"
    # Durch das Ändern der Sprache wird die Konfiguration beim nächsten Neustart automatisch geändert und angewendet.
    # Verfügbare Sprachen : EN | FR | ES | DE | TK | ZH | RU | PL | CZ | OTHER
    Language
    : "DE"
    # Suche nach updates und schreibe dies in die Konsole?
    UpdateCheck
    : true
    Translation by Alex W
    Code (YAML):
    # Onaylama gerektiren komuylar
    Commands
    : "reload, stop"
    # "confirm" yazılarak onaylanacak komutlar
    CommandsWrite
    : "kick, ban"

    # Menü açma sesini etkinleştir
    OpenSound
    : true
    # OP olanların Onaylama menüsünü yetki ile atlaması (confirmmenu.skip)
    SkipPermsForOP
    : false
    # Mesajlar (Mesaj kodları kullanılabilir)
    Text
    :
        ConfirmMessage
    : "&eEmin misin ?"
        WriteConfirmMessage
    : "&eCONFIRM yazarak onayla, yoksa kısa sürede iptal olacak."
        CancelMessage
    : "&cIptal edildi!"
        MenuTitle
    : "&8&lONAYLA"
        MenuConfirm
    : "&a&lONAYLA"
        MenuCancel
    : "&c&lIPTAL ET"
        NewVersion
    : "&eEklentinin yeni bir versiyonu mevcut. Lütfen eklentiyi güncelleyin."
        UpdateFail
    : "&cGüncellemeler kontrol edilemedi !"
    # Dil'i değiştirmek yeniden başlatmadan sonra aktif olacaktır.
    # Mevcut diller : EN | FR | ES | DE | TK | ZH | RU | PL | CZ | OTHER
    Language
    : "TK"
    # Güncellemeleri kontrol et ve konsol'a mesaj gönder
    UpdateCheck
    : true
    Translation by immakita
    Code (YAML):
    # 需要点击确认才能继续执行的命令
    Commands
    : "reload, stop"
    # 需要输入“确认”才能继续执行的命令
    CommandsWrite
    : "kick, ban"

    # 界面有无声音
    OpenSound
    : true
    # 默认情况下op是否有权限跳过确认 ( confirmmenu.skip )
    SkipPermsForOP
    : false
    # 聊天信息 ( 可以使用颜色代码 )
    Text
    :
        ConfirmMessage
    : "&e你确定吗 ?"
        WriteConfirmMessage
    : "&e输入CONFIRM以确认, 输入其他字符以取消."
        CancelMessage
    : "&c你取消了这次操作 !"
        MenuTitle
    : "&8&l确认界面"
        MenuConfirm
    : "&a&l确认"
        MenuCancel
    : "&c&l取消"
        NewVersion
    : "&e插件有新版本更新 !"
        UpdateFail
    : "&c无法检测更新 !"
    # 更改语言,将在重新载入插件时更新
    # 可用语言 : EN | FR | ES | DE | TK | ZH | RU | PL | CZ | OTHER
    Language
    : "ZH"
    # 是否检测更新
    UpdateCheck
    : true
    Translation by LikeWind
    Code (YAML):
    # Список команд, которые нуждаются в подтверждении
    Commands
    : "reload, stop"
    # Список команд, которые нуждаются в подтверждении, через написание "confirm"
    CommandsWrite
    : "kick, ban"

    # Звук при открытии меню подтверждения
    OpenSound
    : true
    # Операторы сервера могут пропустить подтверждение (confirmmenu.skip)
    SkipPermsForOP
    : false
    # Локализация (с поддержкой цветовых кодов)
    Text
    :
        ConfirmMessage
    : "&eВы уверены?"
        WriteConfirmMessage
    : "&eНапишите CONFIRM для подтверждения или любой другой текст для отмены."
        CancelMessage
    : "&cОтменено !"
        MenuTitle
    : "&8&lПОДТВЕРЖДЕНИЕ"
        MenuConfirm
    : "&a&lПОДТВЕРДИТЬ"
        MenuCancel
    : "&c&lОТМЕНИТЬ"
        NewVersion
    : "&eДоступна новая версия плагина, необходимо обновиться !"
        UpdateFail
    : "&cНевозможно найти обновления !"
    # Смена языка приведёт к автоматической смене конфигурации при рестарте сервера
    # Доступные языки : EN | FR | ES | DE | TK | ZH | RU | PL | CZ | OTHER
    Language
    : "RU"
    # Проверять ли обновления и оповещать о новых версиях в консоль
    UpdateCheck
    : true
    Translation by Nartsiss
    Code (YAML):
    # Lista komend wymagających potwierdzenia
    Commands
    : "reload, stop"
    # Lista komend wymagających potwierdzenia poprzez wpisanie "confirm"
    CommandsWrite
    : "kick, ban"

    # Włącz dźwięk menu
    OpenSound
    : true
    # Czy OP domyślnie posiada uprawnienia do pomijania potwierdzeń ( confirmmenu.skip )
    SkipPermsForOP
    : false
    # Treść ( Kody kolorów są ważne )
    Text
    :
        ConfirmMessage
    : "&eJesteś pewien?"
        WriteConfirmMessage
    : "&eNapisz CONFIRM aby potwierdzić, lub wpisz cokolwiek, aby anulować."
        CancelMessage
    : "&cAnuluj!"
        MenuTitle
    : "&8&lPOTWIERDŹ"
        MenuConfirm
    : "&a&lPOTWIERDŹ"
        MenuCancel
    : "&c&lANULUJ"
        NewVersion
    : "&eNowa wersja pluginu jest już dostępna !"
        UpdateFail
    : "&cNie można sprawdzić dostępności aktualizacji !"
    # Zmiana języka nastąpi po restarcie serwera
    # Dostępne języki : EN | FR | ES | DE | TK | ZH | RU | PL | CZ | OTHER
    Language
    : "PL"
    # Sprawdzaj dostępność aktualizacji i wyślij wiadomość do konsoli
    UpdateCheck
    : true
    Translation by bartexs6
    Code (YAML):
    # List příkazu u kterých ze zobrzí menu
    Commands
    : "reload, stop"
    # Seznam příkazů, které vyžadují potvrzení napsáním „confirm“
    CommandsWrite
    : "kick, ban"

    # Povolit zvuky
    OpenSound
    : true
    # OP hráči mají povolení přeskočit potvrzení ve výchozím nastavení ( confirmmenu.skip )
    SkipPermsForOP
    : false
    # Zprávy (Bravy jsou povolené)
    Text
    :
        ConfirmMessage
    : "&eJsi si jistej ?"
        WriteConfirmMessage
    : "&ePotvrďte stisknutím tlačítka POTVRDIT, nebo klikněte na něco jiného pro zrušení."
        CancelMessage
    : "&cZrušeno !"
        MenuTitle
    : "&8&lPotvrdit"
        MenuConfirm
    : "&a&lPotvrdit"
        MenuCancel
    : "&c&lZrušit"
        NewVersion
    : "&eNová verze je dostupna !"
        UpdateFail
    : "&cNelze zkontrolovat aktualizace !"
    # Změna jazyka automaticky změní konfiguraci při příštím restartu
    # Dostupné jazyky : EN | FR | ES | DE | TK | ZH | RU | PL | CZ | OTHER
    Language
    : "CZ"
    # Kontrola aktualizací
    UpdateCheck
    : true
    Translation by SamikCzDev
    [​IMG]
    • "confirmmenu.skip" : Skip confirmation ( can be disbled )
    • "confirmmenu.update" : Receiving update notification on connection
    [​IMG]
    [​IMG] [​IMG][​IMG]
    Become a donor to be added to this list and to obtain a rank on discord !
    No one :(
    This plugin is made for servers using spigot, all functionality is not guaranteed on other types of servers.
    New features are planned soon :
    • API System
    • Sounds gestion
    • Premium version
    For any suggestions, questions or bugs, please use this : Message to MaximePremont

    PLEASE DO NOT USE THE REVIEW SECTION FOR BUGS REPORT
    Flak, GamersX8_YT and lelesape like this.

Recent Updates

  1. [1.1.7] 1.16.2 Support
  2. [1.1.6] 1.16 Support
  3. [1.1.5] Czech

Recent Reviews

  1. Choubatsu
    Choubatsu
    5/5,
    Version: 1.1.7
    Truly amazing plugin!
    Even tho I'd like to see if it's possible that this plugin is only installed on bungee and listens to events for entire network instead of installing it on every server :D
    1. MaximePremont
      Author's Response
      Thank you very much ! Unfortunately this functionality cannot be implemented because the external command hook on BungeeCord does not work.
  2. hemadada
    hemadada
    5/5,
    Version: 1.1.6
    Hello, I can share this plugin with miaomc.net Is that right? I think he's great and I want more people to know about it. I will post the original address and link the download address to the original address.
    1. MaximePremont
      Author's Response
      Hello, thank you very much for this review. I think so, please send me a private message so that we can discuss it.
  3. Binzhirui
    Binzhirui
    5/5,
    Version: 1.1.5
    Can I share this plugin to minebbs? I will let them come here to download and indicate that you are the original author
    1. MaximePremont
      Author's Response
      Thank you very much for your review ! Yes you can if it has not already been done :)
  4. bartexs6
    bartexs6
    5/5,
    Version: 1.1.3
    Nice work, really useful plugin!
    Now I can not make mistake when I write dangerous command.
    1. MaximePremont
      Author's Response
      Thank you so much for your review !
  5. AlexW
    AlexW
    4/5,
    Version: 1.0.8
  6. KazMNF
    KazMNF
    5/5,
    Version: 1.0.6
    Nice work. So many potential on this plugin.
    -+-+-+-+-+-+-+--+-+-+-+-+-+-+-+-+-+-+-+-+-+-++-
    1. MaximePremont
      Author's Response
      Thank you very much !
  7. LikeWind
    LikeWind
    5/5,
    Version: 1.0.4
    such a excellent plugin , it can avoid many mistakes , if you want some suggestions..... maybe you can add a special permission to someone to avoid confirm?(op don't have by default)
    5 stars! :)
    1. MaximePremont
      Author's Response
      Thank you very much !
      Yes it is a good idea, do not hesitate to explain it to me in more detail by sending me a private message thank you :)
  8. TianShuo
    TianShuo
    5/5,
    Version: 1.0.4
    Hello, your plug-in is very practical. Can I move the plug-in to www.mcbbs.net

    There are many fans of China and minecraft. I believe your plug-in will be popular.
    1. MaximePremont
      Author's Response
      Hello, thank you very much for this review !

      Regarding your request I invite you to send me a private message.
  9. Sartox
    Sartox
    5/5,
    Version: 1.0.3
    Is really usefull, ima use it on my network, so I dont accidentaly reload my server for mistake
    Also, I made an spanish version of this, the translation is pretty quick so I did it :p(My main language is spanish), you can implement it if you want
    https://pastebin.com/FgScsHds 5 stars
    1. MaximePremont
      Author's Response
      Thank you very much ! I will add Spanish today :)
  10. DeadSpark
    DeadSpark
    5/5,
    Version: 1.0.2
    A nice working and useful plugin must use and specially needed while using commands like /stop or /restart
    1. MaximePremont
      Author's Response
      Thank you very much !