Crazy Enchantments v1.8 Dev Build v9

A enchantment plugin that adds 80+ enchantments and cool features to your server.

  1. BadBones69
    Native Minecraft Version:
    1.16
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    Source Code:
    https://github.com/badbones69/Crazy-Enchantments
    [​IMG]

    !! Update Warning !!
    This plugin is currently in development build aka dev build.

    Due to the nature of the build, it is NOT recommended for full production servers as it may contain many bugs and or game-breaking errors. Please consider this before choosing to update.

    If you run into any issues please join my Discord server and report them so I can fix them, the link is found below.


    Description:
    Welcome to the Crazy Enchantments Plugin Page. This plugin has a bunch of enchantments that your players can have fun with. This plugin has over 80+ enchantments.

    [​IMG]
    [​IMG]
    List of Enchantments.
    Features:
    • Now 80+ Enchantments!!
    • Sign Shop
    • Lots of customizing
    • Black/White Scrolls
    • Destroy/Success Rate
    • Categories for enchantments
    • GUI Shop
    • Enchantment Limiter
    • Magical Dust
    • Crazy Tinkerer
    • Black Smith
    • Lost Books
    • GKitz
    • Scrambler
    • And More!!!
    For more information on how the features work check out the wiki.
    https://github.com/badbones69/Crazy-Enchantments/wiki
    Supported Plugins:
    - World Guard: Set Block Break to Deny in a region to protect from enchantments.
    - Silk Spawners
    - Feudal

    - Kingdoms+
    -
    Factions by Massive Craft
    - FactionsUUID
    - ASkyBlock: Allows the Wings enchantment to work on islands.
    - MegaSkills

    - Towny
    - Legacy Factions

    Supported Currencies:
    https://github.com/badbones69/Crazy-Enchantments/wiki/Currency-Types

    Commands and Permissions:
    https://github.com/badbones69/Crazy-Enchantments/wiki/Commands-and-Permissions

    Sign Shop Usage:
    Sign shops have 3 different types. They are Category, Black Scroll, and White Scroll shops. The category shops run the same as the GUI. It will use your XP and give you a book. The other two tho can be bought using money or XP(Lvls/Total).

    To make a Sign Shop you need to decide to make a Category, Black Scroll, White Scroll shop.
    How to make a Category Shop
    [​IMG]
    Replace <Category> with one of your categories.
    I'll replace it with the default T1 and this is what I get
    [​IMG]

    How to make a Black/White Scroll Shop
    [​IMG]
    You can replace Black Scroll with White scroll to get the white scroll shop.
    And this is the default look for Black Scroll Sign shops
    [​IMG]

    Videos:
    New English






    French

    English


    [​IMG]
    Source Code

    Translations
    These are translations made by community members. They have shared these with me to allow people who don't speak English to have an easier time to edit the files.

    [​IMG]


    Need to get into contact about an issue or want to chat?
    [​IMG]


    Credits:
    -
    ArmorEquipEvent: Used to allow potion armor when equipping items.
    - NBT API: Used to allow much better version support for some features.
    Yoset, Fuknubu0, AlbertEsin and 89 others like this.

Recent Reviews

  1. Drewit
    Drewit
    1/5,
    Version: v1.8 Dev Build v9
    The plugin itself is okay, it's buggy here and there and requires some tweaking.

    I've been throwing errors for days, contacted multiple people in the Discord, and on Github, no response. The support for this plugin is basically non-existent.

    https://github.com/Crazy-Crew/Crazy-Enchantments/issues/656
  2. Boxeyy
    Boxeyy
    2/5,
    Version: v1.8 Dev Build v9
    This plugin is a great, everything works as expected. But there is one major flaw with it: Lag and crashes.

    With the plugin my TPS drops from 20 to 12 instantly, even after disabling most enchantments it still does this (Only had 10 or so enabled).
    There is also a crash exploit with it, groups of people all using a weird kind of nuker crashed my server multiple times until I decided to remove the plugin.
    After removing it the server runs on 20 TPS all the time, and has never been crashed by anyone. Even with 80+ people online. (Before it would drop to 12 TPS at around 60)
  3. PepsiLemonKongen
    PepsiLemonKongen
    5/5,
    Version: v1.8 Dev Build v9
    I find nothing wrong with this plugin, idk why people are saying its lagging, i find no lag whatsoever in my /timings with paper.
    The only thing showing up with timings is the on inventory clear event, and not many people are in creative on survival servers u know..
  4. Olvier408i
    Olvier408i
    2/5,
    Version: v1.8 Dev Build v9
    Nice idea and all, but one major issues that this plugin has
    COMPLETE LAG!! It was using all of the tick and the TPS dropped to 6 or 3. As soon as it was unloaded, the tps rose to 20. This plugin causes too much lag for it to be considered nice.
  5. Tungkgkg123123
    Tungkgkg123123
    5/5,
    Version: v1.8 Dev Build v9
    [16:51:11 INFO]: [CrazyEnchantments] Enabling CrazyEnchantments v1.8-Dev-Build-v9-RELEASE
    [16:51:11 INFO]: [CrazyEnchantments] Loading the config.yml
    [16:51:11 INFO]: [CrazyEnchantments] Successfully loaded config.yml
    [16:51:11 INFO]: [CrazyEnchantments] Loading the BlockList.yml
    [16:51:11 INFO]: [CrazyEnchantments] Successfully loaded BlockList.yml
    [16:51:11 INFO]: [CrazyEnchantments] Loading the Data.yml
    [16:51:11 INFO]: [CrazyEnchantments] Successfully loaded Data.yml
    [16:51:11 INFO]: [CrazyEnchantments] Loading the Enchantments.yml
    [16:51:11 INFO]: [CrazyEnchantments] Successfully loaded Enchantments.yml
    [16:51:11 INFO]: [CrazyEnchantments] Loading the GKitz.yml
    [16:51:11 INFO]: [CrazyEnchantments] Successfully loaded GKitz.yml
    [16:51:11 INFO]: [CrazyEnchantments] Loading the Messages.yml
    [16:51:11 INFO]: [CrazyEnchantments] Successfully loaded Messages.yml
    [16:51:11 INFO]: [CrazyEnchantments] Loading the Enchantment-Types.yml
    [16:51:11 INFO]: [CrazyEnchantments] Successfully loaded Enchantment-Types.yml
    [16:51:11 INFO]: [CrazyEnchantments] Loading the Signs.yml
    [16:51:11 INFO]: [CrazyEnchantments] Successfully loaded Signs.yml
    [16:51:11 INFO]: [CrazyEnchantments] Loading the Tinker.yml
    [16:51:11 INFO]: [CrazyEnchantments] Successfully loaded Tinker.yml
    [16:51:11 INFO]: [NBTAPI] [NBTAPI] Found Spigot: v1_16_R3! Trying to find NMS support
    [16:51:11 INFO]: [NBTAPI] [NBTAPI] NMS support 'MC1_16_R3' loaded!
    [16:51:11 INFO]: [NBTAPI] [NBTAPI] Found Gson: class com.google.gson.Gson
    [16:51:11 INFO]: Crazy Enchantment Hooks
    [16:51:11 INFO]: WORLD_EDIT: Enabled
    [16:51:11 INFO]: VAULT: Enabled
    [16:51:11 INFO]: TOWNY: Enabled
    [16:51:11 INFO]: WORLD_GUARD: Enabled
    [16:51:11 INFO]: NO_CHEAT_PLUS: Enabled
    [16:51:11 INFO]: SILK_SPAWNERS: Enabled
    [16:51:11 WARN]: [NBTAPI] [NBTAPI] The NBT-API at 'package me.badbones69.crazyenchantments.nbtapi' seems to be outdated![16:51:11 WARN]: [NBTAPI] [NBTAPI] Current Version: '2.7.1' Newest Version: 2.8.0'
    [16:51:11 WARN]: [NBTAPI] [NBTAPI] Please update the nbt-api or the plugin that contains the api!
    [16:51:11 ERROR]: Error occurred while enabling CrazyEnchantments v1.8-Dev-Build-v9-RELEASE (Is it up to date?)
    java.lang.ClassCastException: class de.dustplanet.silkspawners.SilkSpawners cannot be cast to class de.dustplanet.silkspawners.SilkSpawners (de.dustplanet.silkspawners.SilkSpawners is in unnamed module of loader org.bukkit.plugin.java.PluginClassLoader @30f5d47a; de.dustplanet.silkspawners.SilkSpawners is in unnamed module of loader org.bukkit.plugin.java.PluginClassLoader @19aa6e41)
    at de.dustplanet.util.SilkUtil.hookIntoSilkSpanwers(SilkUtil.java:138) ~[?:?]
    at me.badbones69.premiumhooks.spawners.SilkSpawnerSupport.<init>(SilkSpawnerSupport.java:21) ~[?:?]
    at me.badbones69.crazyenchantments.Main.onEnable(Main.java:94) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[patched_1.16.5.jar:git-Paper-790]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:370) ~[patched_1.16.5.jar:git-Paper-790]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:500) ~[patched_1.16.5.jar:git-Paper-790]
    at com.rylinaux.plugman.util.PluginUtil.load(PluginUtil.java:366) ~[?:?]
    at com.rylinaux.plugman.command.LoadCommand.execute(LoadCommand.java:114) ~[?:?]
    at com.rylinaux.plugman.PlugManCommandHandler.onCommand(PlugManCommandHandler.java:95) ~[?:?]
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:45) ~[patched_1.16.5.jar:git-Paper-790]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:159) ~[patched_1.16.5.jar:git-Paper-790]
    at org.bukkit.craftbukkit.v1_16_R3.CraftServer.dispatchCommand(CraftServer.java:826) ~[patched_1.16.5.jar:git-Paper-790]
    at org.bukkit.craftbukkit.v1_16_R3.CraftServer.dispatchServerCommand(CraftServer.java:788) ~[patched_1.16.5.jar:git-Paper-790]
    at net.minecraft.server.v1_16_R3.DedicatedServer.handleCommandQueue(DedicatedServer.java:470) ~[patched_1.16.5.jar:git-Paper-790]
    at net.minecraft.server.v1_16_R3.DedicatedServer.b(DedicatedServer.java:437) ~[patched_1.16.5.jar:git-Paper-790] at net.minecraft.server.v1_16_R3.MinecraftServer.a(MinecraftServer.java:1347) ~[patched_1.16.5.jar:git-Paper-790]
    at net.minecraft.server.v1_16_R3.MinecraftServer.w(MinecraftServer.java:1135) ~[patched_1.16.5.jar:git-Paper-790]
    at net.minecraft.server.v1_16_R3.MinecraftServer.lambda$a$0(MinecraftServer.java:291) ~[patched_1.16.5.jar:git-Paper-790]
    at java.lang.Thread.run(Thread.java:831) [?:?]
    [16:51:11 INFO]: [CrazyEnchantments] Disabling CrazyEnchantments v1.8-Dev-Build-v9-RELEASE
  6. Shadowpauler
    Shadowpauler
    5/5,
    Version: v1.8 Dev Build v9
  7. agatadad
    agatadad
    4/5,
    Version: v1.8 Dev Build v9
    Hola alguien sabe como poner en español es que he buscado y no encontrado desde ya gracias el plugins esta bueno pero al no saber ingles me cuesta
  8. xiongliu
    xiongliu
    5/5,
    Version: v1.8 Dev Build v9
    Awesome plugin! Never had any issues with it whatsoever. Amazing Developer. keep at it!
  9. vasquezfr100
    vasquezfr100
    5/5,
    Version: v1.8 Dev Build v9
    support to 1.17.x please is the best plugin in minecraft really. .............
  10. MemoriesKing
    MemoriesKing
    5/5,
    Version: v1.8 Dev Build v9
    Very Good plugin,But I hope it can support 1.17.x version,Thank you :3
    (support 1.17.x plz)