CT-Core [Inactive] 4.0.3

Required library for my plugins

  1. crysis992
    Native Minecraft Version:
    1.13
    Tested Minecraft Versions:
    • 1.13
    This project is no longer being maintained







    CT-Core is a library that is required for all of my plugins to run. If you don't install this, some of your installed plugins will most likely not work at all.

    This plugin does nothing on its own! So it is useless if you don't run a plugin which requires this library.

    Some features:

    • Tons of util classes
    • Powerful Inventory API
    • WIP - Persistent block API
    • Annotation-based command framework
    • Powerful chat canvas API to display multi-paged chat pages, additionally with clickable
    • Prefix/Suffix API via packets
    • Per-Player async scoreboards
    • LanguageAPI to translate ItemStacks/EntityTypes/Enchantments to a readable String from a configured language file (a language file that is also used by the client)
    • Simple Redis based server<-> server communication via JSON messages inside a bungee cord network
    • BungeeCord compatibility
    • Some useful libs shaded like HikariCP, Apache Commons, Parsiii and more to make some features compatible on a BungeeCord Server
    • ItemBuilder to create Itemstacks easy & fast
    • and more...

    If you're a developer:
    Before you ask, no, there is no source code or wiki or JavaDocs available because I'm too lazy to document all the things since its intended for my public & private plugins/requests only.
    If you decide to use it, I'm not going to give any advanced support or explanations/tutorials on how to use it.



    Plugins depending on it:

    Iluster and Tyrelis like this.

Recent Updates

  1. [4.0.3] Bugfixes
  2. Updated to 1.14.2
  3. 1.14 Update

Recent Reviews

  1. Phaze
    Phaze
    1/5,
    Version: 4.0.3
    Author very unactive and does not respond to pms

    ---------------------------------------------
    1. crysis992
      Author's Response
      Rating my resource with 1-star and an absolutely invalid statement/reason just because you cannot handle a bad review on your resource? wow :)
  2. MatiPoirier
    MatiPoirier
    5/5,
    Version: 3.0.9
    Amazing, but I lost the 1.12 file so now I can't use it in my server.-----------------------
  3. Firea
    Firea
    5/5,
    Version: 2.0.9
    Perfect for every developer, it just does so much work for you, it's great.
    Love it.
  4. mamaie
    mamaie
    5/5,
    Version: 2.0.3
    --------------------------------
    Good plugin :D
    --------------------------------
  5. skyracer2012
    skyracer2012
    4/5,
    Version: 1.0.6
    A very good recource i think it can be a good plugin and the developer too !
    very good work i hope you make more