DiscordLink 1.2

A Discord companion plugin for your server

  1. Agente147
    Agente147
    3/5,
    Version: 1.2
    The plugin is incredible but DON'T THINK THAT IT WOULD BE BETTER IF THE MESSAGES COULD BE CUSTOMIZED ????????
    1. Riku32
      Author's Response
      You can customize the messages, check the config
  2. noprompam
    noprompam
    3/5,
    Version: 1.2
    [23:20:15] [Server thread/ERROR]: Error occurred while enabling DiscordLink v1.2 (Is it up to date?)
    java.lang.UnsupportedClassVersionError: com/freya02/botcommands/PermissionProvider has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_291]
    at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.8.0_291]
    at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.8.0_291]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:201) ~[patched_1.16.5.jar:git-Paper-778]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_291]
    at org.bukkit.plugin.java.PluginClassLoader.loadClass0(PluginClassLoader.java:119) ~[patched_1.16.5.jar:git-Paper-778]
    at org.bukkit.plugin.java.PluginClassLoader.loadClass(PluginClassLoader.java:114) ~[patched_1.16.5.jar:git-Paper-778]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_291]
    at com.github.riku32.discordlink.DiscordLink.onEnable(DiscordLink.java:65) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[patched_1.16.5.jar:git-Paper-778]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:370) ~[patched_1.16.5.jar:git-Paper-778]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:500) ~[patched_1.16.5.jar:git-Paper-778]
    at org.bukkit.craftbukkit.v1_16_R3.CraftServer.enablePlugin(CraftServer.java:518) ~[patched_1.16.5.jar:git-Paper-778]
    at org.bukkit.craftbukkit.v1_16_R3.CraftServer.enablePlugins(CraftServer.java:432) ~[patched_1.16.5.jar:git-Paper-778]
    at net.minecraft.server.v1_16_R3.DedicatedServer.init(DedicatedServer.java:270) ~[patched_1.16.5.jar:git-Paper-778]
    at net.minecraft.server.v1_16_R3.MinecraftServer.w(MinecraftServer.java:1069) ~[patched_1.16.5.jar:git-Paper-778]
    at net.minecraft.server.v1_16_R3.MinecraftServer.lambda$a$0(MinecraftServer.java:291) ~[patched_1.16.5.jar:git-Paper-778]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_291]
    1. Riku32
      Author's Response
      Are you using Java 11? This plugin needs Java 11 to run
  3. coquette
    coquette
    5/5,
    Version: 1.0
    developer was very kind and helpful! this works very well and the webhook system is super cool! much more modern and clean than competitors
  4. DELTAQUAKE
    DELTAQUAKE
    5/5,
    Version: 1.0
    Very nice plugin for what our Discord server needs. Was looking for something like this but DiscordSRV didn't have the few simple things we needed. Also looks way more modern and offers easy customization.