Draconic Evolution Spigot 1.5.4

Awesome armor and utilities!

  1. Nike_Schuh123
    Native Minecraft Version:
    1.14
    Tested Minecraft Versions:
    • 1.13
    • 1.14
    Contributors:
    brandon3055 (Orginal Author),Andinofuchs ( Designer ), Chrieger11 (Designer), 00Buster (Designer)
    Languages Supported:
    English
    DraconicEvolutionTitle.png



    DRYouWant.png




    ITEMLIST.png

    ITEMLISTt.PNG

    commandlist.png
    Drcommands.PNG
    PermsDr.png
    permlist.PNG
    Termsofuse.png

    suppbutton.png
    LordMianite and niho1212 like this.

Recent Updates

  1. Issue fixxes
  2. Configuration improvements
  3. Bug fixes and 1 Boss!

Recent Reviews

  1. Gustavo_Player
    Gustavo_Player
    5/5,
    Version: 1.5.1
    This plugin is great! =O
  2. Monspeet
    Monspeet
    5/5,
    Version: 1.5.1
    I wanted to play this mod with my friends but they couldnt download it.
    Now we can finally play it thanks NikeSchuh123.
    I recommend it to everyone who also likes the original mod :)
    1. Nike_Schuh123
  3. Niklas007
    Niklas007
    5/5,
    Version: 1.4
    I played the Mod DR and now there is a plugin! Cool! Keep up the good work! :smile: . Add 1.12 support please.
    1. Nike_Schuh123
      Author's Response
      Thx <3 1.12.2 Should be possible. Maybe I will add 1.12 support .
  4. BigNan123
    BigNan123
    3/5,
    Version: 1.2
    add 1.8 support, please. seems like a decent plugin based on the mod. respect for making it.
    1. Nike_Schuh123
      Author's Response
      Thanks <3 But 1.8 is not possible currently