DurabilityAlert Legacy [1.8.8-1.12.2] 1.5.6 (1.12 only)

Gives the players a warning when their items are low on durability

  1. DarkMonolith
    Native Minecraft Version:
    Legacy (< 1.13)
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    Source Code:
    https://github.com/christopherwalkerml/DurabilityAlert/tree/da-1.12
    [​IMG]
    DurabilityAlert is a plugin that notifies the player when their items are low on durability.
    Works for: All armour, Pickaxes, Axes, Shovels, Swords, Hoes, Fishing Rod, Shears.

    The warning can be toggled (with the command /durabilityalert toggle) by each player so that it's not forced on everybody.

    NOTE: There are TWO versions for this plugin. The 1.12 version is the default one, but the 1.8 - 1.11 version must be downloaded from the VERSION HISTORY tab.

    [​IMG]
    /durabilityalert (/da) - the base command
    /durabilityalert toggle - toggles the alert per player (set by user)
    /durabilityalert armour <number> - sets the percent at which the armour durability warning will start to show (set by user)
    /durabilityalert tools <number> - sets the percent at which the tools durability warning will show (set by user)
    /durabilityalert type [percent/durability] - sets the warning values to depend on either percent left, or durability left (set by user)
    /durabilityalert enchant - Toggle whether or not alerts hould only be shown for enchanted items
    /durabilityalert status - Shows the current settings for the user

    [​IMG]
    durabilityalert.command:
    description: default durability alert command permission
    default: op
    durabilityalert.alert:
    description: allows the user to get durability alerts
    default: op

    Code (Text):

    lowdurability: "Low durability on %item%"
    durabilityleft: "%durability% Durability left"
    warningsdisabled: "Durability Warnings Disabled!"
    warningsenabled: "Durability Warnings Enabled!"
    enchantedtrue: "Alerts will only show for enchanted items"
    enchantedfalse: "Alerts will show for all items"
    invalidarguments: "Invalid Arguments"
    armourset: "Armour warning value set to %armour%"
    toolset: "Tool warning value set to %tool%"
    mustbenumber: "Percent must be a number! ex: 10"
    settype: "Warning type has been set to %type%"
    prefix: "&f&l[&9&lDurabilityAlert&f&l]"

    #user setting defaults
    defaultvalue: 10
    # 'percent' or 'durability'
    defaulttype: "percent"
    defaultenchanted: false
    enabled-by-default: false
     

    Join my discord server for help/suggestions. I'm active there every day.
    https://discord.gg/AET9mWj


    [​IMG]
    [​IMG]

    Images

    1. dalegacy1.png
    2. dalegacy2.png

Recent Updates

  1. separated versions
  2. separated versions

Recent Reviews

  1. fra130701
    fra130701
    1/5,
    Version: 1.5.6 (1.12 only)
    not working on 1.12.2 .
    1. DarkMonolith
      Author's Response
      Please message me about what is not working so that I can fix it.
      Thanks!

      NOTE: there are TWO versions for this plugin. One is for 1.12 only, and one is for 1.8-1.11 (you have to click the VERSIONS tab to download this one)
  2. Ace_Monkey_Ilium
    Ace_Monkey_Ilium
    5/5,
    Version: 1.5.6 (1.12 only)
    Thank you for this 1.12.2 plugin, I haven't used it yet but I'm excited to start using it when I get on my PC