Easyconomy-Advanced 1.0.1

A fork of Easyconomy (an economy plugin) implementing some advanced features.

  1. Geol
    Native Minecraft Version:
    1.16
    Tested Minecraft Versions:
    • 1.16
    Source Code:
    https://github.com/Geolykt/EasyConomyAdvanced
    Contributors:
    WeiiswurstDev
    Languages Supported:
    German, French
    THIS PLUG-IN REQUIRES JAVA 11!
    Refusing to accept this fact will be met with negligence.


    EasyConomyAdvanced

    About
    This is a production-grade for of the EasyConomy plugin that has more features than the parent project as well as having a no-tolerance bug policy, if you find a bug report it so it can be dealt with accordingly. It was originally meant as a private fork but now also contains features meant for the general user, however due to multiple reasons is incompatible with the parent plugin if you are using it's yaml storage format. (It can be converted rather easily though - so if you want to switch - just ask me).

    Features
    The main policy of the plugin is that it only includes core economy features.

    • Easy setup (Drag plugin in and reload)
    • Few commands
      • /money
      • /eco give/take/set/backup
      • /pay
      • /baltop
    • All messages customizable
    • All settings customizable
    The goal is to take the plugin and implementing more advanced options. Our changes:
    • Bleeding-edge V2 reading compliance for the binary storage format
    • Concurrency-safe
    • Backups are asynchronous
    • Allow to run command prompt commands when doing backups (allows to compress, ship to offsite, etc them)
    • Banks are implemented
    • Force-uses banks for invalid playernames (-> sort-of fixed unsighly baltops)
    • Bundling FIO operations
    • No static abuse
    • Updated to Java 11
    Why NOT use the fork?
    • It makes use of Java 11 - if you don't have it it won't run.
    • This allows for unsafe commandline operations - don't give anyone write acess to the config file!
    Dependencies
    • A Bukkit/Spigot/Paper server with 1.16 or above
    • The Vault Plugin implementing vault-api 1.7 or beyond (Basically a bridge between plugins)
    • Java 11 or higher. This is meant to be used for serious production use, if you are still running Java 8 you are out of luck
    Support
    There currently is no particular discord support server, however feel free to email me via [email protected] or using Github's discussion . You can also use the discussion tab on spigotmc for some basic help.
    ccorp2002 likes this.

Recent Updates

  1. Bugfixes for banks

Recent Reviews

  1. saint-just
    saint-just
    5/5,
    Version: 1.0.1
    Nice, simple to use economy plugin without bloat found in a lot of alternatives.