EmojiChat 1.8.3

A simple, configurable, opensource plugin that adds emojis to your chat!

  1. RadBuilder
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    Source Code:
    https://github.com/RadBuilder/EmojiChat
    Contributors:
    https://github.com/RadBuilder/EmojiChat/graphs/contributors
    Languages Supported:
    Any combination of languages, except Korean and Chinese at the same time
    EmojiChat
    EmojiChat is a simple opensource plugin that adds emojis to your chat.

    [​IMG]
    [​IMG]

    * The GIFs above do not accurately represent the color of each emoji.

    To see the emojis, you'll need the emojichat.see permission. To use emojis, you'll need the emojichat.use permission. To use emojis in chat, use shortcuts from /emojichat list in your chat message! The full list of emojis can be found on the GitHub Wiki.

    EmojiChat hooks into the following plugins:
    - DiscordSRV (displays emojis correctly between Discord and Minecraft)
    - MVdWPlaceholderAPI (for emoji placeholders)
    - PlaceholderAPI (for emoji placeholders)
    Need EmojiChat to hook into another plugin? Let me know!

    Many more emojis are coming soon! More in-depth information can be found on the GitHub Wiki.

    This plugin connects to different sites on the internet for different reasons, including ResourcePack storage, version checking, and statistics collecting. Open the spoiler below for information on what's accessed and collected, and how to opt-out.
    This plugin stores the ResourcePack on GitHub.com, specifically, at github.com/RadBuilder/EmojiChat/releases. When players join the server with the emojichat.see permission, by default, the player will download the ResourcePack. If you'd prefer to not have the ResourcePack downloaded on join, or if you'd prefer to have your players manually download the ResourcePack, set "download-resourcepack" to "false" in your config. GitHub's privacy policy can be viewed at help.github.com/privacy-policy.

    This plugin also connects to spiget.org, which checks to see what the latest version of EmojiChat is. No information is sent to spiget.org - only the latest version number of EmojiChat is received. EmojiChat then compares it to the version you're currently using during server startup to determine if you're able to update. This does not automatically update your version of EmojiChat. You can disable the join notification by negating the permission "emojichat.updates". Spiget's privacy policy can be viewed at spiget.org/legal/privacy/.

    This plugin also submits statistics to bStats.org, which can be viewed by the public at bstats.org/plugin/bukkit/EmojiChat. Statistics include how many servers it's being used on and what version of Bukkit/Spigot they're using, how many players are using it, server information such as Java version, how many emojis are used, and how many servers are using each feature. This data is anonymous, and is submitted to understand what types of server configurations are being used to build a better plugin (i.e. MC/Java versions to continue supporting, features to keep/remove). Data collection has very little/no impact on server performance. If you'd prefer to opt out of the anonymous data collection, go to the bStats config found in your plugins folder (plugins/bStats/config.yml) and set "enabled" to false. Doing so will also disable bStats collection from other plugins. bStats' privacy policy can be viewed at bstats.org/privacy-policy.

    If you have any suggestions or issues with EmojiChat, I'm happy to help work with you to resolve them. Reviews are not a good place for me to help you with issues. Therefore, it's best for you to talk with me in the discussion thread, in an issue on GitHub, or on the EmojiChat Discord. Thanks.

Recent Updates

  1. v1.8.3
  2. v1.8.2 - 1.14 Support
  3. v1.8.1 - bug fixes

Recent Reviews

  1. RealMimikyu
    RealMimikyu
    5/5,
    Version: 1.8.3
    Best plugin ever, but can you add twitch and meme emojis next?
    because well these emojis are pretty cool but it would be funny if meme and twitch emojis would be here too
  2. 0900joshua
    0900joshua
    2/5,
    Version: 1.8.3
    Cant use placeholders in scoreboard or tab. PAPI does not work in general. Was having high expectations when i got it.
  3. Jandy_CZ
    Jandy_CZ
    3/5,
    Version: 1.8.3
    Completly destroying chat, which uses characters like "ěščřžýáíé". Not only it doesn't support it, the texture pack ruins the font. Otherwise a good idea.
  4. binkyquack
    binkyquack
    5/5,
    Version: 1.8.3
    Awesome and simple plugin. For those who are wondering, it works just fine for me in 1.16.1.
  5. Narcox5
    Narcox5
    1/5,
    Version: 1.8.3
    Not supported á,é,ú,ó…. (Hungaryan Launge.) ………………………………………………………………………………………………….
  6. Derili0uS
    Derili0uS
    4/5,
    Version: 1.8.3
    Very good plugin!!
    But please update for 1.15.2 MC version!

    Thank you!! .
  7. EthanNicotine
    EthanNicotine
    2/5,
    Version: 1.8.3
    No support for vowels with accent (áéíóú) or the letter ñ


    ............................
  8. Soyer
    Soyer
    4/5,
    Version: 1.8.3
    An interesting and great plugin for emoji.
    But Cyrillic characters are not supported.
  9. HenyPotter
    HenyPotter
    4/5,
    Version: 1.8.3
    Hello,
    plugin works fine, but i have a one question, how to add my own emojis or shortcuts?
  10. Swilt_
    Swilt_
    4/5,
    Version: 1.8.3
    hello,
    how to change the langage of the plugin ?
    Because he have just config.yml and not langage.yml lmao ?