EnchantGui 1.8 ~ 1.15.2 Editable MaxLevel/Prices 3.0.5

Freely choose the enchantment for your items

  1. LegameMc
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    My Plugins List
    [​IMG]

    BookNews

    This plugin requires VAULT!

    Note: old enchantment's config (enchantments.yml) will NOT work on above v3.0.0 !

    [​IMG]
    click me if the picture is not showing
    Features:
    • Editable prices ( money , level, lapis )
    • Editable GUI
    • Able to set the enchantment's max level.
    • Permission for every single enchantment/level
    • Able to import other plugin's enchantments [tutorial]
    • Lightweight
    Code (YAML):
    # If the plugin is not up-to-date, you will get a notification when you join the server.
    check-update
    : true

    prefix
    : '&a[&bEnchantGui&a] '

    #Player are only allowed to open the "EnchantGui" only if the enchanting table was placed by an admin.
    Only-Admin-EnchantTable
    : true

    # If enabled, the GUI will be closed when player is trying to enchant but they don't have enough money/level.
    CloseInventoryWhenNotEnoughCurrency
    : true

    # If enabled, player requires every single enchantment permission (such as enchantgui.enchantments.DAMAGE_ALL) to enchant.
    # Note: enchantgui.enchantment.ALL to access all the enchantments.
    # the permission above only player can access to all enchantments but not level. (If PermissionForEachEnchantmentLevel is enabled).
    # If you want to give player the permission that access to all Enchantments and level , give "enchantgui.enchantment.*" permission to them.
    PermissionForEachEnchantment
    : false

    # If enabled, player requires every single enchantments level (such as enchantgui.enchantments.DAMAGE_ALL.<level>) to enchant.
    PermissionForEachEnchantmentLevel
    : false

    Message
    :
      Successful-Enchant-Item
    : '&aYou have sucessfully enchanted &6{ENCHANTMENT} &einto your {ITEM}'
      Not-Enough-Money
    : '&cYou don''t have enough money to enchant!'
      Not-Enough-Level
    : '&cYou don''t have enough level to enchant!'
      Not-Enough-Lapis
    : '&cYou don''t have enough lapis to enchant!'
      No-Enchantment-Permission
    : '&cYou don''t have permission to enchant this!'
      No-Enchantment-Level-Permission
    : '&cYou don''t have permission to enchant this level!'
      No-Permission
    : '&cYou don''t have permission to do this!'

    Commands/Permissions: Here

    Please donate if you like the plugin and would like to support me
    [​IMG]
    Having issues with the plugin? You can report it in the discord server.
    It might take some time for me to reply as I am a student. Thank you for your patience
    [​IMG]
    nakaa, Hatti, ENCOM and 3 others like this.

Recent Updates

  1. Fixed another duplication
  2. Fixed some bugs
  3. Bug Fixed

Recent Reviews

  1. nakaa
    nakaa
    5/5,
    Version: 3.0.2
    Ugh i dont know why but when i use the enchant command (/enchant)
    it dont show anything.
    I hope u will help me...(thanks and sorry my english is bad).
    1. LegameMc
      Author's Response
      pretty sure the plugin is disabled due to the "check-update" issue, set "check-update" to false in your config.yml
  2. cuong0175t
    cuong0175t
    5/5,
    Version: 3.0.2
    This is what error it just creates 1 config.yml file (help thanks)
    17:31:39 ERROR]: Error occurred while enabling EnchantGui v3.0.2 (Is it up to date?)
    java.lang.NullPointerException
    at com.gmail.legamemc.enchantgui.EnchantGui.checkUpdate(EnchantGui.java:203) ~[?:?]
    at com.gmail.legamemc.enchantgui.EnchantGui.onEnable(EnchantGui.java:57) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292) ~[skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugin(CraftServer.java:373) [skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugins(CraftServer.java:323) [skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at net.minecraft.server.v1_10_R1.MinecraftServer.t(MinecraftServer.java:412) [skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at net.minecraft.server.v1_10_R1.MinecraftServer.l(MinecraftServer.java:377) [skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at net.minecraft.server.v1_10_R1.MinecraftServer.a(MinecraftServer.java:332) [skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:271) [skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:535) [skyblock1.jar:git-Spigot-72c2605-251a5b6]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_231]
    1. LegameMc
      Author's Response
      hello, can you pm me and send me your config.yml? thanks
  3. Hatti
    Hatti
    5/5,
    Version: 3.0.2
    Wonderful plugin, customizable and with a beautiful guide, excellent support from the creator/developer, thank you very much!
  4. huuliveikko
    huuliveikko
    4/5,
    Version: 2.3.10
    update 1.15 ? i like this plugin
    --------------------------------------------------D
    1. LegameMc
      Author's Response
      Yes, currently I'm updating the plugin
  5. zMaster_
    zMaster_
    5/5,
    Version: 2.3.10
    very good, i like this plugin why is very configuraty andy oi not speak engish bla
  6. KW2
    KW2
    5/5,
    Version: 2.3.10
    Nothing to say really, fully customizeable, great plugin for donator ranks on servers ! keep it up lad !
  7. Firenet
    Firenet
    5/5,
    Version: 2.3.10
    Very easy to config, great developer / fast support; a really good plugin! Really recommend you all to use it for your server!
  8. evrenaydn
    evrenaydn
    5/5,
    Version: 2.3.10
    Great enchantment GUI plugin, very responsive dev and very kind! Glad about the support.
  9. ImEvo2
    ImEvo2
    5/5,
    Version: 2.3.10
    This is a really well-made plugin and perfect for removing money from the economy by allowing players to make their own gear.
    Super easy to set up too.

    Thank you for the work you put into this :)
  10. RubenCaleb
    RubenCaleb
    5/5,
    Version: 2.3.8
    Good plugin but i have problems can you help me? please for pm?
    ---------------------------------------------------------------------------------------
    1. LegameMc