Enhanced AntiSpam 0.5

Stop Spamming. Forever.

  1. Pace
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    • 1.17
    Source Code:
    https://github.com/Pace1337/AntiSpam
    This plugin is meant to stop the spamming for all the Minecraft Servers.

    Don't let those annoying people that come on your server to just spam annoying this disturb you.

    If you find anything wrong, please contact me asap on Spigot, do not leave a bad rating. If you like this plugin, a rating would be appreciated.

    # To bypass all the antispam system you can use the permission antispam.bypass or be a operator.
    antispam:
    repeat: '&7[&b&lAntiSpam&7]&7 Please do not repeat your messages.'
    spam: '&7[&b&lAntiSpam&7]&7 You are not allowed to spam. Wait 2 seconds until sending
    another message.'
    caps: '&7[&b&lAntiSpam&7]&7 Please do not use that much capslock.'
    commandspam: '&7[&b&lAntiSpam&7]&7 Please do not spam commands.'
    commands:
    nopermission1: '&7[&b&lAntiSpam&7]&7 You do not have permission to execute this
    command. (antispam.command)'
    nopermission2: '&7[&b&lAntiSpam&7]&7 You do not have permission to reload plugin
    configuration. (antispam.admin)'
    nopermission3: '&7[&b&lAntiSpam&7]&7 You do not have permission to clear the chat
    (antispam.clearchat)'
    reloadcomplete: '&7[&b&lAntiSpam&7]&7 Plugin configuration has been successfully
    reloaded!'
    clearchat: '&7[&b&lClearChat&7]&7 Chat has been cleared by a staff member.'
    update-checker: true

    Permission to bypass this is antispam.bypass, so if donators, or staff are annoyed by this, they can bypass it. Also all operators are able to bypass this plugin, so if you want to test it, simply deop your self or get an alt account.

    Thank you and hope you enjoy my plugin.

Recent Updates

  1. 0.5
  2. Fix 1.14
  3. 0.3

Recent Reviews

  1. sadasdasda412332
    sadasdasda412332
    3/5,
    Version: 0.3
    [21:00:06] [Server thread/ERROR]: Could not load 'plugins\EnhancedAntiSpam-0.3-SNAPSHOT.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: Unsupported API version 1.16
    at org.bukkit.craftbukkit.v1_14_R1.util.CraftMagicNumbers.checkSupported(CraftMagicNumbers.java:261) ~
    1. Pace
      Author's Response
      This is fixed now, thank you for letting me know.

      Next time go to discussion and not review.