EssentialsX 2.17.2

An updated fork of Essentials with spawner support, performance enhancements, and more

  1. kuba150
    kuba150
    5/5,
    Version: 2.17.2
    Please add per permission commands cooldown for example essentials.commandscooldown.<command>.<time>
  2. NoopyyGaming
    NoopyyGaming
    3/5,
    Version: 2.17.2
    Hello !

    I'm using this new version right now with TacoSpigot 1.8.8 and i saw in console this message :

    You are running an unsupported server version. Is this a issue or it's not a big deal ?
  3. Kendyman
    Kendyman
    5/5,
    Version: 2.17.2
    Lives up to its name. Truly essential for any serious server. Also very performance friendly.
  4. Orcun67_67
    Orcun67_67
    5/5,
    Version: 2.17.1
    Error why?

    [19:16:08] [Server thread/ERROR]: Could not load 'plugins\EssentialsX-2.17.1.62.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.IllegalArgumentException: Plugin already initialized!
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:331) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:278) [Paper.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:293) [Paper.jar:git-PaperSpigot-"4c7641d"]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:202) [Paper.jar:git-PaperSpigot-"4c7641d"]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:563) [Paper.jar:git-PaperSpigot-"4c7641d"]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_241]
    Caused by: java.lang.IllegalArgumentException: Plugin already initialized!
    at org.bukkit.plugin.java.PluginClassLoader.initialize(PluginClassLoader.java:123) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:66) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    at com.earth2me.essentials.Essentials.<init>(Essentials.java:109) ~[?:?]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_241]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_241]
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_241]
    at java.lang.reflect.Constructor.newInstance(Unknown Source) ~[?:1.8.0_241]
    at java.lang.Class.newInstance(Unknown Source) ~[?:1.8.0_241]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:77) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    ... 6 more
    Caused by: java.lang.IllegalStateException: Initial initialization
    at org.bukkit.plugin.java.PluginClassLoader.initialize(PluginClassLoader.java:126) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:66) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    at com.massivecraft.factions.zcore.MPlugin.<init>(MPlugin.java:28) ~[?:?]
    at com.massivecraft.factions.SavageFactions.<init>(SavageFactions.java:90) ~[?:?]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_241]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_241]
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_241]
    at java.lang.reflect.Constructor.newInstance(Unknown Source) ~[?:1.8.0_241]
    at java.lang.Class.newInstance(Unknown Source) ~[?:1.8.0_241]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:77) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[Paper.jar:git-PaperSpigot-"4c7641d"]
    ... 6 more
  5. ChrusKosco
    ChrusKosco
    5/5,
    Version: 2.17.1
    Great!!! But why is keep inv & exp always on for op players
    i wanna enjoy the game server as much as i build it.
  6. Stefanus
    Stefanus
    5/5,
    Version: 2.17.1
    Awesome plugin! Works great on my 1.13.2 server. No error just warn everytime player join my server "Essential Task:#...." apart from that everything is okay. Thanks, keep it up! Hehe :D
  7. HASMCServers
    HASMCServers
    5/5,
    Version: 2.17.1
    Currently using in 1.15.2 and it's working very well. So far no bugs to report, thanks for a quality plugin.
  8. DeleteMetaInf
    DeleteMetaInf
    5/5,
    Version: 2.17.1
    This is the most important plugin of all time. There’s not a single server that doesn’t need EssentialsX. What more can I say?
  9. Noni
    Noni
    5/5,
    Version: 2.17.1
    Great plugin. Very active development and helpful people on their discord server. Everyone complaining about it not having 1.15 support: Open your eyes, there's literally an enormous download button at the top of the plugin description where you can download dev builds.
  10. Albert_Bowden
    Albert_Bowden
    1/5,
    Version: 2.17.1
    Great plugin. Works perfectly but discord support is corrupt. I was banned for no reason, not relating to their rules.
  11. Tmpminetron
    Tmpminetron
    1/5,
    Version: 2.17.1
    Please update to 1.15.1. I would very happy and would make my server go public. Also there is another person that is not using java an his is in 1.15.1.
  12. icansc187
    icansc187
    1/5,
    Version: 2.17.1
    HELP ME SIR

    [18:26:21 WARN]: [Essentials] Plugin Essentials v2.15.0.1 generated an exception
    while executing task 56
    java.lang.NoSuchMethodError: com.earth2me.essentials.storage.BukkitConstructor.c
    onstructScalar(Lorg/yaml/snakeyaml/nodes/ScalarNode;)Ljava/lang/Object;
    at com.earth2me.essentials.storage.BukkitConstructor.access$600(BukkitCo
    nstructor.java:19) ~[?:?]
    at com.earth2me.essentials.storage.BukkitConstructor$ConstructBukkitMapp
    ing.construct(BukkitConstructor.java:184) ~[?:?]
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructObjectNoCheck
    (BaseConstructor.java:204) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructObject(BaseCo
    nstructor.java:193) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructMapping2ndSte
    p(BaseConstructor.java:453) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.SafeConstructor.constructMapping2ndSte
    p(SafeConstructor.java:184) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructMapping(BaseC
    onstructor.java:434) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.Constructor$ConstructMapping.construct
    (Constructor.java:136) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at com.earth2me.essentials.storage.BukkitConstructor$ConstructBukkitMapp
    ing.construct(BukkitConstructor.java:214) ~[?:?]
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructObjectNoCheck
    (BaseConstructor.java:204) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructObject(BaseCo
    nstructor.java:193) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.Constructor$ConstructMapping.newInstan
    ce(Constructor.java:283) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.Constructor$ConstructMapping.construct
    JavaBean2ndStep(Constructor.java:246) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f
    3da3]
    at org.yaml.snakeyaml.constructor.Constructor$ConstructMapping.construct
    (Constructor.java:149) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at com.earth2me.essentials.storage.BukkitConstructor$ConstructBukkitMapp
    ing.construct(BukkitConstructor.java:214) ~[?:?]
    at org.yaml.snakeyaml.constructor.Constructor$ConstructYamlObject.constr
    uct(Constructor.java:309) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructObjectNoCheck
    (BaseConstructor.java:204) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructObject(BaseCo
    nstructor.java:193) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.BaseConstructor.constructDocument(Base
    Constructor.java:159) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseCons
    tructor.java:146) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:524) ~[spigot-1.13.2
    .jar:git-Spigot-1a3504a-84f3da3]
    at org.yaml.snakeyaml.Yaml.load(Yaml.java:467) ~[spigot-1.13.2.jar:git-S
    pigot-1a3504a-84f3da3]
    at com.earth2me.essentials.storage.YamlStorageReader.load(YamlStorageRea
    der.java:41) ~[?:?]
    at com.earth2me.essentials.storage.AbstractDelayedYamlFileReader.run(Abs
    tractDelayedYamlFileReader.java:33) ~[?:?]
    at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftTask.run(CraftTask.jav
    a:81) ~[spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftAsyncTask.run(CraftAsy
    ncTask.java:52) [spigot-1.13.2.jar:git-Spigot-1a3504a-84f3da3]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:
    1.8.0_45]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?
    :1.8.0_45]
  13. Jasonjams8
    Jasonjams8
    5/5,
    Version: 2.17.1
    For those wondering where 1.15.1 support is, download the latest build from Jenkins and it should work just fine
  14. LuxisProchy
    LuxisProchy
    5/5,
    Version: 2.17.1
    Great plugin! Awesome options and easy to use. But could you update the plugin for 1.15, please?
  15. Bloodlex
    Bloodlex
    5/5,
    Version: 2.17.1
    Awesome plugin! Could you please update to 1.15 and add the missing items/blocks to the items.json? Would appreciate a lot! Thanks for your work!
  16. Blake164366
    Blake164366
    4/5,
    Version: 2.17.1
    Loved essentialsX ever since I had my eyes on it and installed it, However update it to 1.15 and you'll get 5 stars out of me. Good work!
  17. Anderson66
    Anderson66
    5/5,
    Version: 2.17.1
    Which functions does not work on 1.15.1? Becouse Im using essentialsx on 1.15.1 and everything works great for now...
  18. Th3_DoC
    Th3_DoC
    3/5,
    Version: 2.17.1
    Shulkers loose contents when creating a kit aside from that it seems to be a solid app, maybe i'm missing something or an update could be added much like how greatkits saves data. 5 stars upon update thanks and keep up the good work.
  19. BourneDev
    BourneDev
    5/5,
    Version: 2.17.1
    Amazing resource! Great support as well. I really appreciate the immediate response, and not only that, but the fact that this is free.
  20. qtt5099
    qtt5099
    5/5,
    Version: 2.17.1
    very very good plugin! but, it does not work in 1.15.1
    please update. i need 1.15.1