EssentialsX 2.15.0.1

An updated fork of Essentials with spawner support, performance enhancements, and more

  1. CraftersGame
    CraftersGame
    5/5,
    Version: 2.15.0.1
    Works very well! I feel that the developer has put a lot of work into this plugin, and I highly recommend using it for your server.
  2. Cocoa
    Cocoa
    5/5,
    Version: 2.15.0.1
    Works as expected. I still wish it weren't quite so bloated, but it works as a one-size-fits-all style resource.
    1. drtshock
      Author's Response
      How is it bloated? It only loads modules that you're actively using / have given people permission to use.
  3. Elguerrero
    Elguerrero
    5/5,
    Version: 2.15.0.1
    _______________________________________________________
    Good plugin,best that the original essentials,thanks so much by do this!:D
    _______________________________________________________
  4. DTPNNK
    DTPNNK
    5/5,
    Version: 2.15.0.1
    Good plugin, I want to see the update with the addition of / mail senditemd to send the player items in the message, namely when he will view the message he will be given items.
  5. AIpha_Dragon
    AIpha_Dragon
    5/5,
    Version: 2.15.0.1
    Without this plugin does not. Download and use, you will not regret. Active developers.
  6. alluahkbar123321
    alluahkbar123321
    5/5,
    Version: 2.15.0.1
    BEST PLUGIN !!

    but can you please add nickname & color support on player's nametag
  7. i4petus
    i4petus
    5/5,
    Version: 2.15.0.1
    this is the most useful and absolute must standard plugin for your server.
    it will make life easier for you and for your players. I have been using it since mc 1.6 or so (well essentials for bukkit), but this fork of bukkit's essentials is just as amazing. Thanks a lot for keeping it alive and coming!
  8. timmyjimmy.exe
    timmyjimmy.exe
    5/5,
    Version: 2.15.0.1
    Will throw a 5 star review for your 5 star plugin, I appreciate you taking the project over and keeping it up to date. Keep up the good work!
  9. Fortepsai
    Fortepsai
    2/5,
    Version: 2.15.0.1
    Really bad Support, Spawn for Newbies is broken, really dissapointed. I hope someone else will come up with some other similar plugin ..
    1. drtshock
      Author's Response
      Helped you out in discord and found out that the issue is on your end, not ours. Spawning and isn't broken.
  10. giulio248
    giulio248
    2/5,
    Version: 2.15.0.1
    It no longer works correctly in 1.12.2 and the support does not answer clearly or even respond.
    After the latest version on both Spigot and Jenkins, the Kits no longer work.
    I can only get the Kits by clicking on the signs but not by command, also with the new commands is 100% impossible to create a Kit, with my staff we have tried everything.
    So in a nutshell the kits do not work.
    1. drtshock
      Author's Response
      Not sure what you mean since I haven't seen anyone not get their questions addressed in Discord all weekend. You probably have your kit file messed up.
  11. vipvipck
    vipvipck
    5/5,
    Version: 2.15.0.1
    [11:15:15] [Server thread/WARN]: [Essentials] Task #110 for Essentials v2.15.0.1 generated an exception
    java.lang.NullPointerException: null
    at com.earth2me.essentials.xmpp.XMPPManager.updatePresence(XMPPManager.java:144) ~[?:?]
    at com.earth2me.essentials.xmpp.EssentialsXMPP.updatePresence(EssentialsXMPP.java:109) ~[?:?]
    at com.earth2me.essentials.xmpp.EssentialsXMPPPlayerListener$2.run(EssentialsXMPPPlayerListener.java:51) ~[?:?]
    at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot.jar:git-Spigot-596221b-9a1fc1e]
    at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:353) [spigot.jar:git-Spigot-596221b-9a1fc1e]
    at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:738) [spigot.jar:git-Spigot-596221b-9a1fc1e]
    at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:405) [spigot.jar:git-Spigot-596221b-9a1fc1e]
    at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:678) [spigot.jar:git-Spigot-596221b-9a1fc1e]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:576) [spigot.jar:git-Spigot-596221b-9a1fc1e]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_171]
    1. drtshock
      Author's Response
      Please use discord or github for support. This isn't an issue tracker.

      I think you just need to delete your xmpp folder though and let it regen the cache.
  12. FlameHero
    FlameHero
    5/5,
    Version: 2.15.0.1
    Use this, not the regular Essentials, it works fine.

    However, I can't seem to get around the kits, the new udpate added a new kits.yml and so now it doesn't give my players a kit on first join.
    [16:33:41 INFO]: [+] hoenest
    [16:33:41 INFO]: [Essentials] Creating empty config: /home/container/plugins/Essentials/userdata/6d9bad17-63aa-4e04-9b0c-56dd10f12561.yml
    [16:33:41 WARN]: [MW] That kit does not exist.
  13. AlexiMaria
    AlexiMaria
    3/5,
    Version: 2.15.0.1
    fix /xp set [TAB] (for player names) not work :(
    -----------------------------------------------------------------
    1. drtshock
      Author's Response
      If you have an issue, please join discord or report on github, not in the reviews ._.
  14. XpcAdam
    XpcAdam
    5/5,
    Version: 2.15.0.1
    THIS IS A MUST HAVE PUGIN FOR EVERY MINECRAFT SERVER. Can't rate it higher unfortunatley
  15. Sitieno14
    Sitieno14
    5/5,
    Version: 2.15.0.1
    Never started a server without Essentials.

    Awesome plugin, thanks a lot for keeping updating it

    Sorry for my bad english, I'm Italian

    Have a nice day,

    Bye, Sitieno14
  16. cguillou
    cguillou
    5/5,
    Version: 2.15.0.1
    Very perfect ! *****************************************************************
  17. JeckTn-Gaming
    JeckTn-Gaming
    5/5,
    Version: 2.15.0.1
    Very Good plugin. but The message file is not good. The author will add it to the file, and can use UTF-8 instead of UTF-16
  18. Bylien
    Bylien
    4/5,
    Version: 2.15.0.1
    Hello! Very nice plugin so far but i have a problem. I opped myself in my server and also i added suggested permissions of essentials from wiki to my group but i can not use " /essentials reload " command , when i used it says " You have no permission to do this. " . What should i do? I tried this essentials reload another essentials versions it worked.
    Is it problem of new update?
    And also is there any updated EssentialsX GroupManager? I'm using EssentialsX GroupManager 2.0.1 that i found from spigot forum.
    I hope you can help me.
    TOTALLY NOTE : Really good work!
  19. dohuuduc
    dohuuduc
    5/5,
    Version: 2.15.0.1
    nice plugins .............................................................................. <3
  20. Roy7885