ExploitGuard 1.5.3

An anti-exploit plugin to fix exploits

  1. EG 1.5.3

    TheMuhammed2188
    Improved:
    • AlreadyIngame check
  2. EG 1.5.2

    TheMuhammed2188
    Fixed:
    • ItemNBT check causing false positives
  3. EG 1.5.1

    TheMuhammed2188
    Fixed:
    • Wrong config version
  4. EG 1.5.0

    TheMuhammed2188
    Added:
    • AlreadyIngame check
    + Renamed "packetlistener" package to "packetlistener_eg"
  5. EG 1.4.1

    TheMuhammed2188
    Fixed:
    • ItemNBT check causing stack traces on 1.9+ versions due to missing null check
    bladbl likes this.
  6. EG 1.4.0

    TheMuhammed2188
    Added:
    • NBT size check
    • Null check for NBTTagCompound
    • Potion amplifier check
  7. EG 1.3.0

    TheMuhammed2188
    Added:
    • Item name length check for ItemNBT module
    • NBT length check for ItemNBT module
  8. EG 1.2.1

    TheMuhammed2188
    Fixed:
    • Player can still use invalid book if it's created before plugin load.
  9. EG 1.2.0

    TheMuhammed2188
    + Combined BookPlace, BookClick and other NBT checks and made it ItemNBT check.
    + Improvements on ItemNBT check
  10. EG 1.1.0

    TheMuhammed2188
    Added:
    • BookClick module
    • Configurable actions section
    Fixed:
    • Comments in config