ExplosiveElytras 0.10.1

High velocity impacts with elytras cause explosions!

  1. TheKraken7
    Native Minecraft Version:
    1.13
    Tested Minecraft Versions:
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    Source Code:
    https://github.com/dscalzi/ExplosiveElytras
    [​IMG]
    Resources
    Wiki | Source | Dev Builds | Issue Tracker
    ExplosiveElytras is a light-weight plugin built using the Spigot API. This plugin causes explosions to occur when a player impacts an object at a high velocity. These explosions only occur if the player has a certain item in their inventory, such as tnt. This plugin is highly configurable, allowing you to customize the conditions which trigger explosions.

    These explosions can only be triggered if a player takes damage. This means that explosions can only occur if a player is in survival mode. Vertical impacts only cause explosions if fall damage is enabled as well.

    A Developer API is provided and actively maintained. More details on this are provided on the wiki.

    This plugin is compatible with Spigot versions 1.9.x, 1.10.x, 1.11.x, 1.12.x, and 1.13.x.

    [​IMG]

    Features
    • Allow high speed elytra collisions to cause explosions.
    • Configure which items a player must have in order to explode on impact.
      • Configure minimum required amounts for each of those items.
      • Choose whether or not the matching required item should be consumed on explosion.
    • Configure the explosion power per required item.
    • Enable/disable an explosion multiplier. If more required items are found in a player's inventory the explosion will be larger.
      • Configurable limit for the maximum explosion power.
    • Configure details about the explosion itself.
      • If blocks should be destroyed.
      • If fire should be spread.
    • Configurable death message when a player dies in an explosive collision.
    • Configurable values for both vertical and horizontal impacts:
      • Set a minimum damage value required to trigger explosions.
    • Enable/disable fireworks on explosion.
    • Metrics by bStats.
    • WorldGuard Integration.
    • Developer API with Maven and Gradle support.
    For more information and details on this plugin, including command usages and permissions, you may consult the wiki page.

    Wiki Contents


    Display Videos




    FAQ


    Where can I find more information about this plugin?
    We keep our wiki page updated to reflect the latest and most useful information about this plugin. If you have further questions don't hesitate to ask the developer.

    How can I report an issue or request a feature?
    You may use our issue tracker to report issues and request new features be added. If you need immediate support you may also try contacting the developer directly.

    [​IMG] Consider also joining our Discord Server.


    Which version should I use?
    You should try to use the version uploaded here on the Spigot page. All versions posted here are considered releases and have undergone extensive testing.
    Dev builds are also provided, however they are usually unstable and not feature complete. Only use these builds if you are interested in testing new versions or if for some reason you need the absolute latest changes.

    Disclaimer for Usage with Protection Plugins

    Some protection/logging plugins may not guard against the BlockExplodeEvent. This is the event which is triggered by explosions in this plugin. If the protection plugin you are using is out of date (no updates in several years), destroyed blocks may not be logged.

    Below is a list of common protection plugins and their status on this.
    • ✓ WorldGuard: Integrated support added. Details:
      • Explosions will not occur if block-tnt is set to true.
      • Explosions will not occur in regions where the tnt flag is set to deny.
      • If block-tnt-block-damage is set to true explosions will still occur but will not damage blocks.
      • You will not blow up in regions where you're not a member unless you have the bypass permission.
      • In the latest WorldGuard versions, the configuration option explosion-flags-block-entity-damage is enabled by default. This will cause ExplosiveElytras to work improperly. Please disable it.
    • ✓ GriefPrevention: Supports this event.
    • CoreProtect: Supported in CoreProtect v2.15.0+. (issue)
    • LogBlock: Supported as of commit defcfee. This is available on the LogBlock build server.
    These are the 4 major plugins that we have tested. If you use another protection plugin please check with us.

    Please consult the wiki file for information on the Developer API.

    View ExplosiveElytras on Dev Bukkit

Recent Reviews

  1. KnifeKat
    KnifeKat
    5/5,
    Version: 0.9.1
    Gotta hand it to you, getting better and better. Nothing feels great other than making a massive explosion to only kill a single person. Explosive destruction at my fingertips to give my players for the simple price in their blood.
  2. KnifeKat
    KnifeKat
    5/5,
    Version: 0.8.0
    I haven't used it but I will give you this rating since it'll be your first one, with motivation to get the updates to it done when your other project is fine. =)

    I appreciate your work and you have a wonderful day!
    1. TheKraken7
      Author's Response
      Thank you! I'll see if I can get back to work on the updates over the next few days :)