eZProtector 4.4.2

Securing your server the easy way!

  1. tomikcz987
    tomikcz987
    5/5,
    Version: 4.2.4
    ---------------------------------+
    ★ ★ ★ ★ ★ +
    ---------------------------------+
  2. DemonMugen
    DemonMugen
    5/5,
    Version: 4.2.2
    It's completely block tab and other leaking. But, can't use tab to call other player name. Help me.
    1. DoNotSpamPls
      Author's Response
      There is no way to differentiate if you're tab completing a name or trying to look at subcommands/plugin names, so I can't really help. Tab completion for player names works outside of a command though :)
  3. minhthanh920
    minhthanh920
    1/5,
    Version: 4.1.6b-ALPHA
    -----------------------------------
    still have old issue
    -----------------------------------
    1. DoNotSpamPls
      Author's Response
      I can't help you without specifying the issue. Also, it's not a good idea to use reviews for support, feel free to DM me, reply in the forum thread or contact us via Discord to get support.
  4. Iso5
    Iso5
    5/5,
    Version: 4.1.6b-ALPHA
    have been using this plugin long time and still does not let me down! totally recommending it to others!
  5. blesk
    blesk
    1/5,
    Version: 4.1.6b-ALPHA
    when i load this plugin it gives me this error :

    [16:20:50] [Server thread/INFO]: [eZProtector] Your server is running version v1_8_R1
    [16:20:50] [Server thread/ERROR]: Could not load 'plugins/eZProtector.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: net/minecraft/server/v1_8_R3/Packet
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:290) [spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:152) [spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:494) [spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_141]
    Caused by: java.lang.NoClassDefFoundError: net/minecraft/server/v1_8_R3/Packet
    at ez.plugins.dan.Extras.Setup.setupEZP(Setup.java:49) ~[?:?]
    at ez.plugins.dan.Main.(Main.java:28) ~[?:?]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_141]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:1.8.0_141]
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.8.0_141]
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_141]
    at java.lang.Class.newInstance(Class.java:442) ~[?:1.8.0_141]
    at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:76) ~[spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    ... 6 more
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_8_R3.Packet
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_141]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_141]
    at ez.plugins.dan.Extras.Setup.setupEZP(Setup.java:49) ~[?:?]
    at ez.plugins.dan.Main.(Main.java:28) ~[?:?]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_141]
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:1.8.0_141]
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.8.0_141]
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_141]
    at java.lang.Class.newInstance(Class.java:442) ~[?:1.8.0_141]
    at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:76) ~[spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigotmc-1.8-R0.1.jar:git-Spigot-59b08be-0899683]
    ... 6 more
    1. DoNotSpamPls
      Author's Response
      Hi there!
      You are using Spigot 1.8.0, which is not supported by eZProtector. If you upgrade your server to version 1.8.8 or newer, it should work. If there are any issues after that, let me know in the plugin forum thread, and not using reviews.
  6. RefexHD
    RefexHD
    5/5,
    Version: 4.1.6b-ALPHA
    Best Plugin! but its every reseting my config
    .
    1. DoNotSpamPls
      Author's Response
      Thanks for the good review! Are you still having config issues though? If yes, feel free to reply to the plugin thread in the forums.
  7. TreesWorld_LP
    TreesWorld_LP
    4/5,
    Version: 4.1.6b-ALPHA
    So i only use this Plugin to Block Schematica which works Perfectly but i dont get notifyed when someone tries to use it here a Part of my Config:
    i know the Issue Tracker is on GitHub but i dont have GitHub and maybe never have it

    schematica:
    block: true
    warning-message: '&cWARN &r&b%player% &cWusste nicht das man Schematica auch Blocken kann'
    punish-command: 'kick %player% &4Vielleicht Morgen lol.'
    1. DoNotSpamPls
      Author's Response
      Schematica is a bit broken, but rest assured - I'm working to fix it ASAP
  8. tomikcz987
    tomikcz987
    3/5,
    Version: 4.1.6b-ALPHA
    spigot 1.9 ERROR
    > [21:40:17 INFO]: [eZProtector] Enabling eZProtector v4.1.6
    > [21:40:17 WARN]: [eZProtector] Your server version is not compatible with eZProtector.
    > [21:40:17 INFO]: [eZProtector] Disabling eZProtector v4.1.6
    > [21:40:17 INFO]: [eZProtector] Plugin disabled.
    PLEASE FIX I NEEED ANTI DMG IDICATOR
    1. DoNotSpamPls
      Author's Response
      You are using an unsupported version of Spigot. The supported versions are 1.7.10, 1.8.8, 1.9.4, 1.10.2, 1.11.2 and 1.12.2. If you upgrade your server to one of those versions, everything should work. If there are any issues after that, let me know in the plugin forum thread, and not using reviews.
  9. RUSVIR
    RUSVIR
    5/5,
    Version: 4.1.6b-ALPHA
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  10. Evan_mcclan
    Evan_mcclan
    3/5,
    Version: 4.1.6b-ALPHA
    PLEASE add a way to block people from joining when they are using MagicLauncher, people are using it as a way to bypass this plugin
    1. DoNotSpamPls
      Author's Response
      MagicLauncher is just a launcher that makes it easier to install other mods. I can't block MagicLauncher by itself, but if you have suggestions for an actual mod to block, let me know (although I can only block it if the developer has implemented a way to do so)
  11. BerryFunChannel
    BerryFunChannel
    5/5,
    Version: 4.1.6b-ALPHA
    VERRRRRRYYYY NIIICCEEE

    Overall like the plugin it helps me hide the plugins. For the guys below saying they have an error, it mustive been fixed or desn't always occur cuz I don't have it...
  12. Lubomircho
    Lubomircho
    4/5,
    Version: 4.1.6b-ALPHA
    [10:30:02] [Server thread/INFO]: [eZProtector] Your server is running version v1_9_R1
    [10:30:02] [Server thread/INFO]: [eZProtector] Enabling eZProtector v4.1.6
    [10:30:02] [Server thread/WARN]: [eZProtector] Your server version is not compatible with eZProtector.
    [10:30:02] [Server thread/INFO]: [eZProtector] Disabling eZProtector v4.1.6
    [10:30:02] [Server thread/INFO]: [eZProtector] Plugin disabled.

    HELP PLEASE
    1. DoNotSpamPls
      Author's Response
      You are using an unsupported version of Spigot. The supported versions are 1.7.10, 1.8.8, 1.9.4, 1.10.2, 1.11.2 and 1.12.2. If you upgrade your server to one of those versions, everything should work. If there are any issues after that, let me know in the plugin forum thread, and not using reviews.
  13. MatsGaming
    MatsGaming
    1/5,
    Version: 4.1.6b-ALPHA
    Also same as BlackHawk2306:
    [WARN] Your server version is not compatible with eZProtector.
    Also running Spigot 1.8.8
    1. DoNotSpamPls
      Author's Response
      You are using an unsupported version of Spigot. The supported versions are 1.7.10, 1.8.8, 1.9.4, 1.10.2, 1.11.2 and 1.12.2. If you upgrade your server to one of those versions, everything should work. If there are any issues after that, let me know in the plugin forum thread, and not using reviews.
  14. YouDoDis
    YouDoDis
    5/5,
    Version: 4.1.6b-ALPHA
    This is a very good plugin! I don't understand why people rate this plugin because of an error. If they are looking for a solution to an error, they should go to the forums or contact the developer. I'm currently having 1 bug and I'll contact you soon. Thanks for the amazing plugin!
  15. Twitchi
    Twitchi
    4/5,
    Version: 4.1.6b-ALPHA
    same as BlackHawk2306


    ------------------------------------------------------------

    :(
    1. DoNotSpamPls
      Author's Response
      Try the latest version - it doesn't have that problem!
  16. xILegend
    xILegend
    3/5,
    Version: 4.1.6b-ALPHA
    Wont work.

    [19:02:52 INFO]: [eZProtector] Enabling eZProtector v4.1.6
    [19:02:52 WARN]: [eZProtector] Your server version is not compatible with eZProtector.
    [19:02:52 INFO]: [eZProtector] Disabling eZProtector v4.1.6
    [19:02:52 INFO]: [eZProtector] Plugin disabled.

    Using latest Spigot 1.8.8 and tacospigot. both says the same... to bad.
    1. DoNotSpamPls
      Author's Response
      Try the latest version - it doesn't have that error anymore :P
  17. IceRush
    IceRush
    5/5,
    Version: 4.1.6b-ALPHA
    Great but can u give me one anticrash plugin for //calc and jigsaw client please bro ?
    1. DoNotSpamPls
      Author's Response
      For //calc you can just negate the permission, and for Jigsaw - it's a hacked client, please read the FAQ for more information on why I can't add it
  18. Tyrelis
    Tyrelis
    5/5,
    Version: 4.1.6b-ALPHA
    This is a very nice plugin and works very well for my server even on version 1.12.2. This is by far one of the most useful plugins on spigotmc. Thanks for helping continue the development of this plugin.
  19. AdrianGamer1048
    AdrianGamer1048
    3/5,
    Version: 4.1.6b-ALPHA
    The plugin did not work on my server, I get an error that I can not identify, or already add ProtocolLib and Vault but it does not work for some strange reason if it works on a survival server 1.10 and 1.8 does not
    1. DoNotSpamPls
      Author's Response
      Try the latest version and let me know how that goes.
  20. MrWonka
    MrWonka
    4/5,
    Version: 4.1.6b-ALPHA
    great plugin that does the work of five diffrent plugins in one. Ignore the negitive reviews by idiots.
    1. DoNotSpamPls
      Author's Response
      Why did you give 4 stars then ;-;