FakeDDOS [1.8 - 1.12] 1.4

A nice little free plugin to troll your friends with /ddos.

  1. Support 1.8 - 1.12

    SpaicyGaming
    • Now FakeDDoS supports all spigot versions from 1.8 to 1.12!
Return to update list...