FBasics - The factions Anti-Glitch plugin 2.1.8

Prevents lots of different kinds of glitches you may come across for factions servers

  1. CorruptedFile_
    CorruptedFile_
    5/5,
    Version: 2.1.8
    this plugin is so great it works really great on my ,minecraft server i love it thank you so much i appreciate you!
  2. Spites44
    Spites44
    1/5,
    Version: 2.1.8
    lot of errors please fix
    -------------------------------------------------------------------
  3. TheN1ck
    TheN1ck
    1/5,
    Version: 2.1.8
    Update a new version. Erros spamming in console with FactionsUUID
    Could not pass event PlayerTeleportEvent to FBasics v2.1.8
    29.04 00:40:56 [Server] INFO java.lang.NoClassDefFoundError: Could not initialize class org.originmc.fbasics.factions.v1_6.FactionsHook$1
    29.04 00:40:56 [Server] INFO at org.originmc.fbasics.factions.v1_6.FactionsHook.hasAccess(FactionsHook.java:40) ~[?:?]
    29.04 00:40:56 [Server] INFO at org.originmc.fbasics.listener.EnderpearlListener.denyEnderpearlFactions(EnderpearlListener.java:75) ~[?:?]
    29.04 00:40:56 [Server] INFO at com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor483.execute(Unknown Source) ~[?:?]
    29.04 00:40:56 [Server] INFO at org.bukkit.plugin.EventExecutor.lambda$create$1(EventExecutor.java:69) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:80) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:66) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:520) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.EntityEnderPearl.a(EntityEnderPearl.java:73) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.EntityProjectile.tick(EntityProjectile.java:160) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.EntityEnderPearl.tick(EntityEnderPearl.java:112) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.World.entityJoinedWorld(World.java:1569) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.World.g(World.java:1536) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.World.tickEntities(World.java:1343) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.WorldServer.tickEntities(WorldServer.java:599) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:1107) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:439) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:940) ~[mypaper.jar:git-Paper-600]
    29.04 00:40:56 [Server] INFO at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:837) ~[mypaper.jar:git-Paper-600]
  4. Zach_Sk
    Zach_Sk
    1/5,
    Version: 2.1.8
    Add support for newer versions I get errors when I put the latest version on my paper 1.9.4 server.
  5. OPMEBeadle
    OPMEBeadle
    3/5,
    Version: 2.1.8
    Theres no enderpearl cooldown for me and i dont know how to contact the developer to fix this.
  6. Fanikz
    Fanikz
    5/5,
    Version: 2.1.8
    Legendary plugin. Yes it does not support latest Minecraft & Factions but it is perfect for the versions it is meant to support and I can't see anywhere on the thread where it would state that it will support latest versions to review it bad.
  7. Firosee
    Firosee
    4/5,
    Version: 2.1.8
    So this plugin is very good. I noticed many people including me having permission issues. Mine was with ./wild. The permission to use it, is not fbasics.wilderness. I added fbasics.user and it let me use wild.
  8. DoubleError
    DoubleError
    5/5,
    Version: 2.1.8
    this plugin is AMAZING been looking for a plugin that blocks 99% of all glitches and bugs and btw to the people who say "/wild" does not work maybe if you read the notes in the config the author left you would understand just change "world:" to the name of your multiverse world you want /wild to work in anyways thanks for the amazing plugin!

    # Worlds that you wish to have wilderness enabled must be listed here.
    wilderness-worlds:
    world:
  9. GAME4PLAY
    GAME4PLAY
    3/5,
    Version: 2.1.8
    [FBasics] Enabling FBasics v2.1.8
    [22:36:53 WARN]: [FBasics] **WARNING**
    [22:36:53 WARN]: [FBasics] Failed to enable Factions integration due to errors.
    [22:36:53 WARN]: [FBasics] This is most likely due to an unsupported version of Factions.
    [22:36:53 WARN]: [FBasics] Defaulting to a non-factions configuration.
    [22:36:53 WARN]: java.lang.ClassNotFoundException: org.originmc.fbasics.factions.v2_13.FactionsHook
    [22:36:53 WARN]: at java.net.URLClassLoader.findClass(Unknown Source)
    [22:36:53 WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101)
    [22:36:53 WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86)
    [22:36:53 WARN]: at java.lang.ClassLoader.loadClass(Unknown Source)
    [22:36:53 WARN]: at java.lang.ClassLoader.loadClass(Unknown Source)
    [22:36:53 WARN]: at java.lang.Class.forName0(Native Method)
    [22:36:53 WARN]: at java.lang.Class.forName(Unknown Source)
    [22:36:53 WARN]: at org.originmc.fbasics.FBasics.integrateFactions(FBasics.java:211)
    [22:36:53 WARN]: at org.originmc.fbasics.FBasics.onEnable(FBasics.java:106)
    [22:36:53 WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321)
    [22:36:53 WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340)
    [22:36:53 WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405)
    [22:36:53 WARN]: at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357)
    [22:36:53 WARN]: at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317)
    [22:36:53 WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414)
    [22:36:53 WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378)
    [22:36:53 WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333)
    [22:36:53 WARN]: at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263)
    [22:36:53 WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525)
    [22:36:53 WARN]: at java.lang.Thread.run(Unknown Source)
  10. Asura_Prism
    Asura_Prism
    5/5,
    Version: 2.1.8
    ======================================================
    Your plugins is very good and blocked many glitchs in my server xD
    *Could using this plugin with MassiveCraft Factions ? <3
    ======================================================
  11. Huntew
    Huntew
    4/5,
    Version: 2.1.8
    Its a good all around plugin that prevents most glitching. When i say most, it does not stop all glitching!
  12. SunnyLo
    SunnyLo
    1/5,
    Version: 2.1.8
    I still can pearl through walls (glass). Please fix this glitch, I am using 1.8.8 spigot
  13. UnProfessional1
    UnProfessional1
    5/5,
    Version: 2.1.8
    Great Plugin Works Fine <3 Thanks for the free plugin! It helps me a lot and I love that this plugin stops glitching in with pearls and bots ext! <3
  14. Evan1215
    Evan1215
    1/5,
    Version: 2.1.8
    Bad plugin /wild only works in worlds name world. I suggest you maybe add that in the next update?
  15. MTM123
    MTM123
    3/5,
    Version: 2.1.8
    I love the features of this plugin. However, I have been getting a lot of problems because of regex not working as it should(even though I tested my regex and tried different variations) also many permissions are not documented so I had to look them up in plugin.yml.
  16. YoulastyFinder1
    YoulastyFinder1
    1/5,
    Version: 2.1.8
    it doesnt allow wilderness in my world and i tried everything.. even the world allowed thing still not there
  17. itzhalo
    itzhalo
    5/5,
    Version: 2.1.8
    Godsent of a plugin. Really was needing this and the plugin delivered with all in one fixes that needed to be addressed!
  18. IEpicDestroyer
    IEpicDestroyer
    2/5,
    Version: 2.1.8
    It's a great plugin and all but it's unable to hook into HCFactions by drkshock which I believe it should be able to...

    [22:35:06] [Server thread/INFO]: [FBasics] Enabling FBasics v2.1.8
    [22:35:06] [Server thread/WARN]: [FBasics] **WARNING**
    [22:35:06] [Server thread/WARN]: [FBasics] Failed to enable Factions integration due to errors.
    [22:35:06] [Server thread/WARN]: [FBasics] This is most likely due to an unsupported version of Factions.
    [22:35:06] [Server thread/WARN]: [FBasics] Defaulting to a non-factions configuration.
    [22:35:06] [Server thread/WARN]: java.lang.ClassNotFoundException: org.originmc.fbasics.factions.vv1_6.FactionsHook
    [22:35:06] [Server thread/WARN]: at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    [22:35:06] [Server thread/WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101)
    [22:35:06] [Server thread/WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86)
    [22:35:06] [Server thread/WARN]: at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    [22:35:06] [Server thread/WARN]: at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    [22:35:06] [Server thread/WARN]: at java.lang.Class.forName0(Native Method)
    [22:35:06] [Server thread/WARN]: at java.lang.Class.forName(Class.java:264)
    [22:35:06] [Server thread/WARN]: at org.originmc.fbasics.FBasics.integrateFactions(FBasics.java:211)
    [22:35:06] [Server thread/WARN]: at org.originmc.fbasics.FBasics.onEnable(FBasics.java:106)
    [22:35:06] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321)
    [22:35:06] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340)
    [22:35:06] [Server thread/WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405)
    [22:35:06] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357)
    [22:35:06] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317)
    [22:35:06] [Server thread/WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414)
    [22:35:06] [Server thread/WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378)
    [22:35:06] [Server thread/WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333)
    [22:35:06] [Server thread/WARN]: at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263)
    [22:35:06] [Server thread/WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525)
    [22:35:06] [Server thread/WARN]: at java.lang.Thread.run(Thread.java:745)

    Please fix it, I got no support in the discussions and I hate to put it in the reviews...
  19. xXMrCubezXx
    xXMrCubezXx
    4/5,
    Version: 2.1.8
    Pretty good except that when I try to use /wild in a different world then world, it says this world does not support wilderness... What am I supposed to do?
  20. PvpPro
    PvpPro
    5/5,
    Version: 2.1.8
    I love the Plugin and Its really Good to use On Server it helps With lots Of bugs and ect.. But i have a Problem when i do /Wild for Normal Players it says You do not have permission to use this command even though i added the permission to the group :( Help?