ForceResourcePack [1.7 | 1.8 | 1.9] 1.1.12

Force players to use a resource pack

  1. inventivetalent
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    This plugin can force players to use a resource pack. If they decline it, you can either specify actions which are denied (chat, interaction, movement, etc.) or you can kick them.

    Depends on ResourcePackApi






    Commands
    /forcerp reload - reloads the configuration (forcerp.reload)
    /forcerp set <player> - sends the resource pack to the specified player (forcerp.set)
    /forcerp setall - sends the resource pack to all online players (forcerp.setall)

    Permissions
    forcerp.deny.bypass - allows you to bypass the action denial
    (Command permissions can be found above)

    Config
    Code (YAML):

    #Link to the resource pack
    link
    : 'http://path/to/resource/pack.zip'
    #Messages
    message
    :
      send
    : '&eAttempting to send you the resource pack...'
      loaded
    : '&eResource pack has been loaded successfully'
      accepted
    : '&eLoading resource pack'
      failed_load
    : '&cFailed to load the resource pack'
      declined
    : '&cPlease accept the resource pack!'
    #Handle a failed download the same way as a denial
    deny_on_fail
    : true
    #Kick players if they deny the resource pack (deny values below will be ignored)
    kick_on_deny
    : false
    #Execute a command if a player denies the resource pack
    command_on_deny
    :
      enabled
    : false
      command
    : "/ban %player%"
    #Log the resource pack results to the console
    console_log
    : true
    #Settings which actions are denied if a player doesn't accept the resource pack
    deny
    :
      message
    : '&cYou can''t do that because you did not accept the resource pack'
      interact
    : false
      interact_entity
    : false
      damage
    : false
      change_world
    : false
      chat
    : false
      build
    : false
      move
    : false
    #Settings when the resource pack is sent
    set_on
    :
      join
    : true
     

    Links





    Please leave a rating if you like this resource.
    Donations to support me or this resource are also very much appreciated.

Recent Updates

  1. 1.10 fix
  2. ResourcePackAPI fix | config fix
  3. Config fix

Recent Reviews

  1. KW2
    KW2
    1/5,
    Version: 1.1.12
    Not functionnal in 1.11.2, it says internal error caused java e.g
    I really need this plugin if I want to go further in my texture pack, please fix this problem. Thank you
    http://pastebin.com/p2WpvJcT
  2. SouTou
    SouTou
    5/5,
    Version: 1.1.12
    Nice plugin , but when players are joining the server , server will go not responding, it's a very serious problem. Can you fix this problem? Or maybe you will need my timings report , i will happy to support that.
  3. galacticwarrior
    galacticwarrior
    5/5,
    Version: 1.1.1
    Great plugin which does exactly what it says. Unlike other plugins, this leaves no false positives or people being able to bypass the resource pack requirement. My only qualm would be people timing out on join, but I realise that is out of the control of plugin author.
  4. RoboMWM
    RoboMWM
    5/5,
    Version: 1.0.2
    Unlike some other plugin I tried, this one actually causes the player to download the resource pack instead of just saying "use custom resource pack" on player join, which could result in using another server's custom resource pack. It also gives a lot of information about the resource pack status in console, which is very nice.
  5. Roissica
    Roissica
    5/5,
    Version: 1.0.2
    very great i waiting that ! i go to try it, i hope to work on my server !
  6. MrRapais
    MrRapais
    5/5,
    Version: 1.0.1
    Muy Bueno, me anda re bien en la version spigot 1.8 e intentado con otros pero este es mas personalizado, cuando pueda donare para que sigas mejorandolo. pero la verdad te pasastes EXELENTE +5
  7. SeniorCluckers
    SeniorCluckers
    1/5,
    Version: 1.0.1
    Terrible Terrible.. The author just ignored me and did not care. This isn't even 1.8 compatible. Thanks for everything though.
  8. Amerikan
    Amerikan
    3/5,
    Version: 1.0.1
    It's a little bit bugged while using it with dynamic textures, should be nice a compatibilty with this plugin, but your plugin is very good!
  9. hsndmrts_
    hsndmrts_
    5/5,
    Version: 1.0.1
    hi, this is great plugin but, its bugy, bug is when ask tex. pack question we can quit esc without kick in server please fixed
  10. ItsWill
    ItsWill
    4/5,
    Version: 1.0.1
    Pretty Good.