GreatKits - [1.7-1.12] - FULL CONFIG - Kits Plugin - Save and load inventory with commands 1.9.5

You an create, change the perms, change the delay easily with cmds.

  1. Kizeko_
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    [​IMG]

    [​IMG]

    GreatKits allows you to easily create and edit kits.
    You are able to change the permission, the cooldown, the contents of the kits and each time with one command !
    You are also able to preview a kit.
    The plugin is fully configurable and it comes with some nice functionnality :p


    [​IMG]
    First, you'll have to create the kit :
    /gk create <kit>
    It will simply create an yml file in the Kits folder inside the dataFolder of the plugin.
    Inside this yml file, you'll find all the ,informations about the kit (Permission, cooldown, contents...)

    /gk remove <kit>
    As you guess, it will delete the kit.
    /gk setinv <kit>
    By typing this command, all your current inventory will be saved in the yml file, ready to be loaded :p
    (The plugin allows you to save equipped armor too)

    /gk setperm <kit> <permission>
    With this command, you can easily change the permission of a kit.
    /gk setdelay <kit> <delay>
    You'll set the new delay of the kit.
    /gk reload

    Reload the configuration of the plugin.
    /kit
    It will display the personalized message the config.yml. Basically, it shows the 3 commands for the player.
    /kit <kit>
    It gives you the kit.
    /kit list
    Display the list of all the kits.
    /kit preview <kit>
    You are able to preview the kit.

    Permissions :

    greatkits.admin
    [​IMG]
    Code (Text):
    ################################################################################################
    #                                                                                               #
    #                                     Copyright Kizeko_                                         #
    #                                      GreatKits 1.0                                            #
    #                                                                                              #
    ################################################################################################

    #Here you can change the lang

    lang:
      design:
        #Change the color of the kit name in /kit preview <kit>
        preview-inv-placeholder: "&e:kitname:"
     
        #Change the color of the commas in /kit list.
        color-commas: "&7"
     
        #If true: The color of the kit in /kit list will change if yes or no they are available.
        auto-color-change: false
     
        #Change the colors of the availables kits.
        auto-color-change-available: "&a"
     
        #Change the colors of the unavailables kits.
        auto-color-change-unavailable: "&c"
     
        #If auto-color-change is false: Change the colors of the kits.
        color-kits: "&6"
     
        #Here you can change the message of /kit.
        list-help:
          - "&7-------------------------------------"
          - "&e/kit &6<name>"
          - "&e/kit list"
          - "&e/kit preview &6<name>"
          - "&7-------------------------------------"
      success:
        #Here you can change the message when you create a kit.
        create: "&eThe kit &9:kitname: &ehas been successfully &acreated"
     
        #Here you can change the message when you remove a kit.
        remove: "&eThe kit &9:kitname: &ehas been successfully &cremoved"
     
        #Here you can change the message when you set the delay of a kit.
        delay-changed: "&eThe delay of the kit &9:kitname: &ehas been changed to : &c:delay:"
     
        #Here you can change the message when you change the permission of a kit.
        perm-changed: "&eThe permission of the kit &9:kitname: &ehas been changed to : &c:perm:"
     
        #Change the message of /kit list ||/!\|| This message is displayed BEFORE the kits.
        kit-list: "&eList of kits:"
     
        #Change the message when you receive a kit.
        kit-received: "&eYou received the kit &9:kitname:"
     
        #Change the message when you set the inventory of a kit
        set-inventory: "&eYou set the inventory of the kit &9:kitname:"
     
        #Reload plugin message
        reload: "&aThe plugin has been successfully reloaded"
      error:
        #Message when you forget to specify the kit.
        specify: "&cYou have to specify the &ename &cof the kit"
     
        #Message when you set too much arguments.
        too-much-args: "&cYou can't set more than &e1 &cargument"
     
        #When you type a wrong command.
        not-found: "&cCommand not found"
     
        #When you try to create a kit who already exists.
        already-exists: "&cThe kit already exists"
     
        #When the kit doesn't exist.
        doesnt-exist: "&cThe kit &e:kitname: &cdoesn't exist"
     
        #When the delay isn't a number.
        number-error: "&cThe delay has to be a number"
     
        #When you forget the delay.
        specify-delay: "&cYou have to specify the &edelay"
     
        #When you forget the permission
        specify-permission: "&cYou have to specify the &epermission"
     
        #When you type /kit list and there are 0 kits.
        no-kit: "&cThere are 0 kits"
     
        #Cooldown message
        cooldown: "&cYou will be able to use the kit in &e:cooldown: &cseconds"
     
        #Permission error message
        permission: "&cYou don't have the permission to do that"
     
        #Here you can change the error message if the items of the kit are null or not set yet.
        item-to-load-null: "&cYou haven't set the &einventory &cof the kit"
     
        #Here you can change the error message when you try to create a kit named "preview" or "list"
        name-error: "&cYou can't use this name"
     
     
       

    Future ADD :
    Option to put different colors according to the availability of the kit

    This plugin will works for 1.7 and 1.8 version, if you are above it won't works (it may works below 1.7)

    If you have any questions, don't hesitate and contact me :)

    If you find any bugs plz report to me :)

    To finish, Sorry for my english x) ...
    QuikMiner, iithum, Roy7885 and 6 others like this.

Recent Updates

  1. FIXED BUGS
  2. Some little fixes
  3. BUG FIXE

Recent Reviews

  1. SladeHazard
    SladeHazard
    3/5,
    Version: 1.9.5
    this used to be my favourite plugin but this plugin dosent save cooldown if i restart the server player can do /kit [name] again without cooldonw!
  2. GuerreroCraft61
    GuerreroCraft61
    1/5,
    Version: 1.9.5
    Very bad support and the you can't give kits to users using commands (it is important for BuyCraft)
  3. valsmidhanc
    valsmidhanc
    5/5,
    Version: 1.9.5
    The plugin is great, i found 0 bugs. Im running PaperSpigot 1.12.2 and it works perfectly. Best regards, zoobros.
  4. FATGUY46
    FATGUY46
    1/5,
    Version: 1.9.5
    It would be a great plugin, but the author has abandoned it and there is 0 support. There are now huge amounts of bugs basically making the plugin unuseable.
  5. Lawhurr
    Lawhurr
    4/5,
    Version: 1.9.5
    I love the plugin, but one problem that I've noticed, and I posted about it in the discussion, is that if you're trying to get a kit that doesn't have anything in the armor slots, and you're currently wearing armor, it will give you the 'internal error occurred' error message in chat. I've bypassed this by simply taking off my armor when I go for the git that I want, but it needs a fix.
  6. CCCCarsten
    CCCCarsten
    1/5,
    Version: 1.9.5
    One star is too much! But I give it, because the developer has a good idea. The support is ZERO. :(
  7. turpo
    turpo
    4/5,
    Version: 1.9.5
    I get error when it do /kit (Name)
    Error: https://pastebin.com/D7WWreP1
    But i like the way how u make the kits so pls help i want to use this plugin
  8. mikka138
    mikka138
    5/5,
    Version: 1.9.5
    The plugin is very good. I just would like to know, how can I make players of a specified group to recieve a specified kit at their first connection?
  9. Gelvin_
    Gelvin_
    3/5,
    Version: 1.9.5
    Good but when previewing kit players can take out kits..
    Please update so they can't.
  10. TDSkitz
    TDSkitz
    5/5,
    Version: 1.9.5
    Best Kits plugin out there! (Much better than Essentials Kits) It has much more functionallity including changing the permissions of the kits.