IronElevators [1.4.6-1.14] 1.5

Stupid-simple elevators!

  1. bryansolis13
    Native Minecraft Version:
    1.14
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    [​IMG]
    IronElevators is based off a plugin I used for a long time. It was a outdated plugin that stopped working in newer verison.

    If updating to IronElveators 1.4 please delete config file for a fresh config.

    As of version 1.3 IronElevators should be compatible with all versions of minecarft. I've tested from 1.14 all the way back to 1.4.6.

    As of now I am updating the plugin to work with all versions of minecraft. I have tested the new version all the way back to 1.4.6.

    The main function for going up and down on IronElevators was done by the original author. Everything added on like support for all versions of minecraft was done by me.

    ORIGINAL POST: http://dev.bukkit.org/bukkit-plugins/ironelevators/

    [​IMG]
    • 1.4.6 - 1.14 Ready and Tested
    • Create an elevator just by placing iron blocks above one another
    • Allows instant vertical travel between aligned iron blocks
    • No commands to make elevator, No signs, No redstone or other required mechanics.
    NEW
    • Create multiple elevators
    • Can change sound for going up or down
    • Cooldowns for elevators
    • Select worlds you want elevators to work in
    [​IMG]
    How to Install

    Drop the jar in your plugins folder
    By default, everyone has the permission to use the plugin


    [​IMG]
    /irreload - reloads the config

    [​IMG]
    Permissions:
    • ironelevators.use | default = true | Allow a player to teleport using this plugin.
    • ironelevators.reload - Allows players to reload config
    • ironelevators.notify - Notify the player when there is a new update
    Note: This permission is true for everyone by default. Use a decremental permission node to take the permission away from certain players. eg. "-ironelevators.use"

    [​IMG]
    How to use

    • Place iron blocks in a vertical line (NO MORE THAN 14 BLOCKS BETWEEN THEM BY DEFAULT)
    • Stand on one
    • Jump to go up to a higher level
    • Crouch to go down to a lower level


    [​IMG]
    Configuration
    Code (Text):
    UpdateMessage: true #Get updates for future releases
    Worlds: #What worlds you want the plugin to work in
    - world
    - world_nether
    - world_the_end
    CoolDownInSeconds: 0 #Cooldown to use the elevator
    Elevators: #You can now add multiple elevators
      IRON_BLOCK:  #Default evelvator
        minElevation: 3 #Minimum blocks for a elevator
        maxElevation: 14 #Maximum blocks for a elevator
        elevatorWhooshUP: IRONGOLEM_ATTACK #Sound when going up a elevator
        elevatorWhooshDOWN: IRONGOLEM_ATTACK #Sound when going down a elevator
      GOLD_BLOCK: #Example second elevator
        minElevation: 3 #Minimum blocks for a elevator
        maxElevation: 50 #Maximum blocks for a elevator
        elevatorWhooshUP: IRONGOLEM_ATTACK #Sound when going up a elevator
        elevatorWhooshDOWN: IRONGOLEM_ATTACK #Sound when going down a elevator

    IMPORTANT!! Please look at spoiler to see how to input your own sounds. Since this is compatible with all versions sounds must be inputted in a certain way
    FULL LIST IN PLUGIN FOLDER

    DOOR_CLOSE("DOOR_CLOSE","BLOCK_WOODEN_DOOR_CLOSE"),

    To use DOOR_CLOSE or BLOCK_WOODEN_DOOR_CLOSE sounds you must put DOOR_CLOSE in config

    FULL LIST IN PLUGIN FOLDER

Recent Updates

  1. Config Changes
  2. Multiple elevators and more
  3. Permission

Recent Reviews

  1. Woodiie
    Woodiie
    5/5,
    Version: 1.5
    Could not have asked for a more simple & straight forward plugin!
    No cluttering features and does exactly what it says.
  2. sand
    sand
    5/5,
    Version: 1.5
    IronElevators is a wonderful and intuitive elevator plugin that I'm sure to install on any server I own or manage. There's not much that you need to explain to players. I use gold blocks on my server for it. Dead simple.
  3. wxys233
    wxys233
    5/5,
    Version: 1.3.1
    Very good plug-in. Could you add a cooling system to the elevator, otherwise it will be easy to jam server
    1. bryansolis13
      Author's Response
      Thank you for the review. I will try and implement that. The upcoming version i am going to release is going to allow for multiple elevators with different heights. But ill try and add your suggestion in the next update. (I have been busy with school but the new update is done and i am just testing for bugs now)
  4. Devee
    Devee
    5/5,
    Version: 1.1
    Great plugin! It works perfectly on 1.12.2! Thank you so much! However, I highly recommend you put all the versions that work into the tested versions - that way people don't feel like they're taking a chance downloading this plugin.
  5. NoLogicGamer
    NoLogicGamer
    5/5,
    Version: 1.1
    Can you update to 1.12.2 ?
    This plugin is very wonderful and useful !
    Farewell long stairs, alive the lifts!
  6. kanarenplastique
    kanarenplastique
    5/5,
    Version: 1.1
    It looks amazing so I rated 5, but it doesn't work on my 1.10 server... I'm so sad :( It doesn't even creates the folder :/
    1. bryansolis13
      Author's Response
      Im sorry to hear that. Maybe try re-downloading it. Ive tested it myself on a 1.10 server and everything worked fine
  7. Ac3dUd3
    Ac3dUd3
    5/5,
    Version: 1.1
    amazing plugin! the best elevator plugin out there and it doesn't use stupid signs! its instant teleportation. amazing work to keep this updated ive always loved it
  8. lavainminecraft
    lavainminecraft
    5/5,
    Version: 1.1
    It's great that it is 1.9.4 but it seems that when I download it and put it in my plugins folder, it doesn't show the jar the config or even in-game
    could you help me maybe even in-game or over a call on skype?
    1. bryansolis13
      Author's Response
      Sure private message me your problem and ill help fix it or your skype
  9. zek2468
    zek2468
    3/5,
    Version: 1.1
    i put it in my server and reload it doesn't start the plugin and when i try to load it with Plug-man it say that file is invalid. I am on 1.9.4 spigot and it doesn't work here's my Server logs if needed

    http://pastebin.com/zd46u7cZ
    1. bryansolis13
      Author's Response
      I compiled the plugin with Java 8. If your on your computer then your not using java 8 or if your using a host they are not using java 8. Ill look into it more if im wrong but that's what i know so far.
  10. lavainminecraft
    lavainminecraft
    5/5,
    Version: 1.0
    Hey, could you update it to 1.9.4 because when I download it and restart my server, nothing happens, I need some help
    1. bryansolis13
      Author's Response
      I updated the plugin to 1.9.4 and tested it. All is working