KitPreview - Display and Buy Essentials kits in a GUI 5.3

Preview Essentials or UltimateCore kits before your purchase or buy them instantly with Vault!

  1. Songoda
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    Contributors:
    Songoda
    [​IMG][​IMG][​IMG][​IMG][​IMG][​IMG][​IMG]
    [​IMG][​IMG]
    [​IMG]
    [​IMG]
    [​IMG] [​IMG]
    [​IMG]
    [​IMG]
    [​IMG][​IMG][​IMG][​IMG]
    [​IMG] [​IMG]
    [​IMG]
    [​IMG] [​IMG][​IMG]
    Premade language files
    Français? - ¿Español? - Português?
    Minecraft EULA Disclaimer
    Selling kits for real-world money is against the Minecraft EULA. If you sell a kit, it must be obtainable with some form of in-game currency that has no value in the real-world. If you would like to charge real-world money for your kits, you must provide ALL users with the ability to access them in-game. If you find yourself in trouble for breaking the Minecraft EULA, I will not be held responsible. Please visit Minecraft EULA for complete details.

    English Tutorial (Build 5.2.7 R3) - Made by Songoda



    Holograms will not work in 1.7
    Official Plugin Compatibility: Spigot 1.7.10, 1.8, 1.9, 1.10, 1.11, 1.12
    AlbertBlue, Gaussz, kiencoi1 and 35 others like this.

Recent Updates

  1. The Most Requested Features
  2. 1.12.1 Compatibility
  3. Bug Fixes

Recent Reviews

  1. GuerreroCraft61
    GuerreroCraft61
    5/5,
    Version: 5.2.7 R3
    Very good plugin, I test a lot of plugin of Kit GUI and this is the best.
    ------
  2. Chrispalm04
    Chrispalm04
    5/5,
    Version: 5.2.7 R3
    Awesome plugin, Brianna! You make incredible plugins and well thought out! :D Keep up the great work!
    1. Songoda
      Author's Response
      Awh you are so sweet I really do try with my plugins, I am super backed up but I have a massive update for EpicSpawners coming out soon :)
  3. daniel659
    daniel659
    5/5,
    Version: 5.2.7 R3
    Its a very cool plugin i like it a lot thx for this plugin

    Keep up the good work :D
  4. xsyasarxs2
    xsyasarxs2
    5/5,
    Version: 5.2.7 R3
    [17:01:29 ERROR]: Could not pass event InventoryClickEvent to KitPreview v5.2.7
    org.bukkit.event.EventException
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja
    va:310) ~[craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    a:62) ~[craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.j
    ava:502) [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    ava:487) [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java
    :1630) [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.PacketPlayInWindowClick.a(SourceFile:31)
    [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.PacketPlayInWindowClick.a(SourceFile:9)
    [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:1
    3) [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [
    ?:1.8.0_144]
    at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_144]
    at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [craftbukki
    t.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:7
    15) [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:3
    74) [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:6
    54) [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java
    :557) [craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_144]
    Caused by: java.lang.NoSuchMethodError: net.ess3.api.IItemDb.serialize(Lorg/bukk
    it/inventory/ItemStack;)Ljava/lang/String;
    at com.songoda.kitpreview.sf9afu0afuas0fjasmerpoweja0eiuad08audas0fuafad
    uya98dayhsaonjenr398rha9f8ayhfas80fsfa0sfafaasfkasjfsdas89dasyd3wnldjhwopij120du
    j80d0ssjd.fasjdfhasds87shcsadfh8eaeaoijada0dusafafafduya98dayhsaonjenr398rha9f8a
    yhfas80fsfa0sfafaduya98dayhsaonjenr398rha9f8ayhfas80fsfa0sfafa.fasjdfhasds87shcs
    adfh8eaeaoijada0dusafafafduya98dayhsaonjenr398rha9f8ayhfas80fsfa0sfafaduya98dayh
    saonjenr398rha9f8ayhfas80fsfa0sfafa(SourceFile:177) ~[?:?]
    at com.songoda.kitpreview.asfkasjfsdas89dasyd3wnldjhwopij120duj80d0ssjda
    sfkasjfsdas89dasyd3wnldjhwopij120duj80d0ssjdaxcxxxa0a9sdusa0duasfsfuas0ffys088fs
    a90s8fsaf.sf9afu0afuas0fjasmerpoweja0eiuad08audas0fuafaduya98dayhsaonjenr398rha9
    f8ayhfas80fsfa0sfafaasfkasjfsdas89dasyd3wnldjhwopij120duj80d0ssjd.duya98dayhsaon
    jenr398rha9f8ayhfas80fsfa0sfafaduya98dayhsaonjenr398rha9f8ayhfas80fsfa0sfafaaxcx
    xxa0a9sdusa0duasfsfuas0ffys088fsa90s8fsaf(SourceFile:521) ~[?:?]
    at com.songoda.kitpreview.duya98dayhsaonjenr398rha9f8ayhfas80fsfa0sfafad
    uya98dayhsaonjenr398rha9f8ayhfas80fsfa0sfafaaxcxxxa0a9sdusa0duasfsfuas0ffys088fs
    a90s8fsaf.asfkasjfsdas89dasyd3wnldjhwopij120duj80d0ssjdasfkasjfsdas89dasyd3wnldj
    hwopij120duj80d0ssjdaxcxxxa0a9sdusa0duasfsfuas0ffys088fsa90s8fsaf.fasjdfhasds87s
    hcsadfh8eaeaoijada0dusafafafduya98dayhsaonjenr398rha9f8ayhfas80fsfa0sfafaduya98d
    ayhsaonjenr398rha9f8ayhfas80fsfa0sfafa(SourceFile:142) ~[?:?]
    at sun.reflect.GeneratedMethodAccessor70.invoke(Unknown Source) ~[?:?]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1
    .8.0_144]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_144]
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja
    va:306) ~[craftbukkit.jar:git-Spigot-e4d4710-e1ebe52]
    ... 15 more

    how can i fix this problem?
    1. Songoda
      Author's Response
      PM me if you need assistance. I'm always here I don't know how you didn't notice the many times on this page where I explain I'm always here to help.
  5. Level5000
    Level5000
    5/5,
    Version: 5.2.7 R3
    A good plugin. I've been looking for a plug-in for kits that supports Essential.
  6. wescvavv7415
    wescvavv7415
    5/5,
    Version: 5.2.7 R3
    -----------------------------------------------------------------
    YEAAAAAAAAAAAAAAAAAAH
    İTS WORKSSSSSS
    VERRRY NİCEEEE MANNNNNNNNN !!!!!!!!!!!
    -----------------------------------------------------------------
    1. Songoda
      Author's Response
      oh x'D Well thanks <3 I try my best :) I hope to update this asap :D
  7. quickgamer
    quickgamer
    5/5,
    Version: 5.2.7 R3
    Amazing plugin!You can create eazy kit crates and the GUI helps is awsome!These is the perfect thing my server needs!Keep up with great work!Thanks!
  8. Rubiks015
    Rubiks015
    5/5,
    Version: 5.2.7 R3
    Fantastic plugin and absolutely amazing prompt support! Easy to use and very configurable. I look forward to additions to this plugin and others made by the Author! Thanks for the great work!
  9. PlayRealRaidzNet
    PlayRealRaidzNet
    5/5,
    Version: 5.2.7 R3
    I rate this plugin a 5 it is amazing although I am having one problem hologram will not pop up and yes I do have hologrpahic displays please HELP
    1. Songoda
      Author's Response
      Thanks for enjoying my plugin, if you have an issue you should message me. Don’t give me 5 stars if you are experiencing issues that’s incorrect.
  10. Benpro23
    Benpro23
    5/5,
    Version: 5.2.7 R3
    -----------------------------------------------------------------------------------------------------
    BEST ESSENTIALS KIT PLUGIN EVER!!!

    This plugin is amazing in every way! It's fast, reliable, does not change my tps at all, and has minimal effect to ram and cpu. Not to mention I was also able to remove KitAdder saving me even more ram, and cpu. KitAdder saved the kits you made into the plugin's storage, but with KitAdder it saves the kits directly to your essentials config.yml making it easier to copy, move, transfer, and share.

    This plugin's developer is kind, helpful, friendly, and supportive. Meaning if you need help with anything you will receive an answer without waiting a really long time. I think the idea of this plugin is very nice, and I am glad I came across it.
    -------------------------------------------------------------------------------------------------------