LANBroadcaster 1.6.2

Broadcasts a Spigot or BungeeCord server over LAN.

  1. Ruan
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    • 1.17
    • 1.18
    Source Code:
    https://gitlab.com/ruany/LANBroadcaster
    serverlist-magic.png

    About
    LANBroadcaster broadcasts your server over LAN, so that clients in the local network can see it when they open their server list.

    Features
    • Supports both Spigot and BungeeCord.
    • Lightweight - does not listen to any events, only runs a single thread on startup. Starts up instantly.
    • Compatible - works with all Minecraft versions that support LAN broadcasting.
    • Works out of the box - no configuration needed!
    Install

    To install, just download the plugin and place it in the plugins folder. (If you have a network, install it to the Bungee plugins folder)

    Nothing else has to be done.

Recent Updates

  1. LANBroadcaster 1.6.2
  2. LANBroadcaster 1.6.1
  3. LANBroadcaster 1.6

Recent Reviews

  1. Gamest23
    Gamest23
    5/5,
    Version: 1.6.2
    Can confirm it works on 1.18.2 with no issues, no extended delay or anything. Just works as intended
  2. Mouton_redstone
    Mouton_redstone
    5/5,
    Version: 1.6.2
    It's a very good plugin, maybe you culd add a customizable server name and color, it's even usable with "online-mode off" servers
    Very useful for LAN parties
  3. Comquister
    Comquister
    4/5,
    Version: 1.6.2
    I think the plugin is very good but I could add the possibility to put rgb and add velocity compatibility
    1. Ruan
      Author's Response
      Color codes should work as-is, but RGB can only work if the client parses it as json, which is unlikely given the age of this protocol.

      Velocity support is planned.
  4. MrMyror
    MrMyror
    5/5,
    Version: 1.6.1
    I mean, you could just put in the server host's internal ip but, this is much cleaner, and is less work. So, very good plugin.
  5. ELROMPEDIENTES
    ELROMPEDIENTES
    5/5,
    Version: 1.6.1
    tanks now I can play in a world with plugins with my family and I am using 1.14.1 is working
  6. jacobvd
    jacobvd
    5/5,
    Version: 1.6.1
    WOW, it actually works!!!
    I downloaded this thinking it might not work BUT IT WORKED!!!!
  7. prodigyrick
    prodigyrick
    5/5,
    Version: 1.6.1
    I have to say, Minecraft finally does what it was suppose to do with this plugin! Very good script. A++
  8. Bolean
    Bolean
    5/5,
    Version: 1.6.1
    Wow is these real srsly are you sure OMG THAT WAS AWESOME AND NICE DUDE THANKS ALLOT hahehahehahaehah
  9. LatePacket
    LatePacket
    5/5,
    Version: 1.6
    I Have Used This Plugin Since 2013 Its One of the most useful plugins out there, thank you for creating this awesome Project!
  10. nebhay
    nebhay
    5/5,
    Version: 1.6
    NiCE!