LightAPI Fork 3.4.6

Plugin support continuation

  1. bottomdumber
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    Source Code:
    https://github.com/Qveshn/LightAPI
    [​IMG]
    Official plugin page: https://www.spigotmc.org/resources/lightapi.4510/
    Author: EvilSpawn (github: BeYkeRYkt)

    This fork is for continuation of plugin LightAPI

    History:
    Originally this fork was as a temporary solution (until the author releases new version). But then, the author retired and offered to continue to support his plugin.
    "There is nothing more permanent than temporary!"
    :)


    All my changes in source code one can find here:
    https://github.com/Qveshn/LightAPI

    Downloads: 1000 :rolleyes:
    Downloads: 2000 :rolleyes:
    Downloads: 3000 :rolleyes:
    Downloads: 6000 :eek:

    Attention! I am going to make API documentation. There will be detailed description and examples. I need help in proofreading the text (I don't know much English). I would be grateful if anyone would help me with this. Write about this in PM or in the discussion section.

    HTML:
        <repositories>
            ...
            <repository>
                <id>sonatype</id>
                <url>https://oss.sonatype.org/content/groups/public/</url>
            </repository>
        </repositories>

        <dependencies>
             ...
            <dependency>
                <groupId>io.github.qveshn</groupId>
                <artifactId>LightAPI-fork</artifactId>
                <version>3.4.6-SNAPSHOT</version>
            </dependency>
        </dependencies>

Recent Updates

  1. Support 1.16.4
  2. Support 1.16.2
  3. Support 1.16

Recent Reviews

  1. FuryMe
    FuryMe
    4/5,
    Version: 3.4.6
    Great plugin.. I simply love it with the exception of spam every single time I log in on my server about the version even though there is no update.
  2. SDpyro
    SDpyro
    4/5,
    Version: 3.4.6
    This plugin does what it says!
    However, PLEASE make the lightapi.updater permission to ONLY SHOW WHEN NEW. Nobody, wants to have extra spam on login. (-1 Star for this)
  3. duckBomb
    duckBomb
    4/5,
    Version: 3.4.5
    works great, could use an config on disabling the -------< LightAPI-fork [version] >------- and using latest version thing as my players were complaining about how its out of place
  4. Luracasmus
    Luracasmus
    5/5,
    Version: 3.4.4
    Very good plugin. Works perfectly with other plugins too! 5 / 5 rating!
    ㅤㅤㅤㅤㅤㅤㅤㅤㅤㅤ
  5. Luracasmus
    Luracasmus
    5/5,
    Version: 3.4.3
    Very good plugin. Works perfectly with other plugins too! 5 / 5 rating!
    Also, please update to 1.16+
  6. chickenmcjesus
    chickenmcjesus
    5/5,
    Version: 3.4.3
    Update to 1.16 please! Fantastic resource! Really useful for developers and absolutely changed my server!
  7. MineKingsHD
    MineKingsHD
    5/5,
    Version: 3.4.3
    Realy nice API and nice to use
    80 caracter limit .................................
  8. Burgil
    Burgil
    5/5,
    Version: 3.4.3
    We are very annoyed with the "You are on the latest version" message every time we log into the server, It's shame we must disable the updates to make it go away
    Thanks for reading
  9. lokka30
    lokka30
    5/5,
    Version: 3.4.2
    Great stuff, thank you for developing the resource.
    Works well for 1.15 and all of the plugins that depend on it.
  10. xuanzhou
    xuanzhou
    5/5,
    Version: 3.4.2
    Good!It's useful for developers and some server.I wanted to mark 50starsbut only 5.May I reposted it to mcbbs.net(The biggest forum of China)?I'll mark the original page and source code page.Look forward.Thanks!