LightAPI Fork 3.2.9

Plugin support continuation

  1. 3.2.9 Support 1.13.2 both new and old builds (including 1.13.1)

    bottomdumber
    :)
  2. 3.2.8 Support 1.13.2

    bottomdumber
    Attention!
    1. LightAPI 3.2.8 is for the latest build of spigot 1.13.2 (git-Spigot-140f654-b446cb5) . Update spigot 1.13.2 to the latest build version!
    2. Now spigot 1.13.1 and old builds of spigot 1.13.2 is not supported. Use version 3.2.7 with them
  3. 3.2.7 Support for 1.13.1 + support for Akarin (a multi-threaded paper fork)

    bottomdumber
    • Added support for 1.13.1
    • Added support for Akarin (a multi-threaded paper fork). Not tested.
  4. 3.2.6 Support for 1.13

    bottomdumber
    Added support for 1.13

    Please edit your config.yml and set updater: repo: to Qveshn/LightAPI
    This is necessary for correct validation of new versions the next time
  5. Fix exception IllegalArgumentException on spigot 1.12.2 server starts

    bottomdumber
    Bug: Sometimes plugin with spigot 1.12.2 throws exception IllegalArgumentException on server starts
    Fix: Workaround with concurrent calls to definePackage in spigot PluginClassLoader (exception IllegalArgumentException during a call to PluginManager.registerEvents)
    Created issue: https://hub.spigotmc.org/jira/browse/SPIGOT-3734

    Edit:
    @md_5 has fixed this bug. If you updated your spigot 1.12.2 to last version then you can skip this LigthAPI version and use...
  6. Fix little bug with chunks update on client side

    bottomdumber
    There was a little bug when create/remove light above 128 y-coordinate. (usually at 193 and above). There was wrong information for client what parts of chunk must be updated.
    I think I fixed it.
    It would be nice if somebody will test this :)