Lite Announcer [Bungee & Spigot] | Server Broadcast | JSON Message Support 1.0.0

Set up your server broadcast! JSON message and PlaceholderAPI support!

  1. TRCRedstoner
    Native Minecraft Version:
    Legacy (< 1.13)
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    Source Code:
    https://github.com/TRCStudioDean/LiteAnnouncer
    Contributors:
    TRCStudioDean
    Languages Supported:
    English, 简体中文
    I don’t speak English, I’m using Google Translate, if you can’t understand what I want to say, I’m sorry.

    Lite
    Announcer


    3-1.jpg

    What is LiteAnnouncer?

    This is a plug-in for automatically playing announcements. It supports BungeeCord and Spigot. You can set the detailed content, broadcast delay, and broadcast conditions of each announcement. It theoretically supports running under all Spigot series, and supports the use of PlaceholderAPI placeholders and JSON messages editor.

    Current Features:
    • Support BungeeCord and Spigot
    • Multi-language support
    • Support delayed announcement
    • Support PlaceholderAPI placeholder
    • Support JSON message editor
    • Support setting broadcast conditions (only players who meet the conditions can see the announcement)
    • Broadcast announcements on asynchronous threads
    • And more...

    Commands:
    • /la help View command help.
    • /la reload Reload configuration files.
    • /la view [Announcement] View the announcement content.
    • /la list List all announcements.
    Images:
    2.png

    1.png

    3.png
    4.jpg

    5.png
    6.png

    How to use?

    • Download the jar file.
    • Put into server's plugins folder.
    • Start server and wait for folder create.
    • Edit Announcement.yml like default configuration file format.
    • When everything is ready, use the command /la reload.
    • Done!

    Ending:
    It is a plug-in I wrote when I was bored (of course...this also contains some other reasons), so I will not take care of this plug-in. If you need help, please submit an issue on GitHub ,Thank you.