MageSpells 2.0.9.1

Delve into the black magics of Minecraft. Create your very own spells!

  1. L2_Envy
    Tested Minecraft Versions:
    • 1.10
    • 1.11
    [​IMG]

    Spoilers:

    Written Tutorial
    Click Me!
    Special thanks to @ch3rry_p0pper for creating this!

    *Requirements*

    In order for this to work, you must have these two plugins installed...
    Title Manager
    Effectlib -- 1.11+
    ParticleAPI -- 1.10​


    (Optional)
    If you want region support, download BOTH of these plugins!
    WorldGuard
    World Edit


    NOTICE:
    Due to the lack of donations :( the free version of this is no longer
    supported. There will now be a newer Paid version to help support the development process! Thank you everyone that has helped this plugin become what it is today!

    Link to Paid version will be place here when it is approved
    LINK


    Terms

    -You are not allowed to decompile this plugin
    -You are not allowed to use my code unless I give permission
    -You are not allowed to sell my plugim
    -By downloading this plugin you are agreeing to these terms.

    Any donations will be accepted. Message me for info on how to donate.
    Thanks! -L2​

    Images

    1. MageSpells.png
    Wei_Boss, Artcore, zThana and 4 others like this.

Recent Reviews

  1. luiscabarcas
    luiscabarcas
    5/5,
    Version: 2.0.9.1
    Hey this plugin seems to be amazing, but I am not savy in yml code. Do you have a template I can see to make my own spells? it is nowhere to be found in the plugin's folder.
  2. TrapSpace
    TrapSpace
    5/5,
    Version: 2.0.8.6
    After one of my server issue finaly i can use the plugin xd and im loving the plugin! such a great magic plugin for your server and the best thing is its easy to use and its not that really hard to create your own spell and wand soo good job to the creator of this plugin ! :^)
  3. Gustavo_Player
    Gustavo_Player
    5/5,
    Version: 2.0.8.6
    Is the "Title Manager" application really necessary?

    And the plugin commands are conflicting with those of "Magic" because they are the same thing!
    1. L2_Envy
      Author's Response
      This and Magic really should not be used together, they are both great but separate magic plugins.
  4. GetTheGun
    GetTheGun
    5/5,
    Version: 2.0.8.6
    Incredible powerful plugin, works like a charm and the dev responds very quickly to issues! 100 characteeeeeeeeeeeeeeeers
    1. L2_Envy
      Author's Response
      Thank you for the review! Glad I could help, and I am very happy you like it!
  5. Trixie
    Trixie
    5/5,
    Version: 2.0.8.5
    LOVE THIS!!!! I have been looking for a simple non lagging wand/spell plugin for a while. So glad I came across this!!! Dev even goes out of his way to help if you have issues or questions! Def recommend!
    1. L2_Envy
      Author's Response
      Im glad we could solve the issues! Hope you enjoy the plugin!
  6. Yasou
    Yasou
    4/5,
    Version: 2.0.8.5
    Very awesome plugin. I used it for my Fables server. I was wondering tho if it was possible to cast spells without wands? Like just select a spell from the GUI and cast it? If not then how could I like add it(or if want to in the future). Besides this, top-notch.
    1. L2_Envy
      Author's Response
      Hopefully soon I plan to make it so spells can be cast via a command, so the best way would to get a GUI that when you click the item, it runs the spell command to be cast. (hopefully in a future update), thanks for the review!
  7. VoltaJack
    VoltaJack
    5/5,
    Version: 2.0.8.3
    I love it and I'm happy to see that it is in developing. There is s chance to change the text message or the text in the Gui?
  8. ThelpixGamer
    ThelpixGamer
    5/5,
    Version: 2.0.8.1
    Really Really Awesome Thnis is what im looking for but can you add 1.8 support because i don't like 1.10 as much
    1. L2_Envy
      Author's Response
      Thank you for the review! Unfortunately I will no longer be able to supply support for 1.8. The reason for this? 1.8 compared to 1.10 is completely different, they changed the sound names, and added in 2 handed options. Covering one mage spells is time consuming as it is. I wish I could, but currently do not have the time to. You are welcome to go back to a 1.8 build.
  9. Ukiyolol1
    Ukiyolol1
    5/5,
    Version: 2.0.8.1
    No words can explain how amazing and awesome this is... just... woooooow!

    ............................
    1. L2_Envy
      Author's Response
      Thank you! I am pleased to hear that you are enjoying it!
  10. MQgamer
    MQgamer
    5/5,
    Version: 2.0.8
    Me before watching the gif : just another simple magic plugin :/
    After watching the gif : this plugin it's the best and it also free! O.o (mind blowing) you should make a plugin like the "heroes" plugin next cuz i'm sure it will be amazzzeeezzzingggggg
    1. L2_Envy
      Author's Response
      Thank you for this kind review! I will look into it for sure!