MessageAnnouncer 1.12.2

JSON message interval announcements with multiple lines and support for tons of placeholders!

  1. clip
    Tested Minecraft Versions:
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    [​IMG]

    [​IMG]

    [​IMG]
    [​IMG]

    Interval auto announcement plugin for JSON messages.

    You can create your JSON messages here: minecraftjson.com

    This plugin hooks into PlaceholderAPI to obtain all of its placeholders which you can use in your JSON messages!

    All messages must be in JSON format or start with the [text] tag or they will not work!

    I will not be adding support to convert your regular text to JSON. Use the site above to generate your text to add to the config if you don't understand it.


    [​IMG]
    Code (Text):

    # MessageAnnouncer v1.6 Main configuration
    announcer_enabled: true
    announcer_random: false
    announce_interval: 120
    interval_announcement_list:
    - one
    - two
    - three
    announcements:
      one:
      - '{"text":"This is announcement one!"}'
      two:
      - '{"text":"This is announcement two!"}'
      three:
      - '{"text":"This is announcement three!"}'
     
    [​IMG]
    [​IMG]

    [​IMG]
    Code (Text):
    permissions:
        messageannouncer.admin:
            description: ability to use /msa commands
            default: op
    Jesen, superZpremium, beez0r and 18 others like this.

Recent Reviews

  1. ZonkedOutZombie
    ZonkedOutZombie
    5/5,
    Version: 1.12.2
    Giving a 5 star because it works well, and due to the fact that people are giving it low ratings because they can't comprehend that a free plugin can't instantly update to new versions
  2. digital_trucker
    digital_trucker
    4/5,
    Version: 1.12.1
    Everything works great in 1.16.3 except the sound that's supposed to play doesn't.
  3. Siuan
    Siuan
    4/5,
    Version: 1.12.1
    Works perfectly until you accidentally put an apostrophe in your JSON message, then your config conveniently gets completely wiped. :)
  4. fallenheart
    fallenheart
    5/5,
    Version: 1.12.1
    works on 1.16.3 :) keep up the good work! great plugin!

    Only request is to add more information in the spigot info. Like what sounds can be used. and other things. :)
  5. xHelyox
    xHelyox
    5/5,
    Version: 1.12.1
    Sii ctm por fin lo actualizaron para la 1.16.2 te amo weon XD, besto plugin rey.
  6. sebastien
    sebastien
    1/5,
    Version: 1.12.0
    Please update the plugin does not work in 1.16.2 (I change my rating once you do)
  7. fra130701
    fra130701
    5/5,
    Version: 1.12.0
    Nice plugin, but need update 1.16.2 pls
    ........................................
  8. Jesen
    Jesen
    5/5,
    Version: 1.12.0
    Good plugin,it works on 1.16.1 but it doesnot work in 1.16.2,please update!!!!!!!!!!!!!!!!
  9. Sicoo
    Sicoo
    4/5,
    Version: 1.12.0
    When i put my servers discord link in MessageAnnouncer config file it doesnt work, message announce on time and everything but links arent clickable
  10. CroaBeast
    CroaBeast
    1/5,
    Version: 1.12.0
    The author needs to update his plugins to the important versions.
    Hope that soon it works for 1.16.2 and the future recoding new versions.