mGuard 1.5

Grief Security

  1. BUHAriGa
    Tested Minecraft Versions:
    • 1.7
    • 1.8
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    Source Code:
    https://github.com/xBuhari/mGuard
    Contributors:
    xBuhariPvP
    Languages Supported:
    Turkish
    mGuard v1.3.0

    Sunucularınız için bir Grief koruması.

    [​IMG]
    • AuthMe desteği bulunmaktadır. Yani eğer sunucunuzda AuthMe varsa , giriş yaptıktan sonra güvenlik kodu girebilirsiniz.​
    • Varsayılan koruma listesinde OP oyuncular olur, bunu istediğiniz gibi düzenleyebilirsiniz.​
    • Güvenlik kodunu girmeden; komut girilemez , sohbete yazı yazılamaz , herhangi bir hareket olayı sağlanamaz.​

    [​IMG]

    Kullanımı:
    • /mguard ekle <player> | Güvenlik listesine oyuncu ekleyebilirsiniz.​
    • /mguard sil <player> | Güvenlik listesinden oyuncu silebilirsiniz.​
    • /mguard liste | Güvenlik listesini gösterir.​
    • /mguard temizle | Güvenlik listesini temizler.​
    • /mguard sifre <sifre> | Güvenlik Kodunu değiştirir.​
    • /mguard reload | Eklentinin ayar dosyasını yeniler.​

    Eğer güvenlik listesindeyseniz , sunucuya girdikten sonra /kullan <şifre> komutunu kullanmalısınız.


    [​IMG]


    • Güvenlik Koduna, 3. taraf kişiler tarafından çalınmaması için şifreleme getirildi.​
    • Güvenlik Kodunu girmeden eşya atma ve alma engellendi.​
    • Güvenlik Kodu artık oyun içinden ayarlanabiliyor. (Bknz: /mguard sifre <sifre>)​

    Şifreleme:

    SHA256: Güvenli!
    SHA1: Güvenli!
    MD5: Güvenli!
    Base64: Güvensiz!

    (Base64 eklememin sebebi, sebebi falan yok sadece zevk.)




    [​IMG]

    Resimler:

    Yetki Olmadığında;
    [​IMG]

    Yanlış Komut Girince;
    [​IMG]

    Doğrulama İstendiğinde;
    [​IMG]
    (Gerisine eklentiyi indirip bakabilirsiniz.)

    Ayar Dosyası:
    Code (YAML):
    ayarlar:
        kullankomut
    : kullan
        sifre
    : '360e46f15f432af83c77017177a759aba8a58519' #Varsayılan şifre: 123456a
        kicksuresi
    : 15
        kickmesaji
    : '&7| &cGüvenlik şifresini girmediniz.'
        sifreleme
    : SHA1

        # Sifreleme Turleri:
        #
        # - SHA256 (Güvenli!)
        # - SHA1 (Güvenli!)
        # - MD5 (Güvenli!)
        # - Base64 (Güvensiz!)
       
    dil
    :
        girismesaj
    : '&7| &cGüvenlik Koruması aktif. /kullan <şifre> yazabilirsiniz.'
        dogrulandiOto
    : '&7&7| &aGüvenlik otomatik olarak doğrulandı! İyi oyunlar.'
        dogrulandi
    : '&7| &aGüvenlik doğrulandı! İyi oyunlar.'
        sifreyanlis
    : '&7| &4Güvenlik doğrulanamadı! Şifre yanlış.'

    [​IMG]

    İndirme Linki:

    SpigotMC

    Kaynak Kodları

    Not!
    AuthMe kullanımı zorunlu değildir. Herhangi bir hatada bana ulaşabilirsiniz.

Recent Updates

  1. new features added
  2. Encryption System was introduced.
  3. Fixed Some Bugs

Recent Reviews

  1. AlperenX3
    AlperenX3
    5/5,
    Version: 1.5
    Güzel bir eklenti sunucumda kullanmayı düşünüyorm eline sağlık.............................
  2. leakage
    leakage
    5/5,
    Version: 1.5
    Adam yapmış abi skript kullanmadan tek seferde basit bir şekilde exploidçilere orta parmak gösterebilirsiniz (nah işareti de olur) Teşekkürler aMguard
    1. BUHAriGa
      Author's Response
      Teşekkür ederim yorumunuz için..
  3. AhmHkn5
    AhmHkn5
    5/5,
    Version: 1.3
    Basit bir şekilde skriptle yapardım derken şifreleme olduğunu görüyorum ve susuyorum. Başarılar.
    1. BUHAriGa
      Author's Response
      Teşekkür ederim yorumunuz için..
  4. Bylien
    Bylien
    5/5,
    Version: 1.3
    Güzel bir eklenti, sunucular "grief"lerin arttığı bugünlerde böyle bir eklentiye ihtiyaç duyuyor.
    Belirlenen şifrenin ya da güvenlik kodunun (adı her neyse) dosya içerisinde şifrelenmesi sayesinde bu config dosyası bir şekilde zararlı kişiler tarafından görülebilse dahi, şifre bulunamayacağından (yüksek ihtimalle kırılamayacağından) eklenti amacına uygun bir hizmet sunacaktır.
    Onun dışında lightweight (hafif) bir eklenti olması, basitleştirilmiş kullanımı da kullanılabilir kılıyor.
    Konfigürasyon seçenekleri arttırılabilir.
    Güzel bir eklenti, öneririm.
    1. BUHAriGa
      Author's Response
      Yorumunuz için teşekkürler.!
  5. maxsimusrap
    maxsimusrap
    5/5,
    Version: 1.3
    Eklenti çıktığı günden buyana tüm sunucularım da kullanıyorum ve bu zamana kadar herhangi bir sorun yaşamadım, başarılar.
    1. BUHAriGa
      Author's Response
      Yorumunuz için teşekkürler.!
  6. woxz
    woxz
    2/5,
    Version: 1.3
    Eklenti bir nevi authme gibi bir sistem, verdiğin şifre sadece rakamlardan oluşuyor. Grief Clientleri bu gibi şeyleri çok basit bir şekilde yok eder
    sadece rakam ile şifreleme yönetmi mantık dışıdır, String ve int eklersen daha mantıklı olurdu böylece isteyenler String i kullanır isteyenler intager ı kullanır boolean sayesinde gayet mantıklı şeyler üretebilirsin,

    2 yıldız vermemin sebebi eklenti çok pasif kalıyor ve her yerde sürekli olarak yapımcı yazısı çıkıyor eğer bir koruma eklentisi yapıyorsan adının her yerde geçmemesi gerek çünki en sonunda seni bulurlar ve önceden yaptığın sistem açıklarından faydalanırlar gerçekden çok eksik bir koruma eklentisi, kusura bakma 2 vermek istemezdim ama bu eklentiye anti grief diyemem
    1. BUHAriGa
      Author's Response
      Eklentinin konusunu okuduğunu hiç düşünmüyorum, teker teker söylediklerine cevap vereceğim;

      - Eklenti bir AuthMe gibi çalışıyor ama AuthMe gibi ağır bir sistem değil sadece basit bir güvenlik koruması.

      - Şifre sadece rakamlardan oluşmuyor, senin belirlediğin şifreyi MD5,SHA1,SHA256 veya BASE64 şifreleme türünde şifreliyor.

      - Eğer Bypass methodunu söylersen fixleyebilirim ama ben bypass edilebileceğini düşünmüyorum.

      - String integer muhabbeti çok saçma, neden böyle bir konu açtın hiç bilmiyorum. String zaten içinde integer, char vb. değerleri barındıran bir değerdir. Ve benim şifreleme sistemim String kullanır, Integer kullanmaz.

      - Her yerde adım geçmiyor, sadece /mguard komutu kullanılınca eğer kişi hatalı komut kullanırsa veya eksik yetkili bir durumda ise çıkıyor. Eklenti ücretsiz bir eklenti ve bence bu gayet normal. Eklenti üzerinden hiç bir ücret kazanmıyorum.

      - Eğer güncellemeleri takip ederseniz hiç bir sıkıntı yaşamazsınız. Piyasada MD5,SHA1,SHA256 şifreleme türlerini kırabilecek insan tanımıyorum.

      Yorumunuz için teşekkürler.!