OldCombatMechanics - Disable 1.9 hit cooldown 1.10.0

Makes combat work like before 1.9, with no weapon cooldown etc.

  1. kernitus
    Tested Minecraft Versions:
    • 1.9
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.14
    • 1.15
    • 1.16
    • 1.17
    Contributors:
    Rayzr522, I-Al-Istannen
    [​IMG]
    [​IMG] [​IMG] [​IMG] [​IMG]

    [​IMG] [​IMG] [​IMG]

    Unlike similar plugins, this plugin focuses on efficiency to not hinder the performance of your server.


    Available features:
    • Master & per-world toggle for each module
    • All modules fully customisable
    • Remove weapon cooldown
    • Setting tool damage as in pre-1.9
    • Make players regenerate like in pre-1.9 & with correct exhaustion
    • Give players a shield while they right click with a sword
    • Have armour be as strong as in pre-1.9
    • Have configurable old potion durations
    • Have configurable old potion effects (strength & weakness)
    • Disable sword sweep attack
    • Option to disable shield crafting
    • Disable off-hand (with white/blacklist)
    • Make shields block 1/2 a heart instead of reduce damage to 33%
    • Configurable general & projectile damage reduction for shields
    • Have arrows not be stopped by shields
    • Re-add snowball, egg & enderpearl knockback
    • Disable player collisions
    • Enchanted golden apple crafting
    • Customisable enchanted & golden apple potion effects
    • Fishing rods knockback and damage like in pre-1.9 (customisable)
    • Automatically add blaze powder to brewing stands
    • Automatically add lapis in enchanting tables
    • Stop usage of elytra
    • Disable random projectile trajectories
    • Disable bow boosting
    • Configure Chorus Fruit properties
    • Old armour durability mechanics
    • Old burn delay when entering fire
    • Configurable gapple & enderpearl cooldown with messages
    • Disable new attack sounds
    • Change invulnerability time in-between attack hits for both players & mobs
    • Make fishing rods go as far as they did in 1.8
    • Replicate 1.8 entity knockback
    • Replicate and configure 1.8 critical hits

    This plugin requires Java 8 or above.

    [​IMG]
    This plugin uses bStats metrics. You can disable it in the bStats plugin folder.

    DISCLAIMER: IF YOU USE REVIEWS OR DISCUSSION FOR REPORTING PROBLEMS OR SUGGESTING FEATURES, YOU WILL BE BRUTALLY IGNORED. GO HERE INSTEAD.
    HexedHero, Dkrieger, reussy and 29 others like this.

Recent Reviews

  1. KidTroid
    KidTroid
    4/5,
    Version: 1.10.0
    The plugin is great but the new version for 1.17 is bugged.

    You don't take damage if you are in full armor...
    (To fix that problem you can set old-armour-strength as false)
  2. kenvn
    kenvn
    5/5,
    Version: 1.10.0
    this is plugins has enabled world and more
    cool
    i likeeeeeeeeeeee this pluginssssssssssssssssssssssssssssssssssssssssss
  3. SenPr
    SenPr
    5/5,
    Version: 1.10.0
    Well made plugin.
    People who complain about this plugin mostly want an exact carbon copy of 1.8 combat.

    This plugin also includes a bunch of other features that you can customize accordingly, not just for no cooldown combat!
  4. HexedHero
    HexedHero
    5/5,
    Version: 1.10.0
    Ignore the 1 star reviews, plugin works perfectly to simulate old combat. Well made and had no issues.
  5. Thurner
    Thurner
    2/5,
    Version: 1.10.0
    It was a great plugin but the latest update doesn't work like as it should, 0 hit delay, please fix!
  6. Nolber
    Nolber
    1/5,
    Version: 1.10.0
    Do not use the latest version of this plugin, it is broken!

    This plugin was the best ever for PvP mods, but now I can't use it, I need to upgrade my server to 1.17 or 1.18 and I can't because the latest version of this plugin doesn't work properly, I can provide more information, however the reception of problems is through github, they should accept the technology and create a discord to listen to the problems, I can't use the latest version of this plugin, it's broken!

    Please fix it, this plugin is pure gold, but the latest version is broken.
  7. andrewkm
    andrewkm
    5/5,
    Version: 1.10.0
    Does exactly what it is designed to do. Constantly updated and developed. Great stuff. Thanks!
  8. User_pt
    User_pt
    1/5,
    Version: 1.10.0
    new update broke it all you can literally kill someone with full netherite armor in 1 second if you use a autoclicker 1.8 pvp doesnt work like that
  9. BenceGamer02
    BenceGamer02
    5/5,
    Version: 1.10.0
    Nagyon jó plugin csak ha görgőzök akkor látszik kicsit a csik, a 1.9 pvp ből. --------------------
  10. jonnycp9
    jonnycp9
    3/5,
    Version: 1.10.0
    camon dude, when you have time, fix this plugin and make good update, i can't use this version, hope for better plugin in the fucture
    https://pastebin.com/xhHyuCTv